Author Topic: subcategory foto doesnt show  (Read 3765 times)

sashasaturn

  • Beginner
  • *
  • Posts: 11
subcategory foto doesnt show
« on: March 11, 2010, 14:36:58 pm »
Hello
VM 1.3 Joomla 1.5.15
Subcategory's image doesn't  shows...
any body can help?


preved medved

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: subcategory foto doesnt show
« Reply #1 on: March 11, 2010, 20:13:15 pm »
Make sure your sub-categories have both FULL and THUMBNAIL image. Category templates show the thumbnail image when listing sub-cats.

sashasaturn

  • Beginner
  • *
  • Posts: 11
Re: subcategory foto doesnt show
« Reply #2 on: March 12, 2010, 08:16:48 am »
subcategory have thumbs and full image assigned but didnt show it
What file is responsible for showing images of subcategory?
preved medved

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: subcategory foto doesnt show
« Reply #3 on: March 12, 2010, 08:46:42 am »
components/com_virtuemart/themes/default/templates/browse/xxxx.php

Where xxxx.php is the assigned category template.

sashasaturn

  • Beginner
  • *
  • Posts: 11
Re: subcategory foto doesnt show
« Reply #4 on: March 12, 2010, 09:26:40 am »
my file is browse1.php
Code: [Select]
<div class="browseProductContainer">
    <div class="browseProductImageContainer">
        <script type="text/javascript">//<![CDATA[
        document.write('<a href="javascript:void window.open(\'<?php echo $product_full_image ?>\', \'win2\', \'status=no,toolbar=no,scrollbars=yes,titlebar=no,menubar=no,resizable=yes,width=<?php echo $full_image_width ?>,height=<?php echo $full_image_height ?>,directories=no,location=no\');">');
        document.write( '<?php echo ps_product::image_tag$product_thumb_image'class="browseProductImage" border="0" title="'.$product_name.'" alt="'.$product_name .'"' ?></a>' );
        //]]>
        </script>
        <noscript>
            <a href="<?php echo $product_full_image ?>" target="_blank" title="<?php echo $product_name ?>">
            <?php echo ps_product::image_tag$product_thumb_image'class="browseProductImage" border="0" title="'.$product_name.'" alt="'.$product_name .'"' ?>
            </a>
        </noscript>
        </div>     
       
        <h4 style="width:100%; class="browseProductTitle"><a title="<?php echo $product_name ?>" href="<?php echo $product_flypage ?>">
            <?php echo $product_type['shyna_shyryna'?><?php echo "/";?><?php echo $product_type['shyna_profile']?><?php echo "/";?><?php echo $product_type['shyna_r']?><?php echo "/";?><?php echo $product_type['shyna_season'?></a>
        </h4>
       
</div>
       
       
preved medved

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: subcategory foto doesnt show
« Reply #5 on: March 12, 2010, 09:34:23 am »
That's nice. I know what the category browse1 page code is :). The question is: is browse1 what you have assigned as your default category page, and is that what each category override is set to.

sashasaturn

  • Beginner
  • *
  • Posts: 11
Re: subcategory foto doesnt show
« Reply #6 on: March 12, 2010, 09:49:04 am »
Yes, browse1 assigned as default
Forrest thanks for helping me...
preved medved

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: subcategory foto doesnt show
« Reply #7 on: March 12, 2010, 09:50:47 am »
How about a link to your site in question.

sashasaturn

  • Beginner
  • *
  • Posts: 11
Re: subcategory foto doesnt show
« Reply #8 on: March 12, 2010, 10:22:48 am »
http://shynomobil.com.ua site in progress
preved medved

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: subcategory foto doesnt show
« Reply #9 on: March 12, 2010, 10:29:11 am »
So I'm a little confused as to WHAT image is not showing for you?

Can you give me link to a specific category page you are referring to and tell me what image is not appearing where?

I was assuming you sub-category thumbnails were not showing, when listing categories... but that is working fine for me.

Is it the HEADER image of a category, when you are in that category, that is not showing for you?

Please be much more specific.

sashasaturn

  • Beginner
  • *
  • Posts: 11
Re: subcategory foto doesnt show
« Reply #10 on: March 12, 2010, 10:40:56 am »
http://shynomobil.com.ua/index.php?option=com_virtuemart&page=shop.browse&category_id=252&Itemid=7
After word  Discoverer A/T and before a text in idea i want to place a image of subcategory
 
preved medved

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: subcategory foto doesnt show
« Reply #11 on: March 12, 2010, 10:57:39 am »
Ah, I see. This is not coded into VM this way.

You can add an image however, but just using the <img src="" /> above your description.

The category image folder for the images you uploaded for each category is:

components/com_virtuemart/shop_image/category/

sashasaturn

  • Beginner
  • *
  • Posts: 11
Re: subcategory foto doesnt show
« Reply #12 on: March 12, 2010, 10:59:54 am »
insert <img src="" /> into browse1?
preved medved

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: subcategory foto doesnt show
« Reply #13 on: March 12, 2010, 11:02:31 am »
NO! Go to VM admin -> Products -> List Categories -> Select Category to edit -> Edit description of each category and add the right image using HTML.

sashasaturn

  • Beginner
  • *
  • Posts: 11
Re: subcategory foto doesnt show
« Reply #14 on: March 12, 2010, 11:06:58 am »
Forrest big thanks to you for help!
preved medved