Author Topic: [SOLVED] after migration, db restore cart images won't display  (Read 1780 times)

bbw

  • Beginner
  • *
  • Posts: 41
  • Wahooo
[SOLVED] after migration, db restore cart images won't display
« on: February 24, 2010, 20:15:19 pm »
After a migration to new server, and a restore of the db my cart images will not display.  I have searched the forum and found a few unanswered posts for problems like this, and found one post about the same problem after an upgrde from 1.1.3 to 1.1.4 but nothing worked or applied to my situation.  My images are in the proper folders on the server, the db fields are calling the correct path name including the "resized/" folder for the thumbs, the dynamic thumbnail resizing is turned on, the image displays on the Images tab when editing in the backend, and when viewing the product detail on the frontend from the product flypage, the image pops up in its full size perfectly when clicked on.  But no thumbs show on the flypage nor on the category browse page in the front end.  Anyone have a clue about this?  It seems to happen everytime I do a db restore in VM but this time there are WAY more products than I can re-edit by hand in the backend.  thanks everyone!

beachy

  • Jr. Member
  • **
  • Posts: 277
  • VirtueMart Version: 2.0.22
Re: after migration, db restore cart images won't display
« Reply #1 on: February 24, 2010, 21:27:13 pm »
Is it possible to have a link to your site to have a look or is it being developed locally?
_______
Joomla 2.5.11 Virtuemart 2.0.22
Apache 2.2.24 PHP 5.4.13
Hosted By RochenHost.com - MVS

bbw

  • Beginner
  • *
  • Posts: 41
  • Wahooo
Re: after migration, db restore cart images won't display
« Reply #2 on: March 01, 2010, 19:06:48 pm »
I had no idea there was a reply to this!  Yes there is a link you can see:  http://www.justkiddingaroundnow.com/dev
thanks for looking!

PRO

  • Global Moderator
  • Super Hero
  • *
  • Posts: 10330
  • VirtueMart Version: 3+
J3.9+ VM 3.4.2
Slowest Page Speed Score (88) (Category)
Fastest Page Speed Score (94-96) (productdetails)

bbw

  • Beginner
  • *
  • Posts: 41
  • Wahooo
Re: after migration, db restore cart images won't display
« Reply #4 on: March 01, 2010, 19:39:44 pm »
thank you for the link to that post - I checked and my virtuemart.cfg.php file was already reflecting the correct location of the site, and turning off and saving and then turning on and saving the dynamic thumbs didn't work either.  I did use Joomlapack to move the site.  But this problem ocurred after a bunch of edits were made to the store, and NO joomlapack backup had been made.  I DID however have a current copy of the sql file from the database and reloaded that - now thumbs won't display even tho they are called correct in the source code of the page, and they do exist on the server in the proper spot...

Just checked server again as I typed this, and noticed that although all the thumbs files were present, all the sizes for them were at 0 (zero) - that's not right of course, so I reloaded all thumbs and they are now appearing.  Thanks for everyone's help!