Author Topic: Custom Attributes  (Read 1470 times)

tgoeltz

  • Beginner
  • *
  • Posts: 11
Custom Attributes
« on: January 08, 2010, 11:40:03 am »
I just installed Joomla/VM a couple of days ago.  I added products that have "color" as an attribute and "name" as a custom attribute. I'm not using child products.

If I just have "color" the item adds to the cart fine. Once I add any custom attributes (in this case "name" I'm getting the "...you have to select a product variant on the detail page" box even though the field is filled in.  

Any help is appreciated.

UPDATE: If the user leaves the "name" field empty they can add it to the cart. Opposite of how it should work.  I believe this is a know bug?

http://dev.virtuemart.net/cb/issue/2750


tgoeltz

  • Beginner
  • *
  • Posts: 11
Re: Custom Attributes
« Reply #1 on: January 09, 2010, 14:16:30 pm »
If this is in fact a known bug, can someone point me to where the following file is located?  I cannot seem to find it to perform the modification listed in the bug report listed in the previous post.

ps_product_attribute.php

Thanks!

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27776
  • Always on vacation
    • Jenkin Hill Internet
Re: Custom Attributes
« Reply #2 on: January 09, 2010, 18:04:51 pm »
It is in /administrator/components/com_virtuemart/classes/
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.4.10335 on Joomla 3.9.19 PHP 7.3.18

tgoeltz

  • Beginner
  • *
  • Posts: 11
Re: Custom Attributes
« Reply #3 on: January 09, 2010, 23:38:44 pm »
Kelvyn:

Thanks!  Found it and fixed it.

Ted