Author Topic: Boost slow product list browse performance  (Read 46578 times)

cworthing

  • Beginner
  • *
  • Posts: 18
Re: Boost slow product list browse performance
« Reply #15 on: February 14, 2010, 16:22:24 pm »
Yes, yes I did.  And this DOES speed it up a TON!  The full images and thumb images I had were already on a hosted site(from our corporation) and they were loading rediculously slow, I just have to actually load the images to my server and do it that way. :( Bummer, no easy way! Thanks djlongy and the above posters!

shawnsi

  • Beginner
  • *
  • Posts: 9
Re: Boost slow product list browse performance
« Reply #16 on: February 19, 2010, 01:23:50 am »
Thank Udo and djlongy for sharing the query improvements! I've been trying to improve the query for quite some time now, but never improved so significantly until made the changes that you've suggested. Thank you so much!

Hope queries will be improved in VM version 1.5. :)

scept1c

  • Guest
Re: Boost slow product list browse performance
« Reply #17 on: February 19, 2010, 09:52:24 am »
the speed has risen significantly, thanks! I just wonder why the default settings are so awfully bad in comparison, is it going to be fixed? :(

powerPT

  • Beginner
  • *
  • Posts: 18
Re: Boost slow product list browse performance
« Reply #18 on: February 20, 2010, 20:47:58 pm »
Your are my god! Amazing hack! I hope that VM team consider some tweak for next version...

beachy

  • Jr. Member
  • **
  • Posts: 277
  • VirtueMart Version: 2.0.22
Re: Boost slow product list browse performance
« Reply #19 on: February 25, 2010, 16:29:14 pm »
Thanks for posting this solution. When I changed it on my site it caused all of the thumbnails to disappear.

Does anyone have any idea why that would be?
_______
Joomla 2.5.11 Virtuemart 2.0.22
Apache 2.2.24 PHP 5.4.13
Hosted By RochenHost.com - MVS

haword

  • Beginner
  • *
  • Posts: 3
Re: Boost slow product list browse performance
« Reply #20 on: February 25, 2010, 20:38:40 pm »
I also thought of this before recently, but made changes a little differently, you can download and check here http://files.mail.ru/UZEUQ6

i change also $count

Hermes

  • Jr. Member
  • **
  • Posts: 73
    • Antimatter-Studios
Re: Boost slow product list browse performance
« Reply #21 on: April 27, 2010, 11:40:10 am »
Thank You very much for this modification. Incredible & Amazing & working perfect in my installation too!!

Deacil

  • Beginner
  • *
  • Posts: 9
Re: Boost slow product list browse performance
« Reply #22 on: April 28, 2010, 19:15:27 pm »
I am not sure what I am doing wrong.  I have searched for the query Udo posted and I cannot find it.  I tried the 2 shop_browse_queries.pnp files posted on this site and neither one have any impact on the speed of pulling up a category.  It takes the same amount of time with and without the new file.

Udo, can you please explain how you made your changes.  I am sure all of the newbies (myself) would greatly appreciate info on where to make the code change.

franzpeter

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 467
    • 2in1-online | Software, Mac, PC, Netzwerk, Drucker, Pad, Display
  • VirtueMart Version: Virtuemart 3.2.6
Re: Boost slow product list browse performance
« Reply #23 on: May 05, 2010, 16:31:42 pm »
Dear Udo and djlongy,

thank you very much for that modification. It does boost the vm shop performance from slow to ultrafast.

callumgilhooly

  • Beginner
  • *
  • Posts: 25
Re: Boost slow product list browse performance
« Reply #24 on: May 13, 2010, 19:19:55 pm »
Brilliant. I'm building a site with around 30,000 products and kept getting time outs and errors on searches. Was tearing my hair out about how to fix this.. Downloaded and used the file above and it's made a great difference. No more errors and results returned quickly.

Many Thanks

Callum

derek webster

  • Jr. Member
  • **
  • Posts: 84
Re: Boost slow product list browse performance
« Reply #25 on: May 25, 2010, 17:42:59 pm »
This should be part of the core - the speed increase was insane - we've got 60,000
with 900+ in some categories. and the page times were 30sec and with this mod the page time wen down to about .5 sec.

Unbelievable
Thanks for this

shinta

  • Beginner
  • *
  • Posts: 6
Re: Boost slow product list browse performance
« Reply #26 on: June 17, 2010, 18:36:22 pm »
@Udo, thank you!  Your hack sped up my page loads from about 1 minute to 0.3 to 0.4 seconds!  I timed the before and after page loads multiple times because I couldn't believe it!  I have about 15,000 products, with 100-200 products in most categories (largest is about 800).  I was so sad when I thought I'd have to give up VM because of the crippling performance, but now I'm extremely happy I can continue using it!

This thread should be stickied imo. :)
Thankfully, this thread was the first google result for "virtuemart slow for large number of products" ;)

bdarlin

  • Beginner
  • *
  • Posts: 1
Re: Boost slow product list browse performance
« Reply #27 on: July 10, 2010, 20:30:27 pm »
I have tried this on my site (~5500 products) but it hasn't appreciably sped up anything.  I've discovered that the culprit is the vmSEF plugin.  I also tried the router.php (manual) plugin.  Both slow the site down to a crawl.  Disabling them brings the types of results others have seen.

Does anybody know a good SEF plugin that doesn't slow the site down so much?

Lylene

  • Jr. Member
  • **
  • Posts: 118
Re: Boost slow product list browse performance
« Reply #28 on: July 12, 2010, 22:18:11 pm »
WHERE (`web_vm_product_category_xref`.`product_id`=`web_vm_product`.`product_id` OR `web_vm_product_category_xref`.`product_id`=`web_vm_product`.`product_parent_id`)

If the statement is replaced with:

WHERE `web_vm_product_category_xref`.`product_id`=`web_vm_product`.`product_id`


I've looked at a shop_browse_queries from vm1.1.3 and it was already as suggested ... does it mean this bad query was an update given with vm1.1.4 ?

kunalvm

  • Beginner
  • *
  • Posts: 10
Re: Boost slow product list browse performance
« Reply #29 on: July 15, 2010, 08:25:04 am »
i am using vm1.1.4..my site used to become very slow after user login..but after making the changes you suggested..its much faster!
thanx :)