Author Topic: No shopper group or permission on registration  (Read 7482 times)

doglatin

  • Beginner
  • *
  • Posts: 6
No shopper group or permission on registration
« on: September 13, 2009, 03:18:05 am »
My VM site is having troubles registering new users.  The registration form completes successfully.  URL looks like this:
.../index.php?option=com_virtuemart&page=shop.registration&Itemid=3&vmcchk=1&Itemid=3

(I don't know what those variables being passed there are BTW)

The user gets created, but only as a Joomla user.  The registration doesn't store the VM user info (address, billing, etc) and doesn't join the default shopper group or have any permissions.

Does anyone know how to fix this?

I've seen a number of unsolved posts on this, and there are even a few that just went up today

http://forum.virtuemart.net/index.php?topic=60014.0
http://forum.virtuemart.net/index.php?topic=59767.0

I didn't post to these as they list slightly different problems, but there seems like a bug or a setting "many" people are missing.

Thanks in advance for any help!

doglatin

  • Beginner
  • *
  • Posts: 6
Re: No shopper group or permission on registration
« Reply #1 on: September 13, 2009, 03:34:51 am »
One more thing I just noticed:

I can not create users in the VM back-end either.  It lets me enter the information, gives a "successful" message, but the user still won't hold the VM user information, shopper group or permissions.

???

solidrock

  • Beginner
  • *
  • Posts: 11
  • Solid Rock Design
    • Solid Rock Design
Re: No shopper group or permission on registration
« Reply #2 on: September 16, 2009, 20:11:46 pm »
Help!  Same prolbem over here ???

I made a domain-transfer and everything worked fine. Then I made a Virtuemart-Upgrade via the Patch-Installer and everything ok. I also deleted all users (being created on the old domain) in the database(-tabels). But now the new users are not stored!?!

Help is greatly apreciated!
.oO Solid Design 4 an unsolid world Oo.

doglatin

  • Beginner
  • *
  • Posts: 6
Re: No shopper group or permission on registration
« Reply #3 on: September 17, 2009, 07:40:29 am »
Solidrock: can you create users in the back-end through the VM interface?

I've also noticed that when I log into the Joomla back end, the first time I click on the VM component, i end up back at the Joomla log in screen, log in again, and then it works fine.  I don't know if that has anything to do with it, but it seems odd.

I'm still stuck with this problem.  Does anyone out there have a fix?

danger89

  • Beginner
  • *
  • Posts: 15
Re: No shopper group or permission on registration
« Reply #4 on: March 15, 2010, 23:36:08 pm »
Same problem!
http://forum.virtuemart.net/index.php?topic=68428.msg226573#msg226573

EDIT:
Ps.
I set just (default) User Registration Type to "Normal Account Creation", without succes  :-[
I think this problem appears to be showing if you use the default register form from Joomla?
And why is "New user activion needed?" in yes (RED)? Why not Green ???

EDIT 2:

http://forum.virtuemart.net/index.php?topic=50954.0

Should I just set ALL modules to none?
Admin -> Components->VirtueMart->Administration->Module list (Show Modules)


Still not solved...


onl

  • Beginner
  • *
  • Posts: 2
Re: No shopper group or permission on registration
« Reply #6 on: January 13, 2011, 15:19:28 pm »
Try downloading and installing the Virtuemart Login Module and use that instead of using the Joomla Login Module. This worked for me.

BotaniaRefresh

  • Beginner
  • *
  • Posts: 9
Re: No shopper group or permission on registration
« Reply #7 on: March 26, 2011, 00:34:41 am »
Where did you download the VM login module?