Author Topic: No Order Confirmation To Admin - The problem persists!!!  (Read 36398 times)

Scar

  • Hero Member
  • *****
  • Posts: 1035
    • J-lux
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #15 on: August 22, 2009, 00:16:34 am »
I've also seen someone who uses it with SMTP Auth: No

Scar

  • Hero Member
  • *****
  • Posts: 1035
    • J-lux
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #16 on: August 22, 2009, 00:23:40 am »
You should probably take a look at this: http://forum.joomla.org/viewtopic.php?f=304&t=268623

There is some interesting posts in that thread.

tcolomb

  • Beginner
  • *
  • Posts: 8
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #17 on: August 25, 2009, 13:22:08 pm »
Finally I did it, it works now. I tried something that was already proposed but that I didn't try because I thought that my configuration was equivalent. Indeed the two following configuration are not equivalent even if in principle it should:

configuration in general configuration that works:
mail server: SMTP server
Adress: name@gmail.com
Name: name
SMTP identification: Yes
SMTP security: none
Port: 25
User: name@gmail.com
Passwd: passwd
Smtp host: ssl://smtp.gmail.com:465

And IT IS NOT EQUIVALENT TO

mail server: SMTP server
Adress: name@gmail.com
Name: name
SMTP identification: Yes
SMTP security: SSL
Port: 465
User: name@gmail.com
Passwd: passwd
Smtp host: smtp.gmail.com


nyktovus

  • Beginner
  • *
  • Posts: 25
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #18 on: September 03, 2009, 00:57:14 am »
i am running VirtueMart 1.1.3 on Joomla 1.5.11
everythings up to date. no install, everything is populated and running great.. i like this alot.

problem is i reached the testing phase and when orders come through i see no emails of the new orders.. but then when "notify customer" is set when changing the status of an order, it SAYS the email was sent to the right email addresses.. but the email never reaches the recipiant.. if it was ever sent at all..

all these responses have helped greatly, i too am working on a vm site that is hosted by godaddy. as is email.
 thanx to kelvn for linking me here.. however the fix he states here (changing shopper_mail to from_mail didnt seem to make any difference.

i get 0 confirmations of orders, no receipts, no admin notifications .. etc. email from joomla itself comes through..

update: if i set my server to phpmail i get the message of "sent message to soandso@whateve.com"
sendmail and smtp both allow massmails to get out, but the order updates say "Could not send a message to soandso@whateve.com ()"

should i just get off godaddy???

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26364
  • Always on vacation
    • Jenkin Hill Internet
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #19 on: September 03, 2009, 09:00:52 am »
sendmail and smtp both allow massmails to get out, but the order updates say "Could not send a message to soandso@whateve.com ()"

Sounds like still being blocked at server level for some reason.

Quote
should i just get off godaddy???

The Joomla! forum has a lot of reports of issues with the GoDaddy system, as does this forum. I use a more expensive host and have never had server issues with Joomla!, VirtueMart or other J! components.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.2 PHP 7.0.25

Testing VM3.2.5.9677 on J!3.8.2

gexplorer

  • Beginner
  • *
  • Posts: 1
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #20 on: September 10, 2009, 13:28:17 pm »
Hi,
   I've been reading this thread for a while and trying everything and I still have the same problem, my joomla site send mails correctly, except for virtuemart, that doesn't work.
   I have Joomla! 1.5.14 Stable and VirtueMart 1.1.3.
My mail configuration is as follows:

mail server: SMTP server
Adress: name@gmail.com
Name: name
SMTP identification: Yes
SMTP security: SSL
Port: 465
User: name@gmail.com
Passwd: passwd
Smtp host: smtp.gmail.com

But still VirtueMart keeps telling me that it's unable to send mails. The page is hosted in my own computer.

┬┐Any ideas?

MikeUK

  • Global Moderator
  • Full Member
  • *
  • Posts: 1344
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #21 on: September 10, 2009, 15:00:02 pm »
How does Joomla send emails from your computer? Anyway, you should probably sort this out after the site is put on a regular server.
Get answers faster:

I can build your online shop, setup or customize Virtuemart or help your existing shop maximize its potential. Email / PM for info

Hellraiser0110

  • Beginner
  • *
  • Posts: 2
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #22 on: October 09, 2009, 08:21:30 am »
Thank so much.
It Worker for me. Joomla! 1.5.14 Stable, VirtueMart 1.1.3
When i using Gmail authenicate and virtuemart cannot send email to customer. after change like that its work fine!!!
Thank again!



Finally I did it, it works now. I tried something that was already proposed but that I didn't try because I thought that my configuration was equivalent. Indeed the two following configuration are not equivalent even if in principle it should:

configuration in general configuration that works:
mail server: SMTP server
Adress: name@gmail.com
Name: name
SMTP identification: Yes
SMTP security: none
Port: 25
User: name@gmail.com
Passwd: passwd
Smtp host: ssl://smtp.gmail.com:465

And IT IS NOT EQUIVALENT TO

mail server: SMTP server
Adress: name@gmail.com
Name: name
SMTP identification: Yes
SMTP security: SSL
Port: 465
User: name@gmail.com
Passwd: passwd
Smtp host: smtp.gmail.com



ihoii

  • Beginner
  • *
  • Posts: 25
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #23 on: October 18, 2009, 17:18:53 pm »
So I looked at all the orders/admin confirmations that NEVER came through. They are for orders with a public email address (Yahoo, Hotmail, MSN)...the customer confirmations go out but the admin confirmation breaks down and does not go out for all orders made with a PUBLIC email address!

I think this issue may be due to the customer email address being used as the FROM address for the email to admin, which is interpreted in some way by the GoDaddy server as an attempt to send spam though your account. Try this:

Around line 2321 in ps_checkout.php find
Code: [Select]
$vendor_mail = vmMail( $shopper_email, $shopper_name, $vendor_email, $vendor_subject, $vendor_mail_Body, $vendor_mail_AltBody, true, null, null, $EmbeddedImages);

change to
Code: [Select]
$vendor_mail = vmMail( $from_email, $shopper_name, $vendor_email, $vendor_subject, $vendor_mail_Body, $vendor_mail_AltBody, true, null, null, $EmbeddedImages);

ie. $shopper_email is changed to $from_email

This puts the site admin as the FROM field so may get around this problem. This does mean that an admin cannot simply reply to the order email, but the customer email address is still shown in the order mail body.

ps_checkout.php is located in /administrator/components/com_virtuemart/classes/

This has solved my problem of receiving the confirmation order.. Thanks

BUT, when an enquiry is made through "Ask a question about this product",  shopper is receiving the confirmation email, and also mail delivery failure and the shop admin doesn't receive the enquiry email ....

Any ideas?

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26364
  • Always on vacation
    • Jenkin Hill Internet
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #24 on: October 18, 2009, 23:35:30 pm »
Try with VirtueMart 1.1.4
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.2 PHP 7.0.25

Testing VM3.2.5.9677 on J!3.8.2

ihoii

  • Beginner
  • *
  • Posts: 25
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #25 on: October 19, 2009, 04:03:49 am »
Try with VirtueMart 1.1.4

I just updated to 1.1.4

The order confirmation email is sent to admin and shooper, but no email is sent to admin when sent through enquiry on "Ask a question about this product", the shopper can receive confirmation email and also Mail delivery failed: returning message to sender.

I searched the forums, some said google aps, but order confirmation is sending safely..why not this about enquiry?

ihoii

  • Beginner
  • *
  • Posts: 25
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #26 on: October 26, 2009, 02:08:45 am »
Any suggestion on this please?

The mail is working fine for orders, but not when someone "ask question about product", I get the "Mail delivery failed: returning message to sender" message.

I updated to latest 1.1.4

Robin Mensinger

  • Beginner
  • *
  • Posts: 28
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #27 on: November 25, 2009, 19:38:35 pm »
I am now having a new problem with email notifications.

Simply put: Some order email notifications come through, and some do not.

For instance, order #18 did not show up in my email notifications, but that same day, I placed an order myself, and the order notification came through.
Today, I had another order come in, but no email notification.
Previous to this week, we have been receiving the orders fine.
No settings have been changed between now and then.

Any help on to what is causing this, would be greatly appreciated!

Thanks :)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26364
  • Always on vacation
    • Jenkin Hill Internet
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #28 on: November 26, 2009, 09:10:46 am »
Check spam filters and maybe ask your host if they changed any mail rules.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.4 on Joomla 3.8.2 PHP 7.0.25

Testing VM3.2.5.9677 on J!3.8.2

luispic

  • Beginner
  • *
  • Posts: 2
Re: No Order Confirmation To Admin - The problem persists!!!
« Reply #29 on: January 16, 2010, 00:38:06 am »
Hi Everyone,

Sorry to bring up again this old thread after such a while... but I'm having the same issue that @ihoii said, and since what @jenkinhill said makes much sense:
Quote
I think this issue may be due to the customer email address being used as the FROM address for the email to admin, which is interpreted in some way by the GoDaddy server as an attempt to send spam though your account. Try this:

Around line 2321 in ps_checkout.php find
Code: [Select]
$vendor_mail = vmMail( $shopper_email, $shopper_name, $vendor_email, $vendor_subject, $vendor_mail_Body, $vendor_mail_AltBody, true, null, null, $EmbeddedImages);

change to
Code: [Select]
$vendor_mail = vmMail( $from_email, $shopper_name, $vendor_email, $vendor_subject, $vendor_mail_Body, $vendor_mail_AltBody, true, null, null, $EmbeddedImages);

ie. $shopper_email is changed to $from_email

This puts the site admin as the FROM field so may get around this problem. This does mean that an admin cannot simply reply to the order email, but the customer email address is still shown in the order mail body.

ps_checkout.php is located in /administrator/components/com_virtuemart/classes/

but why does this happen? it doesn't make much sense that our mail-server sends out email "as the customer" since this is called "spoofing" and it's just not right. Wouldn't it be better to send the mail from the admin account of the website to the same admin account (or other account if easier) with all the details of the inquiry? (customer's email, product and inquiry)

Now, I'm not a coder, I'm just a big fan of building websites with pre-coded stuff like joomla and virtuemart, but who can we talk about this? I mean it isn't a bug but it's just not right, @jenkinhill posted a good way to "fix" the problem on a part of virtuemart but like @ihoii it will happen on the "Ask a question about this product form" because virtuemart is built that way, so what does anyone think? could it be possible to change this part of virtuemart?

I'll read on the coding manual of virtuemart but perhaps someone with more experience can help us out developing a quicker solution?

later!@