Author Topic: Account link won't set to https  (Read 2086 times)

mwenz

  • Jr. Member
  • **
  • Posts: 150
Account link won't set to https
« on: June 08, 2010, 18:18:20 pm »
Hello,

Joomla 1.5.18 (same behavior with .17)
VM 1.14
Joomla seo is on, all 3 settings set to yes.
.htaccess uses rewrite on, rewritebase = /

SEO works fine over the whole site.

HTTPS works with the cart.

However, when one first logs in, the account link will not set to https. A second click on the link will.

I have displayed the secureurl variable in the VM login code so I could view it on the live web site in the login section. The secureurl is correctly set to https before and after login.

But the link initially remains set to http. This is true when all seo settings are turned off.

I hardcoded the https link and that worked on the localhost when developing. That didn't work once I uploaded to my site this morning. Anyway, it isn't a good solution.

Any suggestions?

Thank you, Mike

mwenz

  • Jr. Member
  • **
  • Posts: 150
Re: Account link won't set to https
« Reply #1 on: June 08, 2010, 18:36:46 pm »
A follow up...

I thought it might be helpful if I added the urls.

When hovering over the link, the url is (with my site info temp. removed):

http://.../component/virtuemart/account.html?ssl_redirect=1

When initially clicked upon, the url is appended as:

http://.../index.php?ssl_redirect=1&redirected=1&option=com_virtuemart&Itemid=1

The second click does take one to:

http://.../component/virtuemart/account.html?ssl_redirect=1

thank you, Mike

Forrest

  • Full Member
  • ***
  • Posts: 1972
  • Me and my baby
    • Web Developer
Re: Account link won't set to https
« Reply #2 on: June 10, 2010, 08:02:31 am »
A few solutions to try.

1. Set a link in your Joomla menu to VM account (use paramters to create). Make sure this link is set to force https.

2. Use a redirect plugin for Joomla, whereby you can redirect the http URL to https. There a re a few good ones available on the JED.

3. Check the link (code) on whatever mod you are having this problem. Leverage jRoute and set the SSL parameter to "1". You can learn more about jroute in the Joomla documentation.

mwenz

  • Jr. Member
  • **
  • Posts: 150
Re: Account link won't set to https
« Reply #3 on: June 10, 2010, 15:18:30 pm »
Many thanks, Forest.

I'll check the mod_vm_catmenu... of yours (great hack btw) as it is the only menu leading to vm.

In looking/playing around last night, I think the issue may be related to J seo and router.php

If I leave all the J seo on with router.php in the vm root, I get this behavior *only* with the account link. All else is fine as regards ssl.

If I remove router, all works as expected, including the account link, with the exception of some uglier than they should be seo links.

Again, many thanks. Mike