Author Topic: Still experiencing the "??????????" symbols...  (Read 3376 times)

amphilon

  • Beginner
  • *
  • Posts: 2
Still experiencing the "??????????" symbols...
« on: June 08, 2009, 17:50:10 pm »
Hello guys,

I'm using joomla 1.5.11, VM 1.1.3, and I had followed every step for changing language that you guys had described, but it still shows "??????????" symbols...

I'm trying to use simplified chinese, now the menus and backend of VM are showing chinese correctly, but when I tried to add a category, product name or product description in Chinese and then click "save", all the chinese characters that I just entered are turning into "?????" (question marks), I've checked CHARSET and done <backwardLang>simplified_chinese</backwardLang>, still doesn't work. However, the Joomla itself has no problems at all, it displays chinese that I typed in correctly.

I guess it could still be the encoding issue, but just don't know where else I should look into. Any clues? Thanks in advance.

six gun

  • Jr. Member
  • **
  • Posts: 53
  • Why is coding so difficult sometimes?
    • C60 in olive oil
Re: Still experiencing the "??????????" symbols...
« Reply #1 on: June 09, 2009, 01:37:03 am »
Now simply out of interest I put 世界您好 into the Spanish translation of my Virtuemart shop page.

It came out fine.
I have never put Chinese into a Joomla/Virtuemart site before.
I doubt very much switching between the versions of Chinese script will make any difference - it will come out as ?????????????????? or it will come out as 世界您好.

There is nothing special about my Joomla 1.5.11 site.
It is Joomfish 2.03 and everything else upto date.
The VM is the current version.

Just checked the database - to my surprise this is latin swedish for VM.
I was expecting utf-8 general ci.

Normally I would say make sure that everything is utf-8 right from the start - but there I am with a VM db in latin - swedish.

I am not being much help for you.

amphilon

  • Beginner
  • *
  • Posts: 2
Re: Still experiencing the "??????????" symbols...
« Reply #2 on: June 09, 2009, 05:14:29 am »
OK, problem solved. Here's my story:

I followed every step mentioned in previous discussion to change languages, but the Chinese characters that I keyed in still end up like "????" although the menus and interface showing correct Chinese. So that means it's not the language pack's issue, and I have no problems to show Chinese with Joomla website either, then it should not be Joomla itself.

So I guess it must be something wrong with the character set. since other people in this board do not have my problem and I followed steps as well, then it should not be the page files. the only thing left is database. Because I'm a newbie to Joomla and VM, when I finished install VM, I chose to install sample data, trying to get an rough idea what VM look like, so VM installed sample data automatically into the database with "latin1_swedish_ci" character set!! After I changed them to Chinese character set, everything worked perfectly.

So, to those newbies who would like to use languages other than English (especially Asian languages), DO NOT load sample data while you finish to install VM. However, if you had loaded sample data, then you have to change character sets one by one, no big deal.

(I don't have Joonfish installed.)