Author Topic: Warning: Could NOT create Thumbnail Image! 2009!!!  (Read 2870 times)

sitebuildernow

  • Jr. Member
  • **
  • Posts: 66
    • Coburn Enterprises - "Better Everything"
Warning: Could NOT create Thumbnail Image! 2009!!!
« on: March 29, 2009, 21:23:50 pm »
Hi I have spent at least 3 hours scouring the forums for an updated post about this problem but nothing is solving it. I have vm 1.1.3 running with joomla 1.5.9. I am going crazy with this issue - I need to add ADDTIONAL images to products. I have tried with dynamic resizing on and off, I have checked permissions (all files are 777) I have tried various "patches" NOTHING solve the fact that when I add an additional image using the file manager (as directed) I get this error: Warning: Could NOT create Thumbnail Image!

I am very stressed. Can someone please help?

Thanks
Coburn Enterprises
"Better Everything"
Website Developer / SEO and SEM Expert
Joomla! and Virtuemart (current versions always)

macallf

  • Full Member
  • ***
  • Posts: 2411
    • Mark Callf Design
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #1 on: March 29, 2009, 21:34:29 pm »
Make sure all directories are 755 and all files are 644, never have them at 777!

Make sure /your_site/components is at 755
/your-site/components/com_virtuemart/fetchscript.php is at 644

Also check your servers error log for any permission errors e.g. file/directory writeable by group and correct.
Mark
All of My old mods are now available on my website.
Mark Callf Designs

If you like the work I've done for VM please fell free to Donate

Please Note: I am no longer actively developing or involved with VM development.

sitebuildernow

  • Jr. Member
  • **
  • Posts: 66
    • Coburn Enterprises - "Better Everything"
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #2 on: March 29, 2009, 21:41:27 pm »
Hi Mike, thanks for the input but the only reason I set these files ALL at 777 was to assure this was not a permissions error. I do not leave my files set at 777. As for ownership - if I do a chown on this directory what should I set it as? Thanks,
Harmony
Coburn Enterprises
"Better Everything"
Website Developer / SEO and SEM Expert
Joomla! and Virtuemart (current versions always)

macallf

  • Full Member
  • ***
  • Posts: 2411
    • Mark Callf Design
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #3 on: March 29, 2009, 22:04:42 pm »
chown should be your cpanel login details!

Setting all permissions to 777 can actually cause permissions errors, not always ownership errors
Mark
All of My old mods are now available on my website.
Mark Callf Designs

If you like the work I've done for VM please fell free to Donate

Please Note: I am no longer actively developing or involved with VM development.

sitebuildernow

  • Jr. Member
  • **
  • Posts: 66
    • Coburn Enterprises - "Better Everything"
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #4 on: March 29, 2009, 22:06:47 pm »
Ok, then my chown is correct. I was not aware that 777 could cause permissions errors - learn something every day! Thanks! I'll try messing with these some more.
Harmony
Coburn Enterprises
"Better Everything"
Website Developer / SEO and SEM Expert
Joomla! and Virtuemart (current versions always)

macallf

  • Full Member
  • ***
  • Posts: 2411
    • Mark Callf Design
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #5 on: March 29, 2009, 22:16:54 pm »
check your servers error log, that will show any permission errors. Thats the first thing I check if things don't work as expected
Mark
All of My old mods are now available on my website.
Mark Callf Designs

If you like the work I've done for VM please fell free to Donate

Please Note: I am no longer actively developing or involved with VM development.

sitebuildernow

  • Jr. Member
  • **
  • Posts: 66
    • Coburn Enterprises - "Better Everything"
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #6 on: March 29, 2009, 22:31:43 pm »
this is the only error showing in my log files right after I try to add an image using the image file:
[Sun Mar 29 13:20:16 2009] [error] [client 76.27.252.199] File does not exist: /home/fltcreek/public_html/404.shtml
[Sun Mar 29 13:20:16 2009] [error] [client 76.27.252.199] File does not exist: /home/fltcreek/public_html/2009/templates/js_relevant/images/style3/bullet.gif
Coburn Enterprises
"Better Everything"
Website Developer / SEO and SEM Expert
Joomla! and Virtuemart (current versions always)

sitebuildernow

  • Jr. Member
  • **
  • Posts: 66
    • Coburn Enterprises - "Better Everything"
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #7 on: March 29, 2009, 22:33:32 pm »
I also get this error when deleting an image from the image file but the image gets deleted:
Error: Could not delete the Full Image File.
Coburn Enterprises
"Better Everything"
Website Developer / SEO and SEM Expert
Joomla! and Virtuemart (current versions always)

agrosia

  • Beginner
  • *
  • Posts: 6
Re: Warning: Could NOT create Thumbnail Image! 2009!!!
« Reply #8 on: June 03, 2009, 15:26:26 pm »
I do not see any different on the browse page when setting 755 for the components and com_virtuemart folders. The images folder and subfolders is set to 777.

What else may caused show_image_in_imgtag.php not to work? Is there any workaround to reuse the thumb images which is created during upload?