Author Topic: [3 Issues] debugging error, blank page on add to cart, and within checkout  (Read 3500 times)


  • Beginner
  • *
  • Posts: 29
Heya All,

Hopefull some kind sould reading things in here can shed some light on the issues here!


Joomla 1.5.9
VM 1.1.3 Stable
php version 5.2.8

Issue 1:

I have tried to enable debugging to see if anything comes to light for my checkout/basket issues below.  Ticking the box for logging within the admin screen generates an error in the backend on submit, and in the front end on page loads.
No logfiles get created.

I have tried the following paths


The error text is either:

(for fqdn)
Warning: fopen( [function.fopen]: failed to open stream: HTTP wrapper does not support writeable connections in /data03/jobeky/public_html/administrator/components/com_virtuemart/classes/Log/file.php on line 249


(for directory)
Warning: fopen(/vmlogs) [function.fopen]: failed to open stream: Permission denied in /data03/jobeky/public_html/administrator/components/com_virtuemart/classes/Log/file.php on line 249

For Clarity:

Whilst this appears to be a permissions issue, I am stumped, as I have tried:

  • Permissioning the directory to 777 and 755, with no change in the resulting error messages.
  • I have also confirmed that fopen is available and active with the host (Zen)
  • Searching on 'fopen' and 'error log' seems not to turn up any relevent results on this site!

So can anyone point me in the right direction ?

Issue 2:

The add to cart button from a flypage, adds product to the cart as expected, but then appears to load a blank page (or perhaps no content in the main area ?)

I am posting this in this section, in case this is down to set up, or some options I am unaware of!

Steps to reproduce:

Visit the shop link
Select Cymbals, then Alesis
Select the Cybal pack with a price (Surge Cymbal packs)
Add to cart
voila - blank content area, and product in cart

I would have expected to be taken back to the previous category screen from which I loaded the flypage ?  If that is not the default behaviour, what should I expect ?

For clarity:

  • VM Module loaded on page and active
  • No error in server error logs (such as a 500 error)
  • SEF URL's are not in use
  • Joomla Cache is disabled
  • Same behaviour is seen on standard joomla (rhuk? template)
  • Have disabled the password on the site in case thats effecting permissions
  • Have tried enableing differing shipping methods to see if thats related

You can of course click the show cart link at the botom of the vm_module, but I doubt that loading a blank page, and then having someone click that link is the correct way of setting things up!

Issue 3:

This is of course the major issue that is preventing me from going any further here!

This  might ( I strongly suspect) be related to issue 2 above - however there are some posts on the matter in your payments and checkout subforum, however they dont mention issue 2 above.

When I start the checkout process, the screen loads without difficulty. When I elect to move on to shipping methods, I once more get a blank 'index.php' loaded.

The url for the correctly functioning step 1/4 is:

The url that you are taken to when you access step 2 is:

Please note that 'Checkout: Step 2 of 4' is displayed as the page title.  The main content area however is completely blank!

For clarity:

  • I am not using https yet - this will be enabled and tested once everything works normally
  • Therefore my secure url path is the same as my standard url path
  • Do not go to https is ticked in the backend
  • All the conditions for Issue 2 still apply

Many thanks to anyone who takes the time to read this and provide me with any constructive replies!  I have tried to go out of my way to give you all of the information that you might need to pass comment!

I have a host of styling, and other quesrties as well, but nothing that cant wait untill these 'show stoppers' are resolved!



PS: I am aiming to have the shop elements of the site in place, and fully functioning for Thursday evening - client meeting![/list]


  • Beginner
  • *
  • Posts: 29
Sadly no replies!  Can anyone give me any pointers ? Is my expectation of the default behaviour correct ? Thanks in advance to anyone who takes the time!


  • Beginner
  • *
  • Posts: 3
Hi Martin,

I just came across your post and I am having the same problem as your issue 2. I took a look at your site (Nice) and saw the problem was fixed. Can you please share your solution with me?

Best regards,



  • Beginner
  • *
  • Posts: 35
I'm having the same problem.  Sure would appreciate a fix. 

The struggle continues...