Author Topic: Definitive solution for SH404SEF & Pagination please?  (Read 34680 times)

voycey

  • Beginner
  • *
  • Posts: 36
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #15 on: March 16, 2009, 22:59:55 pm »
Yes - I have tried everything on that thread - if you try and follow it you can see that it becomes convoluted with many contradictions - all we need is a specific solution - preferably step by step.

cristi

  • Beginner
  • *
  • Posts: 17
    • Custom Window Treatments
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #16 on: March 17, 2009, 19:42:44 pm »
I have Joomla 1.5.8, VM 1.1.3 stable and sh404SEF 1.0.16 (Build 222).
What versions do you have?

voycey

  • Beginner
  • *
  • Posts: 36
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #17 on: March 17, 2009, 20:00:34 pm »
Joomla 1.5.8, VM 1.1.2 and SH404SEF 1.0.16(222)

Have not upgraded to 1.1.3 due to a bug it introduced previously - will see if this has been rectified and then update.

Can you confirm that you are able to browse backwards and forwards through the pages using your Solution please Cristi?

mrfoameruk

  • Beginner
  • *
  • Posts: 38
  • UKBeading.co.uk
    • UKBeading
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #18 on: March 17, 2009, 20:37:19 pm »
well i wanted sef and viruemart and tried sh404ef and it was no good because if i had 60 items you could never goto page 2  so absolutly no good for the website.
Ended up going for artio joomsef component and bought the virtuemart plugin. It had problems and needed tinkering but answers were in the faq if you looked. I had to delete something (i think a table) from the database (as sh404 used the same records) and alter one of the components settings, but it works with no pagination problem at all.  Have a problem with https but i don't really need that and that might be because something else is not set correctly, not artio joomsef, who knows?
If you want sef and virtuemart i don't think you have another option but  artio joomsef and paid for plugin for virtuemart.

voycey

  • Beginner
  • *
  • Posts: 36
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #19 on: March 17, 2009, 20:55:00 pm »
SH404SEF is the best SEF extension out there - either way i need the URL's to be the same as the previous site.

voycey

  • Beginner
  • *
  • Posts: 36
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #20 on: March 18, 2009, 15:51:51 pm »
Hi Cristi,

Thankyou for your solution :)

To confirm - Cristi's solution works on VM 1.1.3 and J!1.5.8.

Thanks again :)

cristi

  • Beginner
  • *
  • Posts: 17
    • Custom Window Treatments
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #21 on: March 18, 2009, 23:45:18 pm »
Hi voycey,
Yes, I can browse backwards and forwards through the pages

Freshview

  • Beginner
  • *
  • Posts: 11
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #22 on: April 15, 2009, 13:51:02 pm »
Hi,

I have the same issue with pagination. I have replaced the 1.1.2 version with 1.1.3, but this has not fixed the issue, I still can not go backwards on the pages, is there any other solutions to try?

Regards
Phil

wastedspace

  • Beginner
  • *
  • Posts: 22
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #23 on: May 26, 2009, 22:10:00 pm »
I had the same issue with sh404sef & virtuemart, causing the pagination to go awry. But I can also confirm that cristi's solution worked for me too!

(Joomla 1.5.9 & VM 1.1.3)

jjj2

  • Jr. Member
  • **
  • Posts: 53
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #24 on: June 16, 2009, 17:29:54 pm »
Hi..I use this http://extensions.joomla.org/extensions/extension-specific/virtuemart-extensions/7512/details

Just a router.php file put in virtuemart directory.

But it has a flaw too, the paginaton links causes the breadcrumbs problem.

Rahul B

  • Beginner
  • *
  • Posts: 14
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #25 on: July 06, 2009, 10:57:39 am »
The fix mentioned by Scar worked for me. Thanks Scar for the solution.

nazar2k2

  • Beginner
  • *
  • Posts: 12
    • Hire Joomla Programmer
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #26 on: July 09, 2009, 15:52:08 pm »
Hi To all
I think
It may be a SOBI2 issue with J1.5 compatibility.
It may be a sh404SEF issue with the page navigation.
It may be a Joomla 1.5 issue (that was also discussed).

Thanks
Regards
Nazar
http://www.joomla-web-designer.com
http://www.joomla-web-developer.com


ahurt

  • Beginner
  • *
  • Posts: 6
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #27 on: July 17, 2009, 19:42:20 pm »
the problem is in VM and sh404sef even other sef plgins
the scar solution work for me but... is not practical. (VM 1.1.3 sh404sef 15_1.0.20_Beta_build_237)
the Cristi solution donĀ“t work for me. (look for the first page go on without limit)
thanks


locoman

  • Jr. Member
  • **
  • Posts: 74
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #28 on: August 05, 2009, 15:53:27 pm »
i wrote something like that an siliana pages too.

you set standard display per page to 20 ( i do so) in joomla. this is what virtuemart also do for standard.

in sh404 sef you have to have pagination support enabled (its about somewhere in this thread)

after you go and surf in your pages go back in sh404 sef and try to look for your default number of items to display like Page-1-20.html  where 20 is default number of items to display. you never will find this. your site may work for some hours or days without this but in the end the navigation betweenpages are affected.

why that?

because for the same sef url, sh404 sef wil redirect 2 different nonsef qurrys like:

index.php?option=com_virtuemart&Itemid=64&category_id=14&lang=ro&limit=20&limitstart=0&page=shop.browse 

if you look in there it is a limit=20&limitstratr=0 in the link

if you search for the same sef url you find that another non sef link use the same sef url name

index.php?option=com_virtuemart&Itemid=64&category_id=14&lang=ro&page=shop.browse


click on the sef url name for the one wich have limit=20 in it and change the sef URL to .../Page-1-20.html
the old sef url put in the list af alias (so this link will be saved like user redirect and will not be deleted if you delete your sef urls)

after you have done this, delete all automaticaly created safe urls, 404 not found, joomla cache.

DO NOT DELETE the CUSTOM REDIRECTS

that is. now you cans urf between your pages and even change the number of products to display. all other will be generated automaticalyy only for the default number is this bug.



cauterize

  • Beginner
  • *
  • Posts: 1
Re: Definitive solution for SH404SEF & Pagination please?
« Reply #29 on: August 08, 2009, 23:39:03 pm »
Disclamer: This worked for me, however it might not for you. I am not responsible for messing up your VM setup. BACKUP before trying anything!!

Okay, here is my solution to this problem. Id like to say its based on Cristi's solution, but a step further ;)
My method removes all options for the user and makes every browse pages ALWAYS show 20. The user cant change this, nor can he sort it by price/name or anything. It becomes completely static, however works fien with sh404sef!

Firstly, I HATE the Order By, Display # Products area. This problem was the final straw and I decided to remove these completely. I came to the belief that if your shop is well categorised then you dont need to have sort by options. (Obviously this is debatable, but it works for me!)

Just to breakdown settings etc before we continue.

Im running Joomla 1.5.3 and Virtuemart 1.1.2
I have the latest sh404sef installed, with the virtuemart plugin too.


Step 1: Removing the Order By and Display Forms.

open /components/com_virtuemart/themes/default/templates/browse/includes/browse_orderbyform.tpl.php and Comment out lines 38 to 43.

open /components/com_virtuemart/themes/default/templates/browse/includes/browse_pagenav.tpl.php and Comment out lines 10 to 16.

Step 2: Check the page still works. You should still have Pagination on your browse category, however the drop down boxes should have disappeared. If not, go back a step and check you commented out the right stuff.

Step 3: Setup sh404sef

1. Purge your SEF urls.
2. open the Config and goto the Plugins tab.
3. under Virtuemart, Set Using Items per page drop-down list to YES

Step 4: Creating the urls

The theory behind this is that if you set up the default Page 1 url, the rest will follow this pattern. All of these must be entered manually.

Create a custom sef url using the following Old url.

old url: index.php?option=com_virtuemart&Itemid=1&category_id=33&keyword=&lang=en&limitstart=0&manufacturer_id=0&orderby=product_name&page=shop.browse

Change the Category id (in bold) to your category Id. If you are unsure where this is, open virtuemart category lsit in another window and reference from there)

Set the new url to whatever you need it to be. I suggest you find out what the other Pages have.

new url: parent-category-1/child-category-1/Page-1.html


Step 5: Test it!

Once the urls have been set for all categories, purge your urls and Clear Your Cookies. This is a must as Virtuemart stores cookies on how many products you want per page.
Now remember we have removed the formdrop down box to select this, so from here on your end users cant change it, so it will paginate perfectly.

Load up Page 2, then go back to the new Page 1 url hopefully :)


Hopefully these instructions make sense!
Good luck Virtuemarters!