Author Topic: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.  (Read 10555 times)

dlinstedt

  • Beginner
  • *
  • Posts: 5
VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« on: February 09, 2009, 14:04:42 pm »
I've seen the crashes, and even here - on the demo web-site, it continues to crash using I.E. v7.0.6001 etc..

Here's the environment:
Joomla 1.5.9 - TinyMCE editor
Joomla RAW text extension
Joomla LinkR button extension
Joomla System-Legacy "on" or "off" doesn't matter.
No .htaccess rewrite rules (as plain and simple as possible)
Linux server, PHP 5

1) Go to administration pages
2) Click on VirtueMart - no problem.
3) Click on "Add Vendor" under the vendor menu, no problem - you can add any vendor you want.
4) Expand "product" in the menu on the left
5) click "add new product"

Result: BAM, it explodes.  "object required", which leads me to believe there is a null pointer somewhere that FireFox works with.

I traced the code to line 376: editorArea(....) in product.product_form, when I comment that code out, everything works (I just can't add a product description).

The reason I compared it to Add Vendor, is Add Vendor works, and it has an "editorArea" call that works.  So, I think Add Vendor is "loading something" that "add new product" is not.

I haven't figured out what that is yet, but if anyone can help, I'm sure that we can get this figured out.  It doesn't seem to have anything to do with the javascript, or anything else in the rest of the page.

Cheers,
Dan L

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27478
  • Always on vacation
    • Jenkin Hill Internet
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #1 on: February 09, 2009, 18:40:04 pm »
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10

dlinstedt

  • Beginner
  • *
  • Posts: 5
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #2 on: February 09, 2009, 18:57:49 pm »
Hi Jenkinhill,

Thank-you for your quick response, unfortunately I did try the new javascripts, and I also cleaned up the ext-all.css file so that it is W3C compliant.  Alas, nothing has worked yet.

I even changed the "editor" selection in Joomla to "none" - away from TinyMCE, but this didn't help either.

As soon as I comment out the editorArea(..) call, the page comes up fine, but I can't enter a description.  There has to be something wrong with the launch code (legacy wrapper written) around launching editorArea that's causing this failure.

By the way, using IE7 on the virtuemart.net web-site causes all kinds of "crash failures" too...

Again, when I compared the launch code to New Vendor, New Vendor form works GREAT - with 2 editorArea() calls.  Maybe the product.product_form code has poorly designed DIV codes?

Not sure what's happening, I really need some debugging help here, and it seems I'm not the only one.  ;)
Dan L

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27478
  • Always on vacation
    • Jenkin Hill Internet
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #3 on: February 09, 2009, 23:53:43 pm »
Yes, but you are going to Add Vendor which is labelled as This feature is still in an early ALPHA stadium - which it is. ie not suitable for use as it is partly written and buggy.

This option will be enabled properly in VM1.2 I believe.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10

dlinstedt

  • Beginner
  • *
  • Posts: 5
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #4 on: February 10, 2009, 01:21:46 am »
Ok - I understand about add vendor....

The problem isn't with the Add Vendor page, the original description I posted states exactly where the problem is:

"add new product"  There is a serious error with a null pointer, and it's not in the parameter line, and it's not in the rest of the code.  It's somewhere in the code of editorArea call for product description.

When I comment this one line of code out, the product.product_form works fine.

Please help, I'm at my wits end trying to debug the editorArea call, which looks like it goes to the 1.5 support file.  When I compare the editor Launch code there for joomla 1.5, with JOOMLA's editor launch call, they are way different.  Joomla 1.5.9 launches the editor and returns an instance.  VM's editor launch call launches a new editor object, and returns the object.

This is a serious problem.  Again, this has nothing to do with the add vendor - as I pointed out, add vendor is "WORKING FINE" which to my surprise also contains an editorArea call... this is what is so strange about this bug.

It exists somewhere in the DIV sections or references to the document from within the editor on the product.product_form page.

Please help, I can't solve this on my own.

Thanks,
Dan L
CIO, DataVaultInstitute.com

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27478
  • Always on vacation
    • Jenkin Hill Internet
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #5 on: February 10, 2009, 15:46:36 pm »
I went through your described sequence using FireFox 3.0.5, on Joomla 1.5.9 VirtueMart 1.1.3 and everything works as expected. I do not have (or use) Joomla RAW text extension or Joomla LinkR button extension.

If I don't see the problem on my own test sites then I can see nothing to fix.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10

dlinstedt

  • Beginner
  • *
  • Posts: 5
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #6 on: February 10, 2009, 16:28:40 pm »
I understand your position.  However, please please please, test with internet explorer.  This is part of the title of the post I originally submitted.

I.E. v7.0.6001

I am not the only one whom is having this problem, and as of yet - it remains unsolved.  By the way, if you launch your own web-site (virtuemart.net) and go to the demo section in I.E. you will find all of the problems that plague this shopping cart.

I _was_ set to offer a very generous donation - but that all depended on the responses to this problem that I'm encountering.  Now I'm reconsidering, and searching for an alternative shopping cart, as 90% of my web-site users use Internet Explorer, and they do not use Mozilla - Firefox.

I too tested with Firefox and experienced great success, which is why I mentioned specifically that it is the IE browser that is causing problems.

Now, all of that said; I turned on "show every script error" in IE, and in FireFox I brought up the admin pages, and "showed the error log" - both report numerous problems with the ext-all.css pages and formats, and of course IE reports a ton of NULL objects, missing objects and so on.

I would be more than happy to continue assisting in trying to fix this problem, but I need the developers' help to get after this bug and provide some sort of "fix" or suggested work-around.  Once I know where the problem is occurring, I can replicate the fix to the rest of the "broken pages".

I still believe that this cart is a wonderful effort, and I encourage it to continue it's development, however - until I have a definative answer from you that says you've replicated the problem in IE, I cannot continue to assist in debugging your product.

Thank-you kindly,
Daniel Linstedt
CIO, DataVaultInstitute.com

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27478
  • Always on vacation
    • Jenkin Hill Internet
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #7 on: February 12, 2009, 15:20:01 pm »
No, I cannot replicate the problem using IE7 with J!1.5.9 and VM1.1.3 with the current patches in place. Moving this to Q&T.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10

dlinstedt

  • Beginner
  • *
  • Posts: 5
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #8 on: February 12, 2009, 15:30:27 pm »
I am sorry to hear that you cannot replicate the problem.  As I stated, I turned on "every script error" and went to the virtuemart.net site, and get all kinds of errors popping up.

Don't get me wrong, I think VirtueMart is a wonderful starter project, but I think it's not ready for prime-time.  I have no more time to help you debug this tool, so I've moved to a shopping cart called Magento.  It has a ton more features, and doesn't constantly crash on me.

I will be watching this project, in hopes that someday, the bugs will be fixed and the project will finally grow up, in it's support, in the technical area, and in all of the documentation.

I've viewed the code, and have significant concerns, as it doesn't follow industry best practices of MVC, nor does it seem to follow Object Oriented programming, and it has a number of issues with cross-browser support.

Cheers for now, thank-you though for at least taking a look at the problems.
Daniel Linstedt

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #9 on: February 12, 2009, 21:48:11 pm »
Best of luck to you on your chosen platform.

I will be watching this project, in hopes that someday, the bugs will be fixed and the project will finally grow up, in it's support, in the technical area, and in all of the documentation.

If you would like to see the project mature you have to do more than watching and hoping.

InZane

  • Beginner
  • *
  • Posts: 1
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #10 on: March 12, 2009, 14:45:17 pm »
I have exactly the same problem - works fine with Firefox .. crashes with IE when adding a new product

Running Joomla! 1.5.9 - VirtueMart 1.1.3  (Swedish Language files - Site, Admin & Virtuemart)

eradio

  • Jr. Member
  • **
  • Posts: 76
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #11 on: March 12, 2009, 16:39:40 pm »
I have same issue...Works fine with Firefox but admin control panel crashes in IE 7. Fresh install of Joomla 1.59 and VM 1.13

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #12 on: March 12, 2009, 17:05:43 pm »
Why don't you guys read? See second post of this topic or search.

ruigato

  • Jr. Member
  • **
  • Posts: 71
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #13 on: March 12, 2009, 17:07:48 pm »
same problem here.

HermanH

  • Beginner
  • *
  • Posts: 10
Re: VirtueMart 1.1.3 - Joomla 1.5.9 Crashing in I.E.
« Reply #14 on: April 29, 2009, 10:00:03 am »
Also a crash in back-end at my customers PC. Both IE 6 as IE7 after upgrade.

Use Joomla 1.5.10 + VM 1.1.3 + JoomlaFCK as editor


Difficult to test as I see it only at their computer. Problem may be due to local settings. Elsewhere never seen crashes.

Advised using FF.


HermanH