Author Topic: Product Detail page shows nothing  (Read 2347 times)

BHENRY85

  • Beginner
  • *
  • Posts: 4
Product Detail page shows nothing
« on: January 23, 2009, 20:30:51 pm »
I have recently updated to the newest version of virtuemart (v1.1.2) and when I did I am no longer able to view my products. It stated in the manual that you will have to reconfigure your flypages due to the change in the language or something like that, so I took a mental note of that. I tried using the standard product detail page templates that was packaged in the installation package, but nothing shows up. I would like to make my own flypage like the one that I used to have, but I can't get even the factory ones to show anything for me to base my tweeking off of. The browse pages show up ok, but need some tweeking and the product pages show nothing at all. I have looked through other pages on the forums and nothing has helped so far. My manual installation package didn't contain a folder "/components/com_virtuemart/themes/ja_larix/" for me to paste the product details folder into so I created one and still got nothing. I have created new products and everything trying to get something to work but nothing will. I have been able to get it to show up once or twice during the process of creating a new product by previewing the flypage, but it wont show up like that when I publish it. Can anyone help?

klutzon

  • Jr. Member
  • **
  • Posts: 319
  • Knuckles the Echidna
    • Rage3D
Re: Product Detail page shows nothing
« Reply #1 on: January 24, 2009, 11:34:35 am »
Hi BHENRY85,

We'd need some more information to proceed with this problem.

1) What version of Joomla are you using? Is it the 1.0.x series or the 1.5.x series? And which version of Joomla is it (the latest is 1.5.9)?

2) You mentioned you updated recently to the newest version of VirtueMart. I'm assuming you meant to say 1.1.3, since that came out on Thursday, but are you using 1.1.2 instead? And which version of VM did you update from?

3) Did you have any special extensions installed for VM before you updated?

4) You said "I tried using the standard product detail page templates that was packaged in the installation package, but nothing shows up." What do you mean, nothing shows up? Can you take some screenshots and put them up here so we can get a visual idea of what you're experiencing?

This should be enough information to at least point us in a good direction. Let us know. :)

BHENRY85

  • Beginner
  • *
  • Posts: 4
Re: Product Detail page shows nothing
« Reply #2 on: January 25, 2009, 22:20:25 pm »
Let me start off with the fact that I didn't design my website from the ground up. It was done by my boss's friend who is a professional that had to stop cause he was moving to Germany so I, being the only computer literate person in the office, was forced to take over on all of the things that had to be done to the website. I have done pretty good of locating and modifying the files that had to be modified and adding different products to the website with Virtuemart 1.x version, the exact edition I cannot recall. The site that I refer to is www.sdhomedesigns.com incase anyone would like to research into it.

Answers to your questions:

1) I am using Joomla 1.0.15 and Virtuemart 1.1.2, which at the time was the newest.

2) It is version 1.1.2 that I am using, since I am basically at the begining of the installation process, should I go ahead and update again to Virtuemart v1.1.3 now to keep up?

3) I would not know how to find out if there was special extensions installed or not cause I do not have the knowledge of distinguishing which are extensions and which are not. I do know that there was some modules that were installed to allow some transparent menu features, but other than that I don;t know. If you would like me to look around on my server, then give me a location to start at and I will list everything from there.

4) Under the Administration/Configuration setup, I chose all of the different types of product detail pages and nothing would show up, whether going through the site and trying the view it live or by previewing the flypage for the product when you go to create a new one or edit a old one. The browse pages work fine through out all of the categories. I still need to modify them to not show the page navigation at the top or bottom and some of the colors to match the theme of my sight but they work fine. Here are some screenshots of my product page.

http://www.sdhomedesigns.com/screenshot.jpg

I would like to also update to the newest edition of joomla but I am afraid of the thought of having so many problems like I am having with Virtuemart. It starts asking for MySQL files and host names and stuff and I am like "?What?"

Nirm

  • Contributing Developer
  • Full Member
  • *
  • Posts: 919
    • Me, My Work and I
Re: Product Detail page shows nothing
« Reply #3 on: January 26, 2009, 08:32:33 am »
i didn't know that vm 1.1.2 was compatible with joomla 1.0.15!

Quote
My manual installation package didn't contain a folder "/components/com_virtuemart/themes/ja_larix/" for me to...

ja_larix is not a default theme supplied by VM. It is supplied by Joomlart.com
Quote
paste the product details folder into so I created one and still got nothing

what do you mean by the above

would it very difficult to start over with the latest joomla and vm package (the vm site has one bundled together)
A lot of questions are answered in the VM 1.1 User Manual please read it before asking questions.
-------------------------------------
http://www.nirmoysomaia.com

BHENRY85

  • Beginner
  • *
  • Posts: 4
Re: Product Detail page shows nothing
« Reply #4 on: January 26, 2009, 16:20:22 pm »
Well you see, I thought of doing that I have tried a few times, but I as I stated before, I am not a web designer so I am learning all of the required knowledge on the fly and from forums, tutorials, and a friend who has a little more knowledge than me. I am a residential home designer forced into web design by my boss who had no one capable of grasping the concept. I find it intriguing so I stick with it and do what he needs me to do here and there. So far it hasn't been a problem using the older versions of joomla and virtuemart that was setup by someone else to create, add, and modify what I needed. I have learned the structure and locations of all the main system files through tinkering around and trial n' error.

I have installed the newest versions of both, joomla v1.5.9 and virtuemart 1.1.2, through the e-commerce edition. Before hand, I installed the migrator and created the MySQL file but got stuck when It started asking me for the database location and stuff like that. But all of that is for a different forum.

Either or I got stuck. So I decided to migrate to the newest virtuemart and that's where I am at now. If it is not compatible for the two versions of joomla and virtuemart that I have, then I will gladly go hit the Joomla forum up for help to try and get the problem solved there. So should I?

klutzon

  • Jr. Member
  • **
  • Posts: 319
  • Knuckles the Echidna
    • Rage3D
Re: Product Detail page shows nothing
« Reply #5 on: January 26, 2009, 18:16:33 pm »
BHENRY895,

I'd really like you help you out, but I think I need a visual representation to tell me what's going on. Can you post some screenshots of what you're experiencing?

(I'm going to be modifying my own template files tomorrow and the day after, so I will try to replicate the problem that you and others are having, in the hope of finding out what causes it and how to rectify. :) )

BHENRY85

  • Beginner
  • *
  • Posts: 4
Re: Product Detail page shows nothing
« Reply #6 on: January 26, 2009, 21:44:37 pm »
I have a link below of what my product page displays whenever a product is selected and also my browse pages just in case you would like to see how they looking. Just imagine a product page with everything but the product details and description. It shows the menus, headers, footers, etc. properly (cause those are not the items affected by a flypage template right?) It's just showing nothing in the product section. The boss is a little aggrivated that it has taking me a week to problem solve the issues that are persisting so I had to revert to the previous installation of joomla and virtuemart to regain functionality of the site but if you would like to try and problem solve with a live site, I can revert it back and forth between the different versions that I have if you want. It just may be like someone mentioned earlier that it is the old version of joomla that I have not meshing well with the new version of virtuemart that I had installed. I am in the process of migrating to the newest of both versions in my free time this afternoon so If I do and the problem corrects itself due to this I will keep you posted. And Thanks a lot for all of your help with my problems.

http://www.sdhomedesigns.com/screenshot.jpg
http://www.sdhomedesigns.com/screenshot2.jpg
http://www.sdhomedesigns.com/screenshot3.jpg