Author Topic: (solved) Vendor and Manufacturer links  (Read 2654 times)

JCarnley

  • Beginner
  • *
  • Posts: 12
(solved) Vendor and Manufacturer links
« on: December 23, 2008, 06:16:18 am »
[solved] Sorry I posted this feel like I'm going crazy.  I must have been up too late.  Anyway the flypages do indeed have the links and for both manufacturer and vendor.  I did notice that some check the config and some don't, I think I was using a flypage that didn't check.  What's more I was using an FTP to overwrite the files after deleting these links for whatever reason it must not have been overwriting.  Today I just used NinjaXplorer to edit and that did the trick.  Sorry for any confusion.


I have these turned of in the admin>config>site>config.  Yet they persist.  I deleted them from they flypages and they still persist.  I'm at a loss. What is generating these links?  Why don't they turn off with the config link under site?  I even checked the config file it was right.  I matched up the default templates with the ones for the categories.  I'm not sure where to go from here.

Did some more checking.  I have an old VM site that I am updating.  The old site doesn't seem to have a place to turn off these links.  The site I'm working on displays these links even though I have them set for off.  So out of four VM sites I have live or under development all four have these links and I can't make them go away.  Has anyone ever had success with removing them?

JCarnley

  • Beginner
  • *
  • Posts: 12
Re: (solved) Vendor and Manufacturer links
« Reply #1 on: February 20, 2009, 15:13:32 pm »
Hi I was asked by PM to repost here and give further explanation.  I will do my best because this was a complicated issue for me although in the end it was due to my bad practices and the nature Virtuemart.  I don't believe the above post is really relevant any longer I guess I should organize this as ways to be sure your Vendor and Manufacturer links don't show up.  Using Joomla 1.5.9 VM 1.1.3 sh404sef, Xmap, and CSVimproved for Joomla 1.5 native
  • First, realize that not all product detail or "flypage" templates check the config file.  This means if you choose the wrong one the links will show regardless of what you chose in the config file.
  • Next realize that changing the template in the main config area of Virtuemart under site has no effect on the fly page of previously established categories.  You must change that setting in each individual category.  Visit the category list and then edit a category and you will see where to make the change.  The choices under the Config>site only set the default selection when creating new categories whether manually or with CSVimproved
  • Next problem CLEAR CACHE! When you make a flypage selection the biggest reason it doesn't actually change on the site frontend is because Virtuemart and SEF components create links based on the product flypage.  This means no change will occur on the front end flypage until URL's are purged and rebuilt.  I use sh404sef! and have gotten in the habbit of purging and rebuilding the URL's anytime I add not categories, or products or make changes to the flypage.  It solves a lot of problems. I use Xmap to rebuild links it has a Virtuemart plugin ;)
  • You may also need to empty Joomla cache and browser cache
  • Lastly, if you use CSVimproved and certain categories won't respond to any of the above solutions you may have improperly created a category.  This happened to me nearly two months ago and I changed my practices to prevent it but now I'm not entirely sure this really happens or if it is always do to the SEF urls.  But if nothing else helps this is worth a try.  If you create new products using CSVimproved but didn't create proper categories for those product either manually with Virtuemart or using a CSVI category import template you may have unwittingly created a problem for yourself.  If you type in the category path improperly or don't create the category in advance the product import will create a new one.  However I believe categories created in this way will not allow you to change the flypage.  We could experiment with this but I know I was convinced it was my problem about two months ago.  The only solution would be to delete everything, recreate the categories properly, then populate the products properly into those categories, this shouldn't be too hard because you are already using CSVI :)
Finally, it was difficult for me to see that Virtumart wasn't making changes to the flypage because many of them have similar elements and I wasn't familiar with how they should look anyway.  It wasn't until I started erasing the flypages that I finally learned which one my categories were using.  Then I had to read through the code to find which ones actually consult the config file.  I have found in general if the proper flypage is really being used then the links to turn off and on as they are supposed to.  Now days I use the colorful designs for virtuemart designs and the changes are very apparent.  I hope this helps someone.  I told you it is complicated.