Author Topic: USPS error--little help please  (Read 17685 times)

Stevia

  • Beginner
  • *
  • Posts: 16
USPS error--little help please
« on: December 06, 2008, 21:55:42 pm »
Newbie.  Little webmaster experience/training.
Setting up my first internet site.
Have set up USPS:
-Received USPS Web Tool registration.
-Been moved to production server and received URL's from USPS.
-Installed USPS Module v. 4.
--/home/summeck7/public_html/administrator/components/com_virtuemart/classes/shipping/uspsv4.cfg.php
--selected several methods of shipping:  Express; priority; parcel post; First Class Flat; Several international methods too.
-Made the USPS server-path distinctions (.com vs .dll).
-Still getting error 'Notice: We are unable to obtain any USPS shipping methods at this time, please choose from one of the following shipping methods.'
Thoughts?
Thanks.

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: USPS error--little help please
« Reply #1 on: December 07, 2008, 23:19:44 pm »
Step 1: put your shop into debug mode. 
Step 2: run through the checkout procedure again, see if any pertinent error information is shown.
Step 3: post results here

Hope this helps,
Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

Stevia

  • Beginner
  • *
  • Posts: 16
Re: USPS error--little help please
« Reply #2 on: December 08, 2008, 01:51:32 am »
Hi Reggie,
First, thanks for the reply.
New to this but here is what I did:
-Turned on server and language debug.
-Saved screeen.
-Began to process a purchase.
-Process hung on shipping--same error.
-Seven files generated. 
--shop.debug.php
--config_debug.php
--en_GB.ph_system_debug.ini
--debug.php
--en-GB.plg_system_debug.ini (different path)
--log_Debug.png
--debug.xml
Is it one of these?
Greg.

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: USPS error--little help please
« Reply #3 on: December 08, 2008, 15:53:39 pm »
Greg,
I've never used the debug to file option. I was looking more for a "such and such was on the screen".  But you could zip up all those files you listed and post them in a reply here and I'll look at them, I think we'll get the same info that way.

-Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

Stevia

  • Beginner
  • *
  • Posts: 16
Re: USPS error--little help please
« Reply #4 on: December 08, 2008, 16:51:59 pm »
Good morning Reggie,

Thanks for getting back.

The actual error message is in the first post, in quote marks.  Essentially, unable to access USPS methods.  (see original post above).

If you think the output files will help, then I can zip them up and post as well.

Greg.

olesman20

  • Beginner
  • *
  • Posts: 11
Re: USPS error--little help please
« Reply #5 on: December 08, 2008, 16:52:52 pm »
We get the "Notice: We are unable to obtain any USPS shipping methods at this time, please choose from one of the following shipping methods." too.
We have upgraded to v4 of the USPS module.
It is very strange because we do not get the error if the billing address is in state (Maine in our case) and we use shipping address same as billing.
But if we have an out of state billing address we get the error.
We also get the error if we try to use an address that is different from the billing address no matter if it is in state or out of state.
From debug mode I get:
Debug: Starting Shipping module: uspsv4
XML Post:
http://Production.ShippingAPIs.com/ShippingAPI.dll?API=RateV3&XML=<RateV3Request USERID="XXXXXX" PASSWORD="XXXXXX"><Package ID="0"><Service>All</Service><ZipOrigination>04605</ZipOrigination><ZipDestination>04605</ZipDestination><Pounds>3</Pounds><Ounces>8</Ounces><Size>LARGE</Size><Machinable>FALSE</Machinable></Package></RateV3Request>
XML Result:
<an empty text box>
Notice: We are unable to obtain any USPS shipping methods at this time, please choose from one of the following shipping methods.

Any help would be greatly appreciated.

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: USPS error--little help please
« Reply #6 on: December 08, 2008, 17:12:45 pm »
olesman20 :

Quickly edit your post and remove your username/password from the XML post data

As for the empty XML results...that is very odd to say the least!  The CURL code should have returned some kind of error message.



Stevia:

The error message indicates that no valid rates were returned.  Posting the XML request/reply would help in debugging.  (remove any username/password from the XML post)
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: USPS error--little help please
« Reply #7 on: December 08, 2008, 17:45:22 pm »
Greg,


1) Delete your previous post. It contains your admin name.  You shouldn't post that, anywhere.

2) In the future, please attach the information as a file instead of posting directly to the forums.

3) I think the problem is with USPS online tools.  I sent a basic request OUTSIDE of VirtueMart/Joomla and got this:


Code: [Select]
<Error>
<Number>80040320</Number>
<Description>An unexpected system error has occurred.  Please try again later or contact the System Administrator.  </Description>
<Source></Source>
</Error>

I think they are having issues. 



I sense a disturbance in the force, as if a million online shops called out for rates, and were suddenly silenced...
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

Stevia

  • Beginner
  • *
  • Posts: 16
Re: USPS error--little help please
« Reply #8 on: December 08, 2008, 18:18:11 pm »
Thanks for your insight and security concern.  Thought that I had remove all admin references.

Will try again later.

Thanks again.

jmatz

  • Beginner
  • *
  • Posts: 6
Re: USPS error--little help please
« Reply #9 on: December 08, 2008, 21:11:34 pm »
Was getting the error 'Notice: We are unable to obtain any USPS shipping methods at this time, please choose from one of the following shipping methods.'

Turned on "Report errors on frontend?". Got more detail basically saying that there was no answer from server.

Called the Internet support line at USPS.  Recorded message saying that many of their systems supporting online metering, web tools, etc. were down.

Spoke with the tech guy who came on the line - he confirmed that the problems at their end would definitely affect any requests coming from the USPS module.

10 minutes later, all was working again on my site in VM, without changing anything.

Stevia

  • Beginner
  • *
  • Posts: 16
Re: USPS error--little help please
« Reply #10 on: December 09, 2008, 01:02:43 am »
Good scoop.
Something else must be wrong on my site.
Another attempt yielded the same error.

Question:  after the USPS 4.0 module is installed and configured, are there any other required settings?  NOTE:  I selected several 'methods' within the USPS module i.e. first class flat, priority, etc.

Thanks,

Greg.

ogosense

  • Beginner
  • *
  • Posts: 3
Re: USPS error--little help please
« Reply #11 on: December 09, 2008, 01:39:24 am »
Called the Internet support line at USPS.  Recorded message saying that many of their systems supporting online metering, web tools, etc. were down.

Spoke with the tech guy who came on the line - he confirmed that the problems at their end would definitely affect any requests coming from the USPS module.


We also got the following error on two sites that we maintain:


Notice: We are unable to obtain any USPS shipping methods at this time, please choose from one of the following shipping methods.

I look forward to USPS resolving this issue.

Ogy


Stevia

  • Beginner
  • *
  • Posts: 16
Re: USPS error--little help please
« Reply #12 on: December 09, 2008, 13:21:46 pm »
Thanks for the scoop.

By way of an update, just spoke with USPS Web Sevices support (Tue, 9Dec, 6:20 Central):  servers still down w/no ETA.

Greg.

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: USPS error--little help please
« Reply #13 on: December 10, 2008, 04:02:15 am »
USPS website that shows info about the "interruptions"
http://www.usps.com/homearea/onlinesysteminterruptions.htm

A slashdot story about the mess
http://tech.slashdot.org/article.pl?sid=08%2F12%2F09%2F1935223&from=rss
get your flame on!
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

Stevia

  • Beginner
  • *
  • Posts: 16
Re: USPS error--little help please
« Reply #14 on: December 10, 2008, 23:29:36 pm »
Hmmmmmm.
Do we dare to ask for a name to associate with this type of service?
Better not, huh?
Oh, but the temptation...