Author Topic: I'm stuck. Please help  (Read 7736 times)

mks8500

  • Beginner
  • *
  • Posts: 11
I'm stuck. Please help
« on: November 26, 2008, 03:08:37 am »
I've successfully loaded (I think...followed directions at least) the USPS module but there are no shipping rates listed.  Clearly I did something wrong.  But what? Do I need to sign up for something with USPS? If so, can someone tell me what exactly? Thank you in advance. 

P.S - I'm running Joomla 1.5.8 and VirtueMart 1.1.2

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: I'm stuck. Please help
« Reply #1 on: November 26, 2008, 13:08:51 pm »
Did you select some services to use?
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)

mks8500

  • Beginner
  • *
  • Posts: 11
Re: I'm stuck. Please help
« Reply #2 on: November 26, 2008, 22:58:25 pm »
Yes.  I went under admin of the store and selected the shipping module and also created a new shipper under shipping.  But, under shipping rates, there's nothing.

mks8500

  • Beginner
  • *
  • Posts: 11
Re: I'm stuck. Please help
« Reply #3 on: November 28, 2008, 04:45:16 am »
I'm wondering where on USPS I can actually sign up for whatever I'm supposed to be signed up for in order to use this.  can someone send me a link or a name of what I'm looking for?

bobhair

  • Beginner
  • *
  • Posts: 4
Re: I'm stuck. Please help
« Reply #4 on: December 02, 2008, 07:24:55 am »
Go to http://www.usps.com/webtools.  They will assign a user/password for your account and all the links you need to enter. Good luck. :)

mks8500

  • Beginner
  • *
  • Posts: 11
Re: I'm stuck. Please help
« Reply #5 on: December 03, 2008, 01:28:10 am »
Ahhhhhh....I did this then requested that they send me over to the production server.  They've done that and I'm still getting an error that there are no shipping methods to choose from.  :-( Any other ideas?

mks8500

  • Beginner
  • *
  • Posts: 11
Re: I'm stuck. Please help
« Reply #6 on: December 03, 2008, 01:41:34 am »
This is the error I get on the front end when I'm (the customer) is checking out

Error: Couldn't resolve host 'http:'
Error: USPS was not able to process the Shipping Rate Request.

mks8500

  • Beginner
  • *
  • Posts: 11
Re: I'm stuck. Please help
« Reply #7 on: December 03, 2008, 01:57:34 am »
Oops...I fixed it.  Removed the http:// in front of production.shippingapis.com

All fixed.

Stevia

  • Beginner
  • *
  • Posts: 16
Re: I'm stuck. Please help
« Reply #8 on: December 06, 2008, 15:34:14 pm »
Stuck too.
-Followed the foregoing thread including the USPS server-path distinctions (.com vs .dll).
-Still getting error 'Notice: We are unable to obtain any USPS shipping methods at this time, please choose from one of the following shipping methods.'
Thoughts?
Thanks.

lowmips

  • Global Moderator
  • Full Member
  • *
  • Posts: 1464
    • lowmips.com
Re: I'm stuck. Please help
« Reply #9 on: December 08, 2008, 15:54:35 pm »
That error is generic. Put your VirtueMart shop into debug mode and run through the checkout process again.  See if anything more specific comes up.

-Reggie
Visit my website at www.lowmips.com
View my newsletters Here (sign up for newsletters on the front page of my website)