Author Topic: [Product Details...] result page empty..!!!! What happen?  (Read 10350 times)

memorableurns

  • Beginner
  • *
  • Posts: 8
[Product Details...] result page empty..!!!! What happen?
« on: November 18, 2008, 22:01:01 pm »
Hi guys.

When I finish filling in a new product and publish it. If I press the [Product Details...] under the picture of my products, it brings me to an empty page...

Where is the setting for this? Is there a setting? Or a bug?

Thank you.

Mad

daskata

  • Beginner
  • *
  • Posts: 1
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #1 on: November 20, 2008, 10:59:50 am »
Folow this steps

1.administration in virtuemart
2.page
3.layout
4.set do default

DanyBug

  • Beginner
  • *
  • Posts: 3
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #2 on: December 14, 2008, 02:03:01 am »
i had to replace my  virtuemart.cfg.php with the original ... details are back

slavisa

  • Beginner
  • *
  • Posts: 10
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #3 on: December 14, 2008, 21:38:40 pm »
What i noticed is everything is fine until i disable the downloads. Once i do that the product details disappear. Then once i place the virtuemart.cfg back to the server, the product details are back but also the downloads enabled is checked again.

smoser

  • Beginner
  • *
  • Posts: 1
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #4 on: December 18, 2008, 13:48:07 pm »
Same with my shop.

I changed the template like daskata said, then enabled downloads like slavisa said. And now it works. Ugly, but working.

I installed the Joomla & Virtuemart combi-install. Downloaded it 5 days ago.

Because this solution results in an ugly site (the default layout is not really my choice), i would be happy to get some info about the reasons behind, and/or some other workaround.

;-)
Stefan

bbant

  • Beginner
  • *
  • Posts: 7
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #5 on: December 22, 2008, 18:18:46 pm »
SOLUTION:
I had a same problem. Product details for some products was blank on IE6. On every other browser was OK. It turns out that if the "product name" was longer than 33 characters it displayed a blank page on IE6. I guess its a Virtuemart bug.

jayzpc

  • Beginner
  • *
  • Posts: 3
    • Jayzpc Store
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #6 on: December 23, 2008, 16:18:15 pm »
Ive installed joomla 1.5.8 with virtuemart built in and get this problem as well.  Ive tried changing cfg like others but problem is still the same.  Please let me know if there is a patch or something.

CNCAddict

  • Beginner
  • *
  • Posts: 2
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #7 on: December 24, 2008, 01:37:16 am »
I also noticed if you set the "Default number of products in a row" to something other than "1" that the details disappear :(

bbant

  • Beginner
  • *
  • Posts: 7
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #8 on: December 24, 2008, 19:14:12 pm »
I've also found that this is a problem with the browser title length.
In administrator/components/com_virtuemart/html/shop.product_details.php
change the line:
Code: [Select]
$vm_mainframe->setPageTitle( html_entity_decode( substr($product_name, 0, 60 ), ENT_QUOTES ));with this:
Code: [Select]
$vm_mainframe->setPageTitle( html_entity_decode( substr($product_name, 0, 120 ), ENT_QUOTES ));Or you can delete the line but the browser will not display the product name in the browser title.

jayzpc

  • Beginner
  • *
  • Posts: 3
    • Jayzpc Store
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #9 on: December 30, 2008, 21:08:08 pm »
For some reason ive noticed that no matter which product detail link I click on weither its in module slider "on top" on in random products.  They all give me same url with identical item id.

enzo24

  • Beginner
  • *
  • Posts: 13
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #10 on: January 01, 2009, 14:27:22 pm »
Hi folks
I had the same problem, and I changed the flypage in VM general configuration, and presto, product details showed up as they should.
Hope this helps.

jayzpc

  • Beginner
  • *
  • Posts: 3
    • Jayzpc Store
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #11 on: January 02, 2009, 04:26:22 am »
In VM -> configuration -> site, flypage dropdown box is blank.  Maybe thats why product details dont show?

asterix361

  • Beginner
  • *
  • Posts: 1
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #12 on: January 05, 2009, 10:07:30 am »
I just installed joomla158+VM (ecommerce bundle) and have the same issue.

I think it has to do with "categories" as I installed 2 fresh versions (one with sample data and one empty).

On the empty one
1) created a category
2) created a product and, no matter what I try, it does not show the product details

On the "sample data"
1) created a category
2) created a product and, no matter what I try, it does not show the product details
So, for now it's the same BUT, if I change the product's category to one of the "sample categories", i.e. "Ipod", it works PERFECTLY.

Also:
1) the breadcrumbs are not working fine, and looks like it's a problem related to the first one, as it works with articles, but not with products
2) the sample data categories have an empty flypage also, so I guess it's not the reason
3) any templated resulted in the same behaviour, so looks not related to a template.


I do not know how to solve it, but I guess it will add some light to the gurus.

Thanks!!!

Morne

  • Beginner
  • *
  • Posts: 29
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #13 on: January 05, 2009, 22:46:25 pm »
Folow this steps
1.administration in virtuemart
2.page
3.layout
4.set do default

You mean:
1.administration in virtuemart
2.site
3.layout
4.set do default, where it says "Select the theme for your Shop"

but this didn't work for me?

But the drop down for my flypage is also empty..,aybe this?

Morne

  • Beginner
  • *
  • Posts: 29
Re: [Product Details...] result page empty..!!!! What happen?
« Reply #14 on: January 05, 2009, 23:11:20 pm »
ok mine works again when i activated the "Print View Link" checkbox under:
1. VM admin config
2. Site
3. Show the "Print View" link? (true= Selected checkbox)
 
Works with default and ja_larix theme, and any number products in a row, and Downloads ON or OFF, so i think its mainly the "Print View" link.

I'm using latest Firefox browser.

Hope this helps