Author Topic: [SOLVED} Sessions mixed up ?  (Read 2010 times)

pgvisser

  • Beginner
  • *
  • Posts: 8
[SOLVED} Sessions mixed up ?
« on: September 17, 2008, 12:39:05 pm »
Hi, I need some urgent help.
I build my shop and all worked fine till I opened up.
In the development stage I blocked users and did trail runs as administrator,
Now the site is openend for the public I notice that for customers that are not logged-in in some categories the session ID changes.
For instance customer add's something to the shop, cart content is ok, customer deletes his choices, cart shows "no products", still ok. Customer selects another category: cart has content and with the debug facility on I see another Session ID as the ID for the empty cart.

Again, as administrator or logged-in customer it works fine.

Who can help, i am lost.


pgvisser

  • Beginner
  • *
  • Posts: 8
Re: Sessions mixed up ?
« Reply #1 on: September 24, 2008, 12:37:14 pm »
Found the problem.

In the general settings of Joomla the cache was "off" but in the pluginmanagement the Cache plug was enabled. I disabled the plug and now it all works fine !

JasonYohon

  • Beginner
  • *
  • Posts: 9
Re: [SOLVED} Sessions mixed up ?
« Reply #2 on: October 29, 2008, 15:50:05 pm »
How in the world did you ever figure that out?! Thank you! I've lots lots of $$$ over this problem... It seems to be fixed now. Thank you!

pgvisser

  • Beginner
  • *
  • Posts: 8
Re: [SOLVED} Sessions mixed up ?
« Reply #3 on: October 29, 2008, 16:07:25 pm »
Well, good to hear.
Congratulations
In my case now for 1 month stable and customer-orders.