Author Topic: Virtuemart menu link breaks breadcrumbs  (Read 11368 times)

Tresan

  • Beginner
  • *
  • Posts: 17
Virtuemart menu link breaks breadcrumbs
« on: August 15, 2008, 21:27:47 pm »
I have 2 identical sites.

Both run Joomla 1.5.6 , VM 1.1.2 (and have been tested with or without SEF on)

Site 1:

Menu made of Virtuemart options in the joomla menu system.
Category id assigned to each VM link so it links to each category.

Breadcrumbs reports wrong URLs and repeats itself so instead of doing:

Home -> Cat1 -> Cat2 

it does

Home -> Cat1 -> Cat2 -> Cat1 -> Cat2

All links become url/cat2  instead of url/cat1/cat2

In general the routing is ruined the second a menu link is made using the internal VM link for menu links.

Site 2:

Manually made links to VM categories using External links in Joomla menu system.

Breadcrumbs works and there is no problems.

I have spent around 20 hours trying to fix the problem - trawling trough this forum, joomla forum and sh404sef (again tested both with and without sef and sh404sef and joomla sef).

So the Virtuemart menu option doesnt work as supposed and it breaks breadcrumbs and internal routing.

loiseau

  • Beginner
  • *
  • Posts: 31
Re: Virtuemart menu link breaks breadcrumbs
« Reply #1 on: August 16, 2008, 13:00:38 pm »
same problem.  ???

Tresan

  • Beginner
  • *
  • Posts: 17
Re: Virtuemart menu link breaks breadcrumbs
« Reply #2 on: August 16, 2008, 17:05:37 pm »
Heard the dev team is on holiday so prolly wont see any fixes till monday the easliest.

But sure is a pain when you run a 4 webshops with over 1000 products in each...

Tresan

  • Beginner
  • *
  • Posts: 17
Re: Virtuemart menu link breaks breadcrumbs
« Reply #3 on: August 20, 2008, 16:34:57 pm »
Hope someone gets back from vacation soon  :-\

arana

  • Jr. Member
  • **
  • Posts: 89
Re: Virtuemart menu link breaks breadcrumbs
« Reply #4 on: August 29, 2008, 15:34:19 pm »
this is problem happens when you have VM and sh404sef installed (in my case), what i did was disable breadcrumbs and only use VM site navigation. i think this is a problem with the sh404sef virtuemart plugin, ive searched enough, apparently no solution
(disable sh404sef and see how it does work)

NodNarbOen

  • Beginner
  • *
  • Posts: 4
Re: Virtuemart menu link breaks breadcrumbs
« Reply #5 on: September 05, 2008, 08:52:30 am »
Hi All, I'm having the exact same problem as well. Has a solution been found yet?? This is pretty urgent for my site..

arana

  • Jr. Member
  • **
  • Posts: 89
Re: Virtuemart menu link breaks breadcrumbs
« Reply #6 on: September 05, 2008, 19:22:30 pm »
lets all post in sh404sef site, maybe we are heard there :P

NodNarbOen

  • Beginner
  • *
  • Posts: 4
Re: Virtuemart menu link breaks breadcrumbs
« Reply #7 on: September 06, 2008, 10:30:51 am »
Sure. Have you started a thread? Can I have the link?

arana

  • Jr. Member
  • **
  • Posts: 89

Phatrick

  • Beginner
  • *
  • Posts: 21
Re: Virtuemart menu link breaks breadcrumbs
« Reply #9 on: October 04, 2008, 15:15:34 pm »
I have this problem too..... Joomla 1.5.7, VM 1.1.2 and sh404SEF 1.0.11beta

Home> Product Category > Product

You get a 404 if you link back "Product Category" this is happening because the link omits the category from the SEF link...

example.com/category/View-all-products.html 

should be the correct link

however

example.com/View-all-products.html 

is being cached in the breadcrumb marker.



Phatrick

  • Beginner
  • *
  • Posts: 21
Re: Virtuemart menu link breaks breadcrumbs
« Reply #10 on: October 08, 2008, 13:09:16 pm »
SOLVED!

Switch off the standard joomla SEO/SEF in global config. and this fixes the problem. If anyone wants I can provide more details of my config settings. This was basically producing the conflict

HTH

Orangeyeti

  • Beginner
  • *
  • Posts: 5
Re: Virtuemart menu link breaks breadcrumbs
« Reply #11 on: December 14, 2008, 13:47:56 pm »
I still have the same problem even with joomla SEO/SEF switched off.
I have SEF Service Map Component v.2.0 installed but have disabled that as well just in case, but it didn't seem to make a difference ?
Any ideas welcome

nsw

  • Beginner
  • *
  • Posts: 46
    • Management Consultant
Re: Virtuemart menu link breaks breadcrumbs
« Reply #12 on: January 23, 2009, 15:32:42 pm »
Same problem here with J1.5.9 VM1.1.2.
Any news on a fix for this very annoying problem ?

It would seem that a link from the menu does not include the "page" and "category_id" variables and instead just generates a link based on Itemid as below

index.php?option=com_virtuemart&Itemid=100061

Where as the fully formed VM link includes these variables

index.php?option=com_virtuemart&page=shop.browse&category_id=24&Itemid=76

We effectively now have two links to the same page which then screws up the breadcrubms and probably a few SEF components.

I am seeing this on new raw Joomla installation with no SEF / SEO impleted yet.
 ???