Author Topic: problem with sh404SEF and add to cart after SSL enabled  (Read 7716 times)

samoht

  • Jr. Member
  • **
  • Posts: 104
problem with sh404SEF and add to cart after SSL enabled
« on: August 07, 2008, 16:06:50 pm »
hello,

I love sh404SEF - and it works great with vm 1.1 especially using the vm search.

Problem:
when I enabled my site for SSL the add to cart buttons started to act funny. On the flypage they still act correctly but on the product detail page nothing happens and in the related products when you click on the add to cart - it takes you to a search page and says sorry your requested info was not found???

this is very strange. I noticed that the code is the same in all 3 instances so why would it act differently? Also why would enabling SSL change the functioning?

Anyway, any ideas how to fix?

thanks - I use Joomla 1.5.3 and VM 1.1.1 and 1.0.6_Beta build of sh404SEF
I use Joomla 1.5! and VM 1.1


samoht

  • Jr. Member
  • **
  • Posts: 104
Re: problem with sh404SEF and add to cart after SSL enabled
« Reply #2 on: August 07, 2008, 22:14:31 pm »
ok I updated to the new vm and sh404 - and now I get this error on the product detail page:

Fatal error: Call to undefined method ps_product_attribute::list_thumb() in /var/www/sin/diecicolori.com/components/com_virtuemart/themes/default/templates/product_details/flypage.tpl.php on line 32
I use Joomla 1.5! and VM 1.1


samoht

  • Jr. Member
  • **
  • Posts: 104
Re: problem with sh404SEF and add to cart after SSL enabled
« Reply #4 on: August 08, 2008, 14:56:43 pm »
I was getting that error on my product detail page where my product had subproducts - I realized that the reason for this error was that I had build a custom hack in ps_product.php to display the additional images of the subproducts in a thumbnail gallery. - so I just put that hack back in and the error went away.

BUT - I am still having the same issue with the add-to-cart functionality. And this issue goes away when I disable sh404SEF ???

does the joomla version have anything to do with it?

I also get javascript errors when I click on the non working add-to-cart buttons
http://www.diecicolori.com/brushes/index2.php?ajax_request=1 (Not Found)

Any ideas?
I use Joomla 1.5! and VM 1.1

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: problem with sh404SEF and add to cart after SSL enabled
« Reply #5 on: August 08, 2008, 20:09:51 pm »
VirtueMart 1.1.2 + J1.5.5 and sh404SEF 1.0.11 b 147, works on my test site but have not tested it with SSL, won't be able too because I don't have SSL, have you asked over at sh404SEF forum, maybe a setting should be enabled for SSL

samoht

  • Jr. Member
  • **
  • Posts: 104
Re: problem with sh404SEF and add to cart after SSL enabled
« Reply #6 on: August 08, 2008, 20:19:13 pm »
interesting,

in my case everything worked fine until I enabled SSL

I have checked some at sh404 - and there is some test versions there working on - but they are not production ready.
I use Joomla 1.5! and VM 1.1