Author Topic: Authorize.net Secure Pay  (Read 3753 times)

Heno

  • Beginner
  • *
  • Posts: 3
Authorize.net Secure Pay
« on: May 27, 2008, 07:31:48 am »
G'Day all,

I have an interesting dilemma and any in put would be much appreciated.

I have a virtuemart 1.1.0 shopping cart running in Joomla! 1.0.15 Stable. The site has been up for a while and the client has recently decide that they would like to sell download able content via their site.

The client has a recently purchased an authorize.net service provided by a mob called Secure Pay here in Australia.

I have set everything up in the apparent correct manner with reference to http://forum.virtuemart.net/index.php?topic=14844.0

I have also made the necessary changes to the authorize.net module at lines 382 and 591.

Currently when i process a transaction everything seems to go though fine, the shopping cart is of the belief that the transaction has been successfully processed and notifies both myself and the customer as such via email. BUT when we log into the secure pay management console it indicates that no transactions have been processed. After conferring with the secure pay tech support droid he was able to validate this for me.

So i currently have a shopping cart that is processing orders, not posting any errors but isn't actually passing any info to my authorize.net gate way.

I have tralled the VM forums and Google with out being able to find a similar issue.

I have confirmed that the gate way is using Authorize.net AIM.
I have tried implementing http://forum.virtuemart.net/index.php?topic=40777.0 but this didn't resolve the issue.
I have created a new Authorize.net credentials.


Any one have any ideas?

Regards,

bends

  • Beginner
  • *
  • Posts: 5
Re: Authorize.net Secure Pay
« Reply #1 on: July 31, 2008, 01:04:48 am »
Hey did you manage to get this working?