Author Topic: ERROR: Could not find a Joomla! XML setup file in the package.  (Read 24632 times)

nursejen

  • Beginner
  • *
  • Posts: 2

Upload component - Upload Failed
ERROR: Could not find a Joomla! XML setup file in the package.
[ Continue ... ]
Upload component - Failed
Installation file not found:


Hello. I have read many great things about this component, so I'm very happy to give this one a try. I have encountered the above upon installation, though.

I downloaded the complete package for Joomla. I have unpacked VirtueMart_1.1.0-Manual_Installation_Package.j15, read the PDF file, and tried installing the com_virtuemart_1.1.0.j15 included in the complete package file with the component installer of Joomla in the administration panel (Installers > Components).

What have I done wrong?

Thank you in advance.

emrfixit

  • Beginner
  • *
  • Posts: 8
    • Morgans WebWorks
Re: ERROR: Could not find a Joomla! XML setup file in the package.
« Reply #1 on: July 27, 2008, 12:38:41 pm »
This usually means you have the upload file packed in a zip file. Try extracting this file to another folder and see if your upload file is there. Then install that folder (hint: it should also be another zip file)

nursejen

  • Beginner
  • *
  • Posts: 2
Re: ERROR: Could not find a Joomla! XML setup file in the package.
« Reply #2 on: July 27, 2008, 21:22:40 pm »
Could you explain that to me further please?

I have extracted the com_virtuemart_1.1.0.j15 to another folder onto my computer and I saw some XML files in it. I then tried installing that same zip file containing the XML files and other things and it gave me those errors.


rhommer

  • Beginner
  • *
  • Posts: 1
Re: ERROR: Could not find a Joomla! XML setup file in the package.
« Reply #3 on: August 06, 2008, 04:40:25 am »
I have the same issue.  Any resolution? 

AceG

  • Guest
Re: ERROR: Could not find a Joomla! XML setup file in the package.
« Reply #4 on: August 06, 2008, 08:04:52 am »
 
This usually means you have the upload file packed in a zip file. Try extracting this file to another folder and see if your upload file is there. Then install that folder (hint: it should also be another zip file)

This is exactly what you need to do... In other words... make sure all Zip files are "un-zipped" so to speak... Once everything has been "un-packed" you should have no problem uploading that folder and your installation should be in place.

hDh

  • Beginner
  • *
  • Posts: 4
Re: ERROR: Could not find a Joomla! XML setup file in the package.
« Reply #5 on: August 06, 2008, 17:38:02 pm »
I ran into that issue with the J15 package also. The installer didn't like anything I was giving it.

I worked around it by using the "Install from Directory" option in Extension Manager.
1. Expand the package on your desktop
2. FTP the expanded folder (and its contents) to the tmp folder.
3. Specify the folder name in the "install from directory" field.
4. Click install.

This worked for me. If you have issues with this double-check your permissions on the files and folders.

aravot

  • Peter
  • Moderator
  • Hero Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: ERROR: Could not find a Joomla! XML setup file in the package.
« Reply #6 on: August 07, 2008, 02:36:31 am »
nursejen, it seems you are doing it correct, my guess you downloaded using IE try downloading the zip package using Firefox and retry the installation, let us know.

marcobos

  • Beginner
  • *
  • Posts: 2
Re: ERROR: Could not find a Joomla! XML setup file in the package.
« Reply #7 on: December 28, 2008, 06:56:06 am »
I have spent two full days now on trying to install this module, but so far no success.

I have a Joomla 1.5.8 installation and try to install Virtuemart.

First I tried to install the full (Joomla + Virtuemart) "down.pngComplete Package for Joomla! 1.5" into my Joomla, wich ofcourse didn't work. :D

Then I found the right installer "VirtueMart_1.1.2-COMPLETE_PACKAGE.j15"
The file is too big to upload the Package File, so I read about the manual instruction.

I unzipped the file: "VirtueMart_1.1.2-COMPLETE_PACKAGE.j15" and uploaded it with my FTP application to the /tmp/ folder.

Then after more careful reading of this forum, I realized there were still several zip files within the unzipped "VirtueMart_1.1.2-COMPLETE_PACKAGE.j15" file

NOTE: I really wonder why there are zipped files within a ZIP file, since this would not make the whole zip file any smaller and just adds more work when unzipping the file.

After unzipping all the subfolders as well, I uploaded everything again to the /tmp/ folder
I uploaded the following three folders:
com_virtuemart_1.1.2.j15
plugins
modules


Then I use the "Install from Directory" function and select "/tmp"
What I get is:


        * Error! Could not find a Joomla! XML setup file in the package.
        * Path does not have a valid package.


Warning: opendir(/tmp/fs_sessions): failed to open dir: Permission denied in /home/content/html/test/libraries/joomla/filesystem/folder.php on line 391

Warning: readdir(): supplied argument is not a valid Directory resource in /home/content/html/test/libraries/joomla/filesystem/folder.php on line 392

Warning: closedir(): supplied argument is not a valid Directory resource in /home/content/html/test/libraries/joomla/filesystem/folder.php on line 418
Unable to find install package


I then read about the permissions of the folders, so I changed the permissions of the following folders to 777:
plugins
modules
and all folders and subfiles of libraries/joomla/filesystem/

I must be doing something wrong still, so please help...

 



marcobos

  • Beginner
  • *
  • Posts: 2
Re: ERROR: Could not find a Joomla! XML setup file in the package.: solved
« Reply #8 on: December 28, 2008, 10:14:02 am »
I just went through the manual again and found the manual installation:

http://virtuemart.net/documentation/User_Manual/Manual_Installation.html

This seemed to work, so now I can start playing with Virtuemart

I think the manual installation is a lot simpler than the automatic installation, so I would recomend it to anybody who has trouble with the installation.


VirtueMart Forum

Re: ERROR: Could not find a Joomla! XML setup file in the package.: solved
« Reply #8 on: December 28, 2008, 10:14:02 am »