Author Topic: virtuemart module disappears  (Read 8553 times)

doktor101101

  • Beginner
  • *
  • Posts: 21
virtuemart module disappears
« on: July 16, 2008, 01:14:33 am »
I am using VirtueMart 1.1.0 and Joomla 1.5.2 in Legacy mode.

I created a menu button for VirtueMart on the home page, and when I click on it the  VirtueMart module shows on the page.  However, if I click on any of the other links, such as category links or "List all products", the VirtueMart module disappears, leaving no proper navigation. 

I have read through the entire installation and user manual and did not find an answer to this.  I have read through the posts on this forum but did not find a resolution to the problem.

Does anyone know what causes this and how it might be fixed?

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #1 on: July 16, 2008, 22:34:46 pm »
Are you developing this locally? If not, can you post a link so i can understand what you are talking about?

Thanks,
Tachi
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

doktor101101

  • Beginner
  • *
  • Posts: 21
Re: virtuemart module disappears
« Reply #2 on: July 16, 2008, 23:18:12 pm »
The component is here:  http://www.qualitywebdesign.ca/virtuemart

Try clicking on any of the VirtueMart links and you'll see what I mean -- the module disappears.

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #3 on: July 16, 2008, 23:50:25 pm »
Can you turn off SEF and see what happens?
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

doktor101101

  • Beginner
  • *
  • Posts: 21
Re: virtuemart module disappears
« Reply #4 on: July 17, 2008, 00:01:17 am »

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #5 on: July 17, 2008, 00:16:23 am »
Just as a simple observation, it doesnt look like the VM component is assigned to a particular menu item.
Is it?

Are your backend configurations ok? All VM modules with the proper view permissions?
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #6 on: July 17, 2008, 00:31:59 am »
I'm pretty sure that you need to assign the Virtuemart component to a menu item. The entire session then takes place on that menu item's "page". This is a problem I am running into when trying to target seperate VM modules to the homepage alone while using the VM component linked to my HOME menu item as my frontpage.

See: http://67.15.211.5/~mrbaguet/

The entire time you use the VM product on that site, notice the index remains on "HOME" (Home is highlighted, since VM is asigned to that menu item).
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

doktor101101

  • Beginner
  • *
  • Posts: 21
Re: virtuemart module disappears
« Reply #7 on: July 21, 2008, 20:05:09 pm »
If I understand what you mean, I do have the VirtueMart component assigned to a menu item.  I just hid it on the FAQ page since it is still under development.  I have uninstalled and re-installed and now cannot access without logging in as per this thread:

http://forum.virtuemart.net/index.php?topic=42149.0

and this thread:

http://forum.virtuemart.net/index.php?topic=43314.0

... so I'm not sure if the problem is solved or not, or just compounded with a second problem.

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #8 on: July 21, 2008, 20:17:22 pm »
You uninstalled the VM component and then reinstalled through the Joomla admin right?
So you are working with what, to the best of your knowledge, is a fresh new VirtueMart?
Did you go through the VM modules and check all of their permissions?
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

doktor101101

  • Beginner
  • *
  • Posts: 21
Re: virtuemart module disappears
« Reply #9 on: July 21, 2008, 20:33:13 pm »
Correct for all.  I was going to ditch VirtueMart but didn't find a reasonable alternative.  I have now reinstalled VirtueMart and have begun the setup all over and ran into this glitch.

I have installed the component, the VirtueMart module, and the VirtueMart login module. The access level for the two modules are set to public, the menu item for the VirtueMart component is set to public as well.


Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #10 on: July 21, 2008, 20:43:20 pm »
There is most likely a reason for this that can be corrected, but I don't know what is needed here. I have to say that I have experienced certain weirdnesses with VM. I have never submitted a bug to VM core team, but maybe this one should be if it has not been already.

When you uninstalled, did you happen to see if any modules or folders where left over from the previous installation? Did you manually clean out any VM tables? I would try that before fully ditching VM, but it's up to you.

I wish I could help out more. Let me know if I can.
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #11 on: July 21, 2008, 21:16:30 pm »
Man that's buggy...
Did you want to try a total uninstall? Folders and tables?
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #12 on: July 21, 2008, 21:17:19 pm »
Or, what about Legacy being on? Are others who have this same problem also running in 1.0 legacy mode?
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1

doktor101101

  • Beginner
  • *
  • Posts: 21
Re: virtuemart module disappears
« Reply #13 on: July 21, 2008, 21:33:21 pm »
I just tried a total uninstall, including folders and tables and got the same result.

I disabled Legacy mode, and still have the same problem.

Not sure where to go now.

Tachikoma

  • Jr. Member
  • **
  • Posts: 66
Re: virtuemart module disappears
« Reply #14 on: July 21, 2008, 21:34:56 pm »
ok, one more thing to do before throwing it out the window.
Update to 1.1.1 via the admin.
Joomla 1.5.4 on Siteground
Virtuemart 1.1.1