Author Topic: "&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.  (Read 3911 times)

CatawbaCoops

  • Beginner
  • *
  • Posts: 7
Off the bat Joomla 1.53 and VM 1.10. I did the VM complete install for this Joomla site. Works like a champ in Firefox. In IE it's a different matter.

Look at this browser killing URL:
http://www.catawbacoops.com/index.php?option=com_virtuemart&Itemid=4

IE hates this. I get and error that says: Cannot Opent the Internet Site. Operation Aborted. The browser then forwards to a 404 error page. I almost lost my first customer at http://www.catawbacoops.com because of this. I had to set up an FTP site for her to get her downloadable.

If I remove the &Itemid=4 from the URL to read...
http://www.catawbacoops.com/index.php?option=com_virtuemart

The site works fine! Works like a champ! Up until I try to do something in the cart, and the &Itemid=4 is appended to the URL again. Then it 404's the browser window again.
Kindest Regards,
David Bissette
www.CatawbaCoops.com
Urban Coops for Urbane Chickens

CatawbaCoops

  • Beginner
  • *
  • Posts: 7
Re: "&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.
« Reply #1 on: June 27, 2008, 19:43:15 pm »
Hmmm. That's unusual... the &Itemid=4 was the same number as ItemID in the menu I was linking from. So the menu system is appending the &Itemid=4 to the end of the URL. I deleted that menu item and created a new one. Guess what, my url now reads:

http://www.catawbacoops.com/index.php?option=com_virtuemart&Itemid=5

Well okay... so the question now is, Why is the Joomla menu system killing my shopping cart?
Kindest Regards,
David Bissette
www.CatawbaCoops.com
Urban Coops for Urbane Chickens

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27426
  • Always on vacation
    • Jenkin Hill Internet
Re: "&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.
« Reply #2 on: June 27, 2008, 21:45:35 pm »
I just tried your site with Firefox 3 and IE 8 beta with no problems adding to cart.

Love the site - we keep our hens in an Eglu.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

CatawbaCoops

  • Beginner
  • *
  • Posts: 7
"&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.
« Reply #3 on: June 27, 2008, 23:34:58 pm »
I looked at the Eglu... it's very modern looking. I went for something a little more rustic.

This is an odd problem. After I changed the &Itemid=4 to &Itemid=5 I didn't have any issues... OH WAIT! I also turned off SEF404 as well and cleaned the cache. Has there been a lot of issues with SEF404 creating non-existing URLs?
Kindest Regards,
David Bissette
www.CatawbaCoops.com
Urban Coops for Urbane Chickens

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27426
  • Always on vacation
    • Jenkin Hill Internet
Re: "&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.
« Reply #4 on: June 28, 2008, 00:02:14 am »
There are certainly problems with SEF404 on Joomla 1.5 with VirtueMart and other components.

sh404SEF is the closest to being OK for me.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.8 PHP 7.0.33
Testing VM .3.6.0.10075 on Joomla 3.9.8

CatawbaCoops

  • Beginner
  • *
  • Posts: 7
Re: "&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.
« Reply #5 on: June 28, 2008, 21:08:25 pm »
Upon further investigation... it's a MODULE that is killing my cart. The mod_virtuemart Online Shop Display annihilates my page every time I turn it on.
Kindest Regards,
David Bissette
www.CatawbaCoops.com
Urban Coops for Urbane Chickens

frit

  • Beginner
  • *
  • Posts: 1
Re: "&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.
« Reply #6 on: July 22, 2008, 22:37:48 pm »
Hi.

So have you been able to find a solution?

I am creating a shop online from VirtueMart component and my internship is getting to its end but I have been having the same problem for two weeks now. Explanation on Microsoft pages and everything won't help. Even if I guess I understood the possible cause of the problem, I can't find how to fix it.

I have noticed it happens when a user is logged in (using the VirtueMart login form module). If you leave(/quit) the tab or the page into your browser and then come back to the home page (and only this one), you get this annoying message about operation aborted because the file can't be opened. You can always go to a former visited page different from the home page and logout but I don't think customers will appreciate.

It seems that some JavaScript loaded in the page somewhere tries to access/modify an element that doesn't exist already. It happens right before the login form is loaded into my browser.

If anyone has an idea, please let me know. I am stuck with this and my internship is getting to its end very soon. Every time I find this problem somewhere on the Internet it's about a different part of the website and that worries me a lot.

Thank you for your help

jolmeda

  • Moderator
  • Beginner
  • *
  • Posts: 24
Re: "&Itemid" in the URL Kills/Slays/Destroys My VirtueMart Install.
« Reply #7 on: July 22, 2008, 22:58:21 pm »
Well we are having some errors with the &Itemid sent through the address...  I have 2 different top categories (Itemid=75 and Itemid=124 are both cats) created in VirtueMart, but the sub and sub sub categories for all parent categories always add the &Itemid=75, and that mess up my site...

Does anyone know how to fix this?