Author Topic: Has the multiple-images per product issue been addressed?  (Read 32315 times)

cosmick

  • Beginner
  • *
  • Posts: 2
Has the multiple-images per product issue been addressed?
« on: June 20, 2008, 03:15:00 am »
Hi all! I'm wondering if someone can point me in the right direction, or to an appropriate thread, that addresses a simple way for multiple images to be assigned to a product (not just thumbnail and fullsize, but several different images of the product)?

I have spent far too many hours searching for a way to do it. Surely, considering it was voted number one (1) most desired feature years ago there must be something available? Unfortunately I'm not a coder so I'm looking for an extension of some kind.

Any help would be much appreciated.

rrijnders

  • Beginner
  • *
  • Posts: 38
Re: Has the multiple-images per product issue been addressed?
« Reply #1 on: June 20, 2008, 07:05:13 am »
I don't understand the question  ???

Do you mean something other than the media / file manager? Through the media / file manager you can upload as many pictures as you want and they will display on the flypage:

  • Add a product (but don't add any pictures yet)and Click save
  • Click List Products
  • Next to your new product is an icon in the column that says "media"; click the icon
  • The File Manager window pops open. This lists all the existing files and media (including pictures) associated with the product


The "New" button will allow you to add new files and images. File Type Product Image (Full and Thumb) is the main image for the product that you're used to seeing. Adding files of type Additional Image will add more images that will display on your product flypage as thumbnails and also be clickable for full size.

hth
  ~~ rich

cosmick

  • Beginner
  • *
  • Posts: 2
Re: Has the multiple-images per product issue been addressed?
« Reply #2 on: June 20, 2008, 07:25:29 am »
Ahh rrijnders, you may not have understood my question but you answered it perfectly! Your clear explanation was exactly what I had been looking for, in fact better. Can't believe it has not been made more clear how to do that, I've been going crazy trying to find that media manager. Thank you so much for taking the time to explain!

Pr10t

  • Beginner
  • *
  • Posts: 1
Re: Has the multiple-images per product issue been addressed?
« Reply #3 on: July 07, 2008, 23:13:49 pm »
I don't understand the question  ???
Do you mean something other than the media / file manager? Through the media / file manager you can upload as many pictures as you want and they will display on the flypage:
  • Add a product (but don't add any pictures yet)and Click save
  • Click List Products
  • Next to your new product is an icon in the column that says "media"; click the icon
  • The File Manager window pops open. This lists all the existing files and media (including pictures) associated with the product

The "New" button will allow you to add new files and images. File Type Product Image (Full and Thumb) is the main image for the product that you're used to seeing. Adding files of type Additional Image will add more images that will display on your product flypage as thumbnails and also be clickable for full size.
hth
  ~~ rich

Hello, I did what you wrote too. But I see the pictures in the map (shop_image\product) but they don't show in my webshop? Any idea what  could be the reason for that? I guess it has something to do with rights but I cannot find out wich ones.

theonlycore4

  • Beginner
  • *
  • Posts: 19
Re: Has the multiple-images per product issue been addressed?
« Reply #4 on: August 13, 2008, 22:52:11 pm »
When trying to add product images using this method, I get a "Service Temporarily Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Apache/1.3.39 Server at bambooflooringinstaller.com Port 80"

error.

How to fix? Anyone's help is much appreciated.

sweb

  • Beginner
  • *
  • Posts: 2
Re: Has the multiple-images per product issue been addressed?
« Reply #5 on: September 03, 2008, 16:21:09 pm »
Is it possible to show multiple images in the lightbox effect but show only one thumbnail in the flypage?

Ricibob

  • Beginner
  • *
  • Posts: 1
Re: Has the multiple-images per product issue been addressed?
« Reply #6 on: September 04, 2008, 20:16:51 pm »
Hi,
Ive followed the above and works ok except that the thumbs are not directly on the fly page - they are displayed in a separate popup via a LINK on the flypage "View More Images" - how to get the extra images as thumbs directly on the flypage?  I have seen solutions (eg http://forum.virtuemart.net/index.php?topic=27795.msg114316) for Virtuemart 1.0 and PAY solutions (http://www.jmds.eu/shop/virtuemart-1.1.x/more-images-4-virtuemart-1.1.x.html) for Virtuemart 1.1 but nothing free for 1.1 - is there anything out there free to do this??  Thanks in advance.

morehawes

  • Beginner
  • *
  • Posts: 1
Re: Has the multiple-images per product issue been addressed?
« Reply #7 on: January 29, 2009, 16:29:48 pm »
rrijnders, thanks very much for the info. Really helpful for newbies!

klutzon

  • Jr. Member
  • **
  • Posts: 319
  • Knuckles the Echidna
    • Rage3D
Re: Has the multiple-images per product issue been addressed?
« Reply #8 on: January 29, 2009, 17:46:40 pm »
rrijnders, thanks very much for the info. Really helpful for newbies!

It's information you'd easily find if you read the User Manual... ;)
http://virtuemart.net/documentation/User_Manual/Product_Administration.html


Hi,
Ive followed the above and works ok except that the thumbs are not directly on the fly page - they are displayed in a separate popup via a LINK on the flypage "View More Images" - how to get the extra images as thumbs directly on the flypage?  I have seen solutions (eg http://forum.virtuemart.net/index.php?topic=27795.msg114316) for Virtuemart 1.0 and PAY solutions (http://www.jmds.eu/shop/virtuemart-1.1.x/more-images-4-virtuemart-1.1.x.html) for Virtuemart 1.1 but nothing free for 1.1 - is there anything out there free to do this??  Thanks in advance.

If Mark Callf doesn't mind, I'd like to give porting his module to VM 1.1x a shot, and if I manage that, I will share it with you guys. This shouldn't be too difficult, but it will take time getting used to how to port code from an old VM to the new one.

In the meantime though, I will look for an easier way for you guys to display the multiple images as thumbnails inside the product details page and not in a pop up link.

There is a member of this forum whose site I checked out recently, and he managed to get the multiple images showing as thumbnails on their product page...

Here you go, check this out: http://www.onrust-yacht-charters.com/

The author of that site is Marc. O, feel free to send him a PM to find out how he did it: http://forum.virtuemart.net/index.php?action=pm;sa=send;u=24785

DeeCee

  • Jr. Member
  • **
  • Posts: 177
Re: Has the multiple-images per product issue been addressed?
« Reply #9 on: January 30, 2009, 04:05:25 am »
i have mulitple thumbs up with it all attached through the lightbox no worries :)

just click on the entry in column "media" and upload additional images through the media manager.

They appear on the flypage and are viewable through the lightbox function

once additional images are assigned to the product id, then the media associated with the product increases according to media attached :)



I take no responsibility for any lost work. It is your responsibility to back up files before attempting anything I suggest as I may be:
a) intoxicated
b) high on sugar
c) can't concentrate due to lack of sleep

If you like my hacks, feel free to buy me a coffee, muffin or both :)

paypal: deecee23 at gmail dot com

Hacks in progress: Manufacturer Logo Hack - 100% done

Paladin Brewer

  • Beginner
  • *
  • Posts: 7
Re: Has the multiple-images per product issue been addressed?
« Reply #10 on: February 24, 2009, 05:40:49 am »
Hello,

Reading this thread, I seem to having the same problem. Ive tried it many times and I also only get one image on the fly page. Let me walk you through what I am doing and maybe you can see if there is something wrong.

1) I create a new product with whatever details. I do not add an image here. Save when finished.

2) I go to Products -> List Products.

3) In the row of the product I just created, I go to Media and click where it says (0), which brings up another interface.

4) I choose my first image. Settings are as follows:
File type: Product Image (full and thumb)
upload to: default product image path
Resize Full image and Auto-create thumbnail are both checked.
File is published is checked.
File title: test card           (name is just for testing purposes)

5) After that finished, I click on new to add a second picture.
File type: additional image
upload to: default product image path
Resize Full image and Auto-create thumbnail are both checked.
File is published is checked.
File title: test card

That's it. I save it, and then I look, and the page is only showing the first image. If I View Full, both images to show up in the lightbox, but I want both thumbs on the main page as well.

you can view at my temporary link here:

http://test.swordofthedragon.org/index.php?page=shop.product_details&flypage=flypage.tpl&product_id=9&category_id=2&option=com_virtuemart&Itemid=2

any help would be very very much so appreciated, as I seem to be stuck :/

Paladin Brewer

  • Beginner
  • *
  • Posts: 7
Re: Has the multiple-images per product issue been addressed?
« Reply #11 on: February 25, 2009, 19:46:39 pm »
Bumpers in hope of any suggestions.

macallf

  • Full Member
  • ***
  • Posts: 2411
    • Mark Callf Design
Re: Has the multiple-images per product issue been addressed?
« Reply #12 on: February 25, 2009, 19:57:39 pm »
I take it you fixed it, because checking your site both images are there!
Mark
All of My old mods are now available on my website.
Mark Callf Designs

If you like the work I've done for VM please fell free to Donate

Please Note: I am no longer actively developing or involved with VM development.

Paladin Brewer

  • Beginner
  • *
  • Posts: 7
Re: Has the multiple-images per product issue been addressed?
« Reply #13 on: February 25, 2009, 20:44:19 pm »
Um...that's weird. I didn't do anything to it at all from when it was not working. I don't know why it is working now, perhaps what was not working was just in my cache. Strange :/

Paladin Brewer

  • Beginner
  • *
  • Posts: 7
Re: Has the multiple-images per product issue been addressed?
« Reply #14 on: February 26, 2009, 05:48:33 am »
Actually it may be a Firefox issue. It seems that if I add a couple images, then go to view the product in Firefox, it will only show the 1 image. If I refresh the page than the additional images will pop up. Does not seem to be a problem in IE, however. Any thoughts on why Firefox would do that?