Author Topic: Native 1.5 SEF URL's and 1.1  (Read 4498 times)

latristesse

  • Beginner
  • *
  • Posts: 23
Native 1.5 SEF URL's and 1.1
« on: June 18, 2008, 19:55:35 pm »
At what point will I be able to use to Joomla 1.5's native SEF URL functionality and VirtueMart?  If I make menu items pointing to VM categories, then the Joomla SEF holds up but if the user clicks on a link from within VM content to categories, then the URL is non-SEF.  Also, of course, if I don't create a menu item for the product, then there is no SEF URL for the flypage.

Kind of a bummer to have to install an additional component when Joomla finally has native SEF URL's.

comicdom

  • Beginner
  • *
  • Posts: 18
    • COMICDOM
Re: Native 1.5 SEF URL's and 1.1
« Reply #1 on: June 21, 2008, 23:11:50 pm »
Definitely agreed there.

Any ideas when this support will be implemented in VM?  I'd think that development for 1.5 native SEF URLs would supersede any additional component options.
--
Kevin Bush
COMICDOM
Using VirtueMart 1.1.1 Stable on Joomla! 1.5.4 (MySQL 5.0.32 + PHP  5.2.0-8+etch11)

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27385
  • Always on vacation
    • Jenkin Hill Internet
Re: Native 1.5 SEF URL's and 1.1
« Reply #2 on: June 22, 2008, 16:07:26 pm »
It is the Joomla team who should be fixing their version of SEF, and it looks like they will be trying to do this for Joomla 1.6, but in the meantime third party developers are working to address the issues.
sh404SEF does a good job.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.6 PHP 7.0.33
Testing VM 3.4.5.10058 on Joomla 3.9.6

comicdom

  • Beginner
  • *
  • Posts: 18
    • COMICDOM
Re: Native 1.5 SEF URL's and 1.1
« Reply #3 on: June 27, 2008, 09:55:17 am »
Thank you Kelvyn, appreciate the update. =]
--
Kevin Bush
COMICDOM
Using VirtueMart 1.1.1 Stable on Joomla! 1.5.4 (MySQL 5.0.32 + PHP  5.2.0-8+etch11)