Author Topic: List of bugs in VM1.1  (Read 9247 times)

undoIT

  • Beginner
  • *
  • Posts: 37
    • Keyboard Shortcuts
List of bugs in VM1.1
« on: April 12, 2008, 18:02:50 pm »
I've been developing a site using VM1.1RC3 (RC2 reported in admin area) and Joomla 1.5.2 with core SEF (mod_rewrite) turned on over the past few days. I'm running PHP 5.2.0 and mySQL 4.1.22. Sorry if any known issues are duplicated in the list and thank you for the great component.
1. If terms and conditions are disabled, agreed checkbox is still active and required in User Fields although hidden on the frontend. This will prevent visitors from creating a new account.
Solved: Turn off options for Terms and conditions in Admin > Manage User Fields.
2. The state / province field disappears in Account Maintenance. There is a drop down but no options. Options are available during account creation.
Note: I disabled state / province because it was automatically selecting a state when set to required. After republishing state, this is not an issue.
3. Checkout with greybox does not work if a user is not logged in. After filling out the address information, the entire site is loaded in the greybox area for checkout.  Greybox checkout does seem to be working if logged in.
4. Font size is too large for greybox. Text field boxes overlap the field labels that have longer titles.
5. None of the greybox option for mod_virtuemart appear to be working.
6. The link to show cart in the module goes to a different URL than the button in the AJAX notice:
  Module: /component/virtuemart/?page=shop.cart
  AJAX Button: /component/virtuemart/index.php?option=com_virtuemart&page=shop.cart&product_id=5
7. After clicking checkout from the cart, the checkout process seems to use the same Menu parameters as the frontpage (Home). If you have assigned specific modules that you only want to appear on the home page, this becomes a problem. Especially if you are using a module position for a static mission statement at the top of the content area on the homepage.
8. None of the billing information is displayed during the first stage of checkout, even though it is entered correctly for the account.
Solved: Country field must be enabled, otherwise billing information is not displayed.
9. When adding weights to products, if something weighs less than one pound and a decimal amount is entered without a zero before the decimal point, the weight is saved as whole number. For example. .33 pounds become 33 pounds after being saved. 0.33 pounds is saved properly. (I know fuel prices are high, but I was wondering why the shipping was so freaking expensive ;)
10. After adjusting weights, USPS rates are still not being calculated properly.
Solved: Download the latest USPS module here: http://forum.virtuemart.net/index.php?topic=40284.0
11. UPS does not appear to be working. No UPS during checkout, even though all account info is entered correctly.
12. Generally prevent https option does not seem to be working. Clicking non-secure areas of the site does not change back to http.
13. All of the shop areas selected for https does not seem to work. Even though I selected all areas available, only checkout is being redirected.
14. Even though registration is set to optional, users still receive login information. Also, all of the users information is stored. This is misleading, since you would think that user information would not be stored if they don't create an account.
15. The send registration input is outside of the send registration delimiter. Also, perhaps this should read "Continue" because if the optional registration works, customers are not actually registering for an account at this point if they have unchecked the register option.
16. I don't think it is necessary to display this in the virtuemart module, "No account yet? Register". Why would somebody register through the virtuemart module if they aren't going to buy something? Registration is displayed anyways during checkout if the user isn't logged in.
17. SEF is not really working with Joomla core SEF turned on. Navigating the site works, but no clean URLs are created that reflect the categories and products.
18. Total amount in cart exceeding 1000 is displayed with a space between the thousands and the hundreds. i.e. "1000" is displayed "1 000"
Solved: Setting to change this is in Store > Edit Store

xyzbytes

  • Beginner
  • *
  • Posts: 7
Re: List of bugs in VM1.1
« Reply #1 on: April 18, 2008, 15:01:45 pm »
I'm running Joom 1.5.2 and VM 1.1 RC3 and the only issue that I had was with UPS shipping not showing up in the cart after enabling it. I found that after turning off all of the SEO functions in the Joomla config, it displaysfine and seems to work normally although I need to perform some more testing.

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: List of bugs in VM1.1
« Reply #2 on: April 18, 2008, 18:11:30 pm »
Quote
I've been developing a site using VM1.1RC3 (RC2 reported in admin area) and Joomla 1.5.2 with core SEF (mod_rewrite) turned on over the past few days.
If it says RC2 than you are not using RC3.


Quote
1. If terms and conditions are disabled, agreed checkbox is still active and required in User Fields although hidden on the frontend. This will prevent visitors from creating a new account.
The option is controlled from ‘Manage User Fields’

Quote
2. The state / province field disappears in Account Maintenance. There is a drop down but no options. Options are available during account creation.
Can not duplicate, in Account Maintenance selected country Armenia states of Armenia show in drop down list.

Quote
3. Checkout with greybox does not work if a user is not logged in. After filling out the address information, the entire site is loaded in the greybox area for checkout.  Greybox checkout does seem to be working if logged in.
Have not checked greybox checkout.

Quote
4. Font size is too large for greybox. Text field boxes overlap the field labels that have longer titles.
Have not checked greybox checkout.

Quote
5. None of the greybox option for mod_virtuemart (all in one) appear to be working.
Have not checked greybox checkout.

Quote
6. The link to show cart in the module goes to a different URL than the button in the AJAX notice:

Module: /component/virtuemart/?page=shop.cart
AJAX Button: /component/virtuemart/index.php?option=com_virtuemart&page=shop.cart&product_id=5
The module shows the content of the cart, the Ajax button either add an item to cart or shows the content of the cart.

Quote
7. After clicking checkout from the cart, the checkout process seems to use the same Menu parameters as the frontpage (Home). If you have assigned specific modules that you only want to appear on the home page, this becomes a problem. Especially if you are using a module position for a static mission statement at the top of the content area on the homepage.
It has been like this since Mambo-phpshop days, I don’t think it will change.

Quote
8. None of the billing information is displayed during the first stage of checkout, even though it is entered correctly for the account.
I am not sure what you are referring to I have billing address on Step 1 of checkout.

Quote
9. When adding weights to products, if something weighs less than one pound and a decimal amount is entered without a zero before the decimal point, the weight is saved as whole number. For example. .33 pounds become 33 pounds after being saved. 0.33 pounds is saved properly. (I know fuel prices are high, but I was wondering why the shipping was so freaking expensive 
Zero has to be used e.g 0.33 NOT .33, this is true for product price too.

Quote
10. After adjusting weights, USPS rates are still not being calculated properly.
I have heard of this too, but the person who coded USPS hasn’t been active for almost 8 months unless someone who knows about USPS shipping takes over this, I don’t see a change (head over to USPS shipping section users are collecting money to hire a coder familiar with USPS to have this fixed)

Quote
11. UPS does not appear to be working. No UPS during checkout, even though all account info is entered correctly.
Works for me, maybe you didn’t enter something correctly

Quote
12. Generally prevent https option does not seem to be working. Clicking non-secure areas of the site does not change back to http.
Joomla issue

Quote
13. All of the shop areas selected for https does not seem to work. Even though I selected all areas available, only checkout is being redirected.
Have not checked this.

Quote
14. Even though registration is set to optional, users still receive login information. Also, all of the users information is stored. This is misleading, since you would that user information would not be stored if they don't create an account.
Try build 1365 or higher, I personally have not tested the option as I want users to register on my site, the few that don’t want to register can shop somewhere else.

Quote
15. The send registration input is outside of the send registration delimiter. Also, perhaps this should read "Continue" because if the optional registration works, customers are not actually registering for an account at this point if they have unchecked the register option.
I don’t know what you are referring too.

Quote
16. I don't think it is necessary to display this in the virtuemart module, "No account yet? Register". Why would somebody register through the virtuemart module if they aren't going to buy something? Registration is displayed anyways during checkout if the user isn't logged in.
If you don’t want the option you can hide it in module configuration.

Quote
17. SEF is not really working with Joomla core SEF turned on. Navigating the site works, but no clean URLs are created that reflect the categories and products.
VirtueMart does not support Joomla core SEF, maybe in a later version.

patrik60

  • Guest
Re: List of bugs in VM1.1
« Reply #3 on: April 20, 2008, 18:10:44 pm »
Quote
7. After clicking checkout from the cart, the checkout process seems to use the same Menu parameters as the frontpage (Home). If you have assigned specific modules that you only want to appear on the home page, this becomes a problem. Especially if you are using a module position for a static mission statement at the top of the content area on the homepage.

This only happens with Joomla 1.5.2. No problems in Joomla 1.0.15.

Patrik

hifist

  • Beginner
  • *
  • Posts: 3
Re: List of bugs in VM1.1
« Reply #4 on: June 24, 2008, 22:21:50 pm »
Quote
8. None of the billing information is displayed during the first stage of checkout, even though it is entered correctly for the account.
I am not sure what you are referring to I have billing address on Step 1 of checkout.

I was able to duplicate this defect/bug. It occurs (at least), when country is disabled from user address fields. If country is "NULL", no billign information is displayed. When I changed that value to DB, address appeared.

Noticed tracker item (Bug [# 2129]) of this too.

voonixs

  • Beginner
  • *
  • Posts: 24
    • Voonix - Nästa generations hemsidor
Re: List of bugs in VM1.1
« Reply #5 on: June 24, 2008, 22:32:40 pm »
So wich is the best way: (don't want to use countries if thats possible)

-Delete the country field
-Enable country so my users must makte this chooice

undoIT

  • Beginner
  • *
  • Posts: 37
    • Keyboard Shortcuts
Re: List of bugs in VM1.1
« Reply #6 on: June 24, 2008, 22:37:52 pm »
I deleted all of the countries I know I won't be using. It would be nice to hide the country drop-down altogether, but it needs to be enabled.

Another small bug is that if you make State/Province/Region required, it automatically selects the first alphabetical state in the list. Sometimes customers forget to change this and it screws up shipping calculation. I think this may be a Joomla issue because I have seen this behavior in other components when making a dropdown list required.

voonixs

  • Beginner
  • *
  • Posts: 24
    • Voonix - Nästa generations hemsidor
Re: List of bugs in VM1.1
« Reply #7 on: June 24, 2008, 23:53:28 pm »
Well that bugg i will love if i got it =D I will only use 1 country.

undoIT

  • Beginner
  • *
  • Posts: 37
    • Keyboard Shortcuts
Re: List of bugs in VM1.1
« Reply #8 on: June 25, 2008, 04:47:08 am »
Found another issue. When the total amount in the cart is 1,000 or greater, the amount is displayed "1 000". If you have a narrow template, this causes the total amount to break to the next line. Looks like this:

Total: $1
      025.00

It would be best to display the amount without the space or a comma.

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: List of bugs in VM1.1
« Reply #9 on: June 25, 2008, 06:30:13 am »
In Store configuration instead of space use comma.

hifist

  • Beginner
  • *
  • Posts: 3
Re: List of bugs in VM1.1
« Reply #10 on: June 25, 2008, 06:44:16 am »
Well that bugg i will love if i got it =D I will only use 1 country.

I'm going to use one country (Finland) only too (at least at beginning). But maybe that country selection has to be displayed in Registration form. Luckily it can be removed from other screens.

undoIT

  • Beginner
  • *
  • Posts: 37
    • Keyboard Shortcuts
Re: List of bugs in VM1.1
« Reply #11 on: June 25, 2008, 06:58:07 am »
In Store configuration instead of space use comma.
Perfect, thanks! I looked all through Admin > Configuration and couldn't find the option. Deleted the space and now the total displays properly.