Author Topic: Problem with mod_virtuemart_cart  (Read 6791 times)

kwgerdyk

  • Beginner
  • *
  • Posts: 12
Problem with mod_virtuemart_cart
« on: May 26, 2008, 18:20:48 pm »
I have a problem with the  mod_virtuemart_cart. When I add a product to the cart everything is fine. But when i add another product to the cart it's added to the  mod_virtuemart_cart. But when i click on the "Goto CART" the second product is deleted from the cart. But when i click on refresh all products come back in the cart.

Recently i have moved my installation up 1 directory (from "/test" to the root). Maybe it is wise to do re install of the " mod_virtuemart_cart" ??

It's really a big, big problem. The whole cart is not reliable anymore. If you delete products and you go back to the shop they appear again.


I am using:

Joomla 1.5.3.
VM 1.1.

kwgerdyk

  • Beginner
  • *
  • Posts: 12
Re: Problem with mod_virtuemart_cart
« Reply #1 on: May 28, 2008, 14:54:59 pm »
Is it possible that the refresh rate of the dbase is too slow?? I did a clean install en after 10 minutes or so the problem came up again.


clockwood

  • Beginner
  • *
  • Posts: 44
Re: Problem with mod_virtuemart_cart
« Reply #2 on: June 01, 2008, 03:19:13 am »
Don't take this the wrong way, but how many people add stuff to their cart, then delete it and go add something else?

I'm not saying that shouldn't work, but I'll bet 95% of the time it's add to cart, then checkout. Or at least right before checkout they delete any unwanted items.

Graphic 3

  • Jr. Member
  • **
  • Posts: 203
    • Graphic 3
Re: Problem with mod_virtuemart_cart
« Reply #3 on: June 01, 2008, 07:00:37 am »
your post doesn't help resolve his problem at all...
iPhone, Droid and Blackberry App downloads and reviews
http://www.app-talk.com

chaliet

  • Guest
Re: Problem with mod_virtuemart_cart
« Reply #4 on: June 01, 2008, 07:14:45 am »
I agree with kade119's point, and also add that clockwood misunderstands what kwgerdyk is saying.  Kwgerdyk is not deleting the product, it is just not appearing in the cart module until after refresh.

Out of curiosity, would you try disabling your ajax cart pop-up feature and see if the problem still exists?

Disable ajax add to cart:
Go to Admin, Configuration, "Site" tab, in "Layout" section, click on the "Configuration" link.  Select "No" for "Use Ajax to add, update or delete products from the cart?"

kwgerdyk

  • Beginner
  • *
  • Posts: 12
Re: Problem with mod_virtuemart_cart
« Reply #5 on: June 01, 2008, 10:09:41 am »
With the help of the Dutch Joomla forum we did the following (it was a lot of work  :). I build my webpage local the same as online and then it worked fine. But when i did a sql dump and uploaded it online the problems where there again. A lot of problems with the virtuemart module. Our conclusion was this: if the site works fine locally why doesn't it work fine online. So we think it is a host problem. I will test some more today maybe i have overlooked something in the way i do the sql dump, but our main conclusion is that the problem is the host.

@Cahliet
Yes I tried to delete Ajax add to Cart, but that did not help either. From the beginning of my problems i have always thought that it can't be a Virtuemart problem.

@Clockwood

A Cart has to be the most reliable thing on your website, period. So i'll keep on testing and changing until i get it right.