Author Topic: cookie check not working  (Read 7983 times)

DDPaul

  • Beginner
  • *
  • Posts: 28
cookie check not working
« on: May 29, 2008, 01:18:00 am »
I'm getting a strange cookie error. I have the cookie check enabled but in firefox with cookies disabled all that happens is that the cart remains empty when I  click on the add to card link. No notice is shown informing users that they need to enable cookies in order to purchase products.

my configuration is:
joomla! 1.5.3(cache off , SEF off);virtuemart1.1.0 stable (23/04/2008); Firefox 2.0.0.14 (both javascript enabled and disabled); Internet Explorer 7.0.6001.18000;  Apache 2.2.8; MySQL 5.0.51a; PHP 5.2.5
both joomla! and virtuemart configured with sample data installed
sample site configured as per forum discussion
http://forum.virtuemart.net/index.php?topic=39100.0

any help solving this problem will be appreciated.

DDPaul

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26042
  • Always on vacation
    • Jenkin Hill Internet
Re: cookie check not working
« Reply #1 on: May 29, 2008, 22:28:46 pm »
Are you closing the browser down after an admin session and then re-opening for testing?
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.3.9579 on Joomla 3.7.3 PHP 7.0.19

Testing VMVM3.2.4 on J!3.7.3

DDPaul

  • Beginner
  • *
  • Posts: 28
Re: cookie check not working
« Reply #2 on: May 30, 2008, 00:23:53 am »
YES. I connected (on localhost)to admin using IE7 to enable the cookie check. I closed IE 7 and then tested with firefox with cookies not accepted. 

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26042
  • Always on vacation
    • Jenkin Hill Internet
Re: cookie check not working
« Reply #3 on: May 30, 2008, 11:48:34 am »
OK I just confirmed this with Firefox and Opera using the latest SVN of VM1.1. I made sure cookie check was turned on, too. Have added it to the bug tracker, thanks.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.3.9579 on Joomla 3.7.3 PHP 7.0.19

Testing VMVM3.2.4 on J!3.7.3

elallaix

  • Beginner
  • *
  • Posts: 2
Re: cookie check not working
« Reply #4 on: June 10, 2008, 19:56:24 pm »
I have the same problem with Joomla 1.0.15 and VirtueMart 1.1.0

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 26042
  • Always on vacation
    • Jenkin Hill Internet
Re: cookie check not working
« Reply #5 on: June 11, 2008, 12:19:36 pm »
It will be fixed in the VM1.1.1 release, due out soon.
Kelvyn

Jenkin Hill Internet,
Keswick, Lake District

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM3.2.3.9579 on Joomla 3.7.3 PHP 7.0.19

Testing VMVM3.2.4 on J!3.7.3

elallaix

  • Beginner
  • *
  • Posts: 2
Re: cookie check not working
« Reply #6 on: January 07, 2009, 22:37:37 pm »
I have always the same problem with virtuemart 1.1.2 + joomla 1.0.15

can you help me? thanks

robynm

  • Beginner
  • *
  • Posts: 7
Re: cookie check not working
« Reply #7 on: January 08, 2009, 07:21:53 am »
I am also having intermittent cookie issues problems with Virtuemart 1.1.2 + Joomla 1.5.8 when browsing with FF v.3.0.5.

debengel

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: cookie check not working
« Reply #8 on: December 08, 2015, 03:04:50 am »
I have the same problem and can not add products or go to my cart page to check out. Anyone knows a solution?

GJC Web Design

  • 3rd party VirtueMart Developer
  • Hero Member
  • *
  • Posts: 7485
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 2.6.22 & 3.2.2
Re: cookie check not working
« Reply #9 on: December 08, 2015, 09:57:46 am »
your 3rd post for the same problem.. your not helping yourself... 
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation