Author Topic: Frontend shows english instead of translation (hebrew)  (Read 16864 times)

A K

  • Beginner
  • *
  • Posts: 19
Frontend shows english instead of translation (hebrew)
« on: May 26, 2008, 04:12:33 am »
Hi.

I've made a copy of each lang file and renamed them to hebrew.php - in corresponding directories of course.

At the backend everything is fine, but in frontend english strings are displayed, although all the rest is in hebrew.

VMLM is showing that there's two languages and allows to edit both hebrew and english files.

I've triple-checked everything but it just seems that for some reason only english tokens are being displayed at the frontend.


Pisu

  • Moderator
  • Jr. Member
  • *
  • Posts: 451
  • ..still looking for..
    • Blog di Stefano Bagnatica
Re: Frontend shows english instead of translation (hebrew)
« Reply #2 on: May 31, 2008, 08:01:59 am »
Do you have correctly installed the hebrew language in Joomla? VM automatically use the language configured inside Joomla, as default language. And, if you have this Joomla hebrew pack, look inside the XML file definition, the "backwardLang" must be used as files name (commonly "italian", "french"...).
Pisu - Team VMItalia (Supporto Italiano VirtueMart)
www.stefanobagnatica.it | www.vmitalia.net

A K

  • Beginner
  • *
  • Posts: 19
Re: Frontend shows english instead of translation (hebrew)
« Reply #3 on: June 01, 2008, 06:14:37 am »
No SEF, will be installing it in a day or two - hopefully there won't be too much problems.

This is the content of he-IL.xml
Code: [Select]
<?xml version="1.0" encoding="utf-8"?>
<metafile version="1.5"  client="site" >
<tag>he-IL</tag>
<name>Hebrew (Israel)</name>
<description>Joomla!Hebrew Site Translation - by Mati (MtK) Kochen</description>
<version>1.5.0-RC4</version>
<creationDate>Nov 2007</creationDate>
<author>Mati (MtK) Kochen - Hebrew Translation Team Coordinator - joomla.co.il</author>
<authorUrl>www.smartmtk.com</authorUrl>
<authorEmail>mtk@smartmtk.com</authorEmail>
<copyright>(C) 2007 - 2008 Mati (MtK) Kochen. All rights reserved.</copyright>
<license>http://www.gnu.org/licenses/gpl-2.0.html GNU/GPL</license>
<metadata>
<name>Hebrew (Israel)</name>
<tag>he-IL</tag>
<rtl>1</rtl>
<locale>heb_IL.utf-8,heb_IL.utf8,he_IL.utf-8,he_IL.utf8,he,hebrew,israel,il,he-IL,heb-IL,he-IL.uft8,heb-IL.utf-8,he-il</locale>
<winCodePage>windows-1255</winCodePage>
<backwardLang>hebrew</backwardLang>
<pdfFontName>freesans</pdfFontName>
</metadata>
<params />
</metafile>

At backend hebrew is OK, at frontend also OK including Joomfish - but for some reason there's no &lang=he in URL and virtuemart shows only english @ front end.

$mosConfig_lang contains he-IL
flypage templates are red from /default_rtl/templates
i've made two copies of all VM lang files and named htem hebrew.php and he-IL.php

but nothing helps :(
at localhost however everything is working fine

mtk

  • Jr. Member
  • **
  • Posts: 96
  • Joomla & RTL Expert
    • MtK - Smart Internet Solutions
Re: Frontend shows english instead of translation (hebrew)
« Reply #4 on: June 01, 2008, 08:34:47 am »
are you using some kind of SEF component?
can you answer this?
Which version of Joomla & VM are you using?

A K

  • Beginner
  • *
  • Posts: 19
Re: Frontend shows english instead of translation (hebrew)
« Reply #5 on: June 01, 2008, 08:36:11 am »
I'm not using any SEF component yet.
Joomla 1.5.3
VM 1.1.0


A K

  • Beginner
  • *
  • Posts: 19
Re: Frontend shows english instead of translation (hebrew)
« Reply #7 on: June 01, 2008, 09:11:33 am »
yes, i think so.
הורשה: 1.0

mtk

  • Jr. Member
  • **
  • Posts: 96
  • Joomla & RTL Expert
    • MtK - Smart Internet Solutions
Re: Frontend shows english instead of translation (hebrew)
« Reply #8 on: June 01, 2008, 11:46:26 am »
Try setting it to OFF, & go directly into the VM pages (front-end).
I just want to eliminate this issue...

A K

  • Beginner
  • *
  • Posts: 19
Re: Frontend shows english instead of translation (hebrew)
« Reply #9 on: June 02, 2008, 02:12:14 am »
After i've set it off and disabled JEvent Calendar it started to show hebrew in VM frontend.
on the flypage there was error:
Parse error: syntax error, unexpected T_STRING in /home/xxx/public_html/administrator/components/com_virtuemart/classes/ps_product.php(2090) : eval()'d code on line 1:

$mosConfig_lang = hebrew

and price behaves a bit strange -
381.15 ₪ (including 15.5 % tax) - with legacy on
381.15 ₪ (כולל $tax % מע"מ) - with legacy off

mtk

  • Jr. Member
  • **
  • Posts: 96
  • Joomla & RTL Expert
    • MtK - Smart Internet Solutions
Re: Frontend shows english instead of translation (hebrew)
« Reply #10 on: June 02, 2008, 09:35:11 am »
it is obviously something interfering the process, try disabling any other components and/or plugins.
(even better, try it on a clean installation)

A K

  • Beginner
  • *
  • Posts: 19
Re: Frontend shows english instead of translation (hebrew)
« Reply #11 on: June 02, 2008, 09:53:20 am »
after turning on and off some modules i've determined that disabling Joomfish Absractraction Layer has exactly the same effect - same error message, etc.

A K

  • Beginner
  • *
  • Posts: 19
Re: Frontend shows english instead of translation (hebrew)
« Reply #12 on: June 02, 2008, 10:25:02 am »
apparently the problem was with JoomFish 2.0 beta interfering with legacy plugin.

Is there any other way to make bilingual bidirectional e-store based on joomla 1.5 & VM 1.1 ?

mtk

  • Jr. Member
  • **
  • Posts: 96
  • Joomla & RTL Expert
    • MtK - Smart Internet Solutions
Re: Frontend shows english instead of translation (hebrew)
« Reply #13 on: June 02, 2008, 10:26:21 am »
currently, wait till JF is stable.

do you have you Joomla+VM ready?
if not, then finish it first, with one language, then add the second...

A K

  • Beginner
  • *
  • Posts: 19
Re: Frontend shows english instead of translation (hebrew)
« Reply #14 on: June 02, 2008, 10:33:00 am »
yeah
probably that's what i'm gonna do.

Thank you for your help.

BTW
what could be done to avoid VM's ps_product.php error while handling מע"מ ?
if i just write מעמ it's ok, but with double quotes it wont work with following error message:
Parse error: syntax error, unexpected T_STRING in /home/xxx/public_html/administrator/components/com_virtuemart/classes/ps_product.php(2090) : eval()'d code on line