Author Topic: Have I to enable mod_rewrite ??  (Read 4879 times)

YtseDrummer

  • Beginner
  • *
  • Posts: 21
Have I to enable mod_rewrite ??
« on: May 22, 2008, 12:48:38 pm »
Hi!

I have enabled sh404sef and I'm using:

+Joomla! 1.5.2 Production/Stable
+VirtueMart 1.1.0 RC2
+sh404SEF 134 stable


Joomla SEO functions is working fine with normal page and is using this URL name structure:
ALL-OTHER_PAGE:
Code: [Select]
http://www.euroweb97.com/cms/index.php/pannello-di-controllo
I have installed sh404sef for supporting SEF URL with VirtueMart.
I have enabled mod_rewrite on Joomla the name of the URL is this:
I
VM_PAGE:
Code: [Select]
http://www.mysite.com/cms/component/virtuemart/?page=shop.browse&category_id=7
In this way, with the page staring with "?page=", I can't create custom SEF URL in sh404sef control panel...

If I disabled mod_rewrite on Joomla the VM_URL change to:
Code: [Select]
http://www.mysite.com/cms/index.php/component/virtuemart/?page=shop.browse&category_id=7
Now, in the URL, there is the "index.php" so I tried to set a custom SEF URL:

Is it correct?

YtseDrummer

  • Beginner
  • *
  • Posts: 21
Re: Have I to enable mod_rewrite ??
« Reply #1 on: May 23, 2008, 12:13:41 pm »
up

_fD_

  • Jr. Member
  • **
  • Posts: 118
    • Printdesign :: Joomla! CMS Webdesign :: Apple Computer Support
Re: Have I to enable mod_rewrite ??
« Reply #2 on: May 26, 2008, 13:20:27 pm »
Hi

do you have installed the sef_ext for virtuemart and do you have renamed the htaccess.txt to .htaccess?

And for SEF-URLs without the index.php you have to activate the mod_rewrite.

Regards, Urs