Author Topic: Problem with url-rewrite on VirtueMart  (Read 11883 times)

YtseDrummer

  • Beginner
  • *
  • Posts: 21
Problem with url-rewrite on VirtueMart
« on: May 20, 2008, 14:56:45 pm »
Hi!

I've read the sh404sef's FAQ but I couldn't find anything that could help me...

I've installed
+Joomla! 1.5.2 Production/Stable
+VirtueMart 1.1.0 RC2
+sh404sef 1.0.4_Beta - build_60

-I've enabled the "legay mode" plugin in order to make sh404sef working on J1.5!

-I've enabled Joomla's SEO function:


-Ho attivato il componente sh4sef senza aggiungere nessun'altra opzione. Gli url delle categorie normali funzionano come voluto.
-I have activated sh404sef component without making any configuration and the cagegory's url is working
-Then, I tried to make a manual configuration for a VirtueMart link:


The VirtueMart is still the old one... Why?
Does the cache must be activated?

korb

  • Quality&Testing Team
  • Full Member
  • *
  • Posts: 685
  • VM 2.0 in heavy testing
    • Buy my work
Re: Problem with url-rewrite on VirtueMart
« Reply #1 on: May 21, 2008, 23:40:54 pm »
1. Before all, make a good back-up if you have something valuable (product pictures, databases - I hope you didn't started a Joomla production site with theese versions...)
2. Please use or try to update all to:
-Joomla 1.5.3
-Virtue Mart 1.1.0 stable
-sh404SEF 134 stable

4. Make sure you have published the sef module in module manager, and youo must use mod_rewrite Si.
Come back, and give a feedback.

5. If it doesn't work, try the configuration in my avatar.
Ciao

YtseDrummer

  • Beginner
  • *
  • Posts: 21
Re: Problem with url-rewrite on VirtueMart
« Reply #2 on: May 22, 2008, 09:22:42 am »
Hi!

Thanks for the answer.
Now I have te possibility to update only sh404sef. When all the project will be ready I will set all the latest versions of Joomla and VM in production environment
Now I will try to install this version: com_sh404SEF_Version_1.3.4_build_288.joomla.zip

Shoul I have to enable the legacy mode plugin in order to make sh404sef working?

YtseDrummer

  • Beginner
  • *
  • Posts: 21
Re: Problem with url-rewrite on VirtueMart
« Reply #3 on: May 22, 2008, 09:41:11 am »
I've installed the latest version of sh404sef.
In the configuration panel I have this error:
Quote
Notice: Undefined index: mosConfig_locale in /var/www/vhosts/mysite.com/httpdocs/cms/administrator/components/com_sef/sh404sef.class.php on line 1889
Code: [Select]
$shTemp = explode( '_', $GLOBALS['mosConfig_locale']);
I want to set a custom SEF url.
The starting link is:
Quote
http://www.mysite.com/cms/component/virtuemart/?page=shop.browse&category_id=6

But it doesn't starts with index.php...

This is my .htaccess file:
Code: [Select]
##
# @version $Id: htaccess.txt 9975 2008-01-30 17:02:11Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On


#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

RewriteBase /cms


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section


########## Begin - 3rd Party SEF Section
############# Use this section if you are using a 3rd party (Non Joomla! core) SEF extension - e.g. OpenSEF, 404_SEF, 404SEFx, SEF Advance, etc
#
RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
#
########## End - 3rd Party SEF Section

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

What I have to do?