Author Topic: [sh404SEF] blank page after the installation  (Read 7579 times)

YtseDrummer

  • Beginner
  • *
  • Posts: 21
[sh404SEF] blank page after the installation
« on: May 19, 2008, 16:18:09 pm »
Hi!

I'm using Joomla! 1.5.2 with VirtueMart 1.1.0 RC2. It's all working with this configuration:


I've tried to install sh404sef (com_sh404SEF-15_1.0.4_Beta_build_60.joomla1.5.x.zip) using the automatic installation on the administration's Joomla panel.
Then, I tried to access to sh404sef panel, but I always have a blank page...

Why?

YtseDrummer

  • Beginner
  • *
  • Posts: 21
Re: [sh404SEF] blank page after the installation
« Reply #1 on: May 20, 2008, 11:11:31 am »
I forget to enable PHP error display. So I have:


Quote
Notice: Undefined variable: acl in /var/www/vhosts/sito/httpdocs/cms/administrator/components/com_sh404sef/admin.sh404sef.php on line 16

Fatal error: Call to a member function acl_check() on a non-object in /var/www/vhosts/sito/httpdocs/cms/administrator/components/com_sh404sef/admin.sh404sef.php on line 16
   

line 16:
Code: [Select]
[tt]if (!($acl->acl_check('administration', 'edit', 'users', $my->usertype, 'components', 'all')[/tt]
code around line 16:
Code: [Select]
[tt]// Ensure that user has access to this function.
if (!($acl->acl_check('administration', 'edit', 'users', $my->usertype, 'components', 'all')
    | $acl->acl_check('administration', 'edit', 'users', $my->usertype, 'components', 'com_sh404sef'))) {
    mosRedirect('index2.php', _NOT_AUTH);[/tt]

I didn't touch this file before and after the sh404installation.


shumisha

  • Beginner
  • *
  • Posts: 35
    • Joomla sef url with sh404sef
Re: [sh404SEF] blank page after the installation
« Reply #3 on: June 27, 2008, 14:17:00 pm »
Hi,

The above is not valid anymore, it's been some time sh404sef operates natively on Joomla 1.5. Please make sure you check for the lateest version, or even latest development version available at http://download.siliana.com/category.php?id=2

Rgds