Author Topic: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5  (Read 679190 times)

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #60 on: June 05, 2008, 18:36:12 pm »
Have you tried to install(upload) the files again?
Maybe they did not overwrite the first time.
You can also place a printscreen of your product status tab, to see how it looks

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #61 on: June 05, 2008, 18:52:43 pm »
I'll try to upload the files again, also if that doesn't work I'll try to find a way to upload a screenshot here ;)
Thanks for help and hope I don't have to write about this again :)

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #62 on: June 05, 2008, 19:03:53 pm »
Quick question:
Do I have to modify my files like the old times (http://forum.virtuemart.net/index.php?topic=28192.msg79490#msg79490) or is it enough if i just upload the files again?

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #63 on: June 05, 2008, 19:23:47 pm »
I think i've solved the problem.
As my site is in Swedish, the Custom Attributes didn't show up.
Was about to change language to english (to take a screenshot), but there it was.  :o :)

Hope you will fix this til next release :) But for now I'm just too happy that it worked  ;D

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #64 on: June 05, 2008, 19:33:22 pm »
Glad it works in English.
Did the VM custom attributes work before the hack?

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #65 on: June 05, 2008, 22:59:20 pm »
I don't think they did :/
I'll make another try with a basic version in another DB.

EDIT:
Doesn't work from start (Using VM pack with Latest VM & Joomla)

Also Noticed that code strings like this doesn't work for me:
(Ignore the "")

"javascript:document.adminForm.toggle.onclick();vm_submitButton('new','adminForm','product.product_form');"

Including the buttons which the link comes from. (Attached a screenie)

I have no clue what is going on with my site, if these problems are client related (my browser/software who isn't correct/good) or if it's the webhost that blocks it. :S

[attachment cleanup by admin]

marianaf

  • Beginner
  • *
  • Posts: 24
HELP!
« Reply #66 on: June 06, 2008, 00:04:24 am »
HELLO TO ALL!

I´M getting a bit crazy with this. My problem is:
1) I had installed the hack and everything went good, I could give attributes do child products (which is my main need for the shop)
2) today, something went wrong, I don´t know what. The child attributes were gone (please see attached pdf).
3) I came back, downloaded the hack again, uploaded all the files. When I entered the flypage of the product the following error message is displayed:

Fatal error: Class 'JHTMLBehavior' not found in /home/tereecom/public_html/joomla/components/com_virtuemart/themes/default/templates/product_details/includes/addtocart_form.tpl.php on line 23

4) I uploaded the older addtocart_form.tpl.php and the page is allright but the attributes are still missing. If you want to see it, please go to:
http://www.teresafrade.com/joomla/index.php?page=shop.product_details&flypage=flypage.tpl&product_id=23&category_id=6&option=com_virtuemart&Itemid=106

What do you think I should do?

please see the pdf....i´m so frustrated! I had spent long hours to achieve it and now it´s gone...I think it happened at any time when I was costumizing the layout..

thank you so much..

Mariana

[attachment deleted by admin]

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #67 on: June 09, 2008, 20:39:14 pm »
My problems were solved when I changed webhost.
Many thanks for your help Marco, now I'm just waiting for the final conversion of this excellent hack (with support for swedish ;) ).

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #68 on: June 10, 2008, 07:37:41 am »
Hi

I'm not sure your problem is related to the hack.
Your problem is attribute field not showing up in the VM admin, am I right?
If so, this file is not modified by the hack.
Think you have to look at the VM language files, or just leave the backend in english.

@marianaf
Sorry I don't have time to help you. It's very busy at the moment at my place.
And it seems your problem is no hack bug/problem.
Hope you find an other way to solve your problem.

jimspice

  • Beginner
  • *
  • Posts: 41
    • Me
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #69 on: June 10, 2008, 19:36:23 pm »
Quote
Fatal error: Class 'JHTMLBehavior' not found in /home/tereecom/public_html/joomla/components/com_virtuemart/themes/default/templates/product_details/includes/addtocart_form.tpl.php on line 23

I am receiving the same error.  Where exactly is 'JHTMLBehavior' defined?

Spice
Joomla 1.5.6
VirtueMart 1.1.2 stable
Custom Attributes Extended Hack 2.15

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #70 on: June 11, 2008, 11:25:01 am »
Can you tell me when the error happens?

jimspice

  • Beginner
  • *
  • Posts: 41
    • Me
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #71 on: June 11, 2008, 11:45:35 am »
I found andre.maito's suggestion (post #49 on last page) and that seemed to work.

However...when I use the date syntax and child lists two date fields will not work.

More digging perhaps.
Joomla 1.5.6
VirtueMart 1.1.2 stable
Custom Attributes Extended Hack 2.15

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #72 on: June 11, 2008, 11:54:16 am »
I will give JK the info.
And see if he's got an answer.

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #73 on: June 11, 2008, 21:36:44 pm »
If you comment out the $echo calendar thingy on line 23 or whatever the error is, no error will show up.
Thou, I dunno if it affects the functionallity of VM or CA.

@Marco
Seems it works in swedish aswell :)
Never mind the last post :) (But the thanks ofc ;))

ivo claessens

  • Beginner
  • *
  • Posts: 11
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #74 on: June 11, 2008, 22:46:54 pm »
Hi,
I installed the hack on my installation of Joomla 1.5.3 and VM 1.1.0.
In the backoffice the hacks seems to work fine, but when i open de site and open an shop item (with or withour custom attributes) i just gat a white screen, Nothing loads!
I tried to change to a standard joomla template and change the language to english, but both make no difference.
Does anyone have any idea what i am doing wrong here?
Thanks,
Ivo