Author Topic: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5  (Read 671711 times)

korb

  • Quality&Testing Team
  • Full Member
  • *
  • Posts: 685
  • VM 2.0 in heavy testing
    • Buy my work
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #45 on: May 28, 2008, 14:14:45 pm »
Interesting project
Keep on going guys :)

korb

  • Quality&Testing Team
  • Full Member
  • *
  • Posts: 685
  • VM 2.0 in heavy testing
    • Buy my work
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #46 on: May 28, 2008, 20:16:30 pm »
I wish for this feature:
-to be compatible with a future feature/plugin for virtuemart for product comparison, so only theese atributes show up there.
-offer suport for development of a filtering products by theese coustom atributes extended.

I want to much?

andre.maito

  • Beginner
  • *
  • Posts: 8
Problems w multiple Image Upload
« Reply #47 on: June 02, 2008, 22:18:36 pm »
I'm having problems when I put 2 'file' attribute. The first is -r and the second is not. When I upload 1 file it work's fine, but when I try to upload 2 files it crashes. A blank page is shown.

Any Ideas?? Thanks!

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #48 on: June 02, 2008, 22:33:50 pm »
Hi

I tried to reproduce your problem, but mine is working fine.

Could you share more info?
Versions you use, maybe filesize you try to upload etc.

andre.maito

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #49 on: June 03, 2008, 01:26:44 am »
Hi, I'm using J! 1.5.3 w/ Virtuemart 1.1.0 (in fact i've installed the Joomla! 1.5.3 eCommerce Edition)

At first I've got an error with
Code: [Select]
JLoader::import('joomla.html.html.behavior');
JHTMLBehavior::calendar();
and changed to
Code: [Select]
JHTML::_('behavior.calendar');
After that the file upload begins to work (1 file only). After that I tried to put 2 file attributes, but a blank page is being shown after adding to cart.

I'm using the attribute like this (maybe the error is here):
Arquivo(file-r)(Imagem a ser impressa na almofada.|field-below)(images/|.jpg,.cdr|0);Arquivo2(file)(Imagem a ser impressa na almofada.|field-below)(images/|.jpg,.cdr|0)

You can check this at http://macroart.tempsite.ws/index.php?page=shop.product_details&flypage=flypage.tpl&product_id=1&category_id=1&option=com_virtuemart&Itemid=2

Thanks...

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #50 on: June 03, 2008, 08:03:54 am »
Hi

I tried your link, but also had no problem uploading on your site.
Files to big? Timeout?

andre.maito

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #51 on: June 03, 2008, 14:32:01 pm »
Hi
I tried your link, but also had no problem uploading on your site.
Files to big? Timeout?
Now it's working for me too... Anyway... Thanks for help and for the hack... Donations are going to be made in the end of this work!

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #52 on: June 03, 2008, 14:38:27 pm »
Good to hear... :)

andre.maito

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #53 on: June 03, 2008, 18:41:47 pm »
Check this: When I upload one or two files for the first time, it works fine. But When I do it for the second time, I gov an error.

Doesn't matter if I delete the item from the cart or not.

Can you check it for me (again)?

thanks!

http://macroart.tempsite.ws/index.php?page=shop.product_details&flypage=flypage.tpl&product_id=1&category_id=1&option=com_virtuemart&Itemid=2

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #54 on: June 03, 2008, 21:33:28 pm »
Yes, I'm getting it also on your site.
But on my own site, again no problems.

I don't know what to think about this one, maybe someone else knows?

gerasimos

  • Beginner
  • *
  • Posts: 3
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #55 on: June 04, 2008, 10:47:40 am »
I have a question about upload file.. it is possible to have in cart a thumb of this file if it is image and a link of this image in confirmation email.. ?????

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #56 on: June 04, 2008, 11:03:13 am »
Allmost everything is possible.
It only has to be coded in.
I'm not a coder, so someone else has to add this in if you want it.(paid or for free)
I have no real need for this myself.

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #57 on: June 05, 2008, 18:06:18 pm »
I have a problem with installing CA-hack for latest VM & Joomla.
I've replaced the files, as instructions say, but can't find where to add the ca-syntaxes? (Extra attributes in product doesn't work, which I thought it would.)

Also I have a smaller problem with my site, dunno if it's server related, joomla/vm configuration related or client-related, but I can't add property or attributes to a product, more than the first line with one property.

Any ideas how to solve these?

Keep Up This Wonderful Project (It's Awsome)
/Krille

Marco

  • Jr. Member
  • **
  • Posts: 139
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #58 on: June 05, 2008, 18:15:38 pm »
CA attributes are placed in the "Custom Attribute List" you find under the "Product Status" tab.
If you place the right syntax, it should work, or at least do something.

krille_kp

  • Beginner
  • *
  • Posts: 8
Re: Converted Custom Attributes Extended Hack 2.1 for VM 1.1 + J1.5
« Reply #59 on: June 05, 2008, 18:22:08 pm »
Thanks for a quick answer.
Thou I cannot find anything like "Custom Attributes List".
Only thing in product status is "Attributelist:" which doesn't work (as I said above ;) ) and "Extra attribute:" which doesn't want to make the CA-syntaxes show up like they should. Atm it's just printing the text as if I haven't "installed" CA-hack :S