Author Topic: Category Menu Icon / Images  (Read 11760 times)

Rhals

  • Beginner
  • *
  • Posts: 9
Category Menu Icon / Images
« on: April 27, 2008, 17:34:16 pm »
Good Morning:

Wonderful software! :)  I am using Joomla 1.5.3 and Virtuemart 1.1.  Things are going well.  Question.  When I turn on the category module, the JS menu works as intended.  However, the image or icon is missing. 

Can anyone tell me how to resolve? 

If this is covered in another forum or I have placed this in the wrong forum, my apologies!  :)

Thanks,

Rich Halsey
www.morethanrugs.com

 

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27466
  • Always on vacation
    • Jenkin Hill Internet
Re: Category Menu Icon / Images
« Reply #1 on: April 29, 2008, 00:05:19 am »
Not clear to me which image is missing. Is this with IE7? What about FireFox?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.10 PHP 7.0.33
Testing VM 3.5.0.10097 on Joomla 3.9.10

Rhals

  • Beginner
  • *
  • Posts: 9
Re: Category Menu Icon / Images
« Reply #2 on: April 29, 2008, 15:57:32 pm »
Kelvyn:

Thanks for responding!

It is in IE7 and the Red X on the JSCook office Menu. 

Thanks,

Rich Halsey

Rhals

  • Beginner
  • *
  • Posts: 9
Re: Category Menu Icon / Images
« Reply #3 on: April 30, 2008, 14:55:11 pm »
More information:
JSCook Menu:  ThemeOffice
* IE7  Red X where the icon should be
* Firefox  No icon at all

Hope this makes thisngs more clear.

Thanks for your time and the help!

Rich Halsey

spacialek

  • Jr. Member
  • **
  • Posts: 56
    • Xaomé - Intégration Joomla
Re: Category Menu Icon / Images
« Reply #4 on: April 30, 2008, 22:37:34 pm »
Hi,

I'm having the same problem with JsCook Menu, images are not displayed in Firefox, in Opera and in Safari, it's displaying a missing image symbol (see the attached screenshot of JSCookMenu in Safari, Windows XP)

Anybody knows how to fix that ? 

[attachment cleanup by admin]

Rhals

  • Beginner
  • *
  • Posts: 9
Re: Category Menu Icon / Images
« Reply #5 on: May 01, 2008, 04:40:26 am »
Good Evening All:

This solved my issue.  Maybe it will work for you as well.

In the file vm_JSCook.php at line 80 change from:

$mymenu_content.= "\n['<img src=\"$mosConfig_live_site/components/com_virtuemart/js/ThemeXP/darrow.png\">','".$db->f("category_name",false)."','".sefRelToAbs('index.php?option=com_virtuemart&page=shop.browse&category_id='.$db->f("category_id").$itemid)."',null,'".$db->f("category_name",false)."'\n ";

Change to

$mymenu_content.= "\n['<img src=\"$mosConfig_live_site/modules/mod_virtuemart/ThemeXP/darrow.png\">','".$db->f("category_name",false)."','".sefRelToAbs('index.php?option=com_virtuemart&page=shop.browse&category_id='.$db->f("category_id").$itemid)."',null,'".$db->f("category_name",false)."'\n ";

Let me know if this works for you.

Rich Halsey

spacialek

  • Jr. Member
  • **
  • Posts: 56
    • Xaomé - Intégration Joomla
Re: Category Menu Icon / Images
« Reply #6 on: May 01, 2008, 06:03:51 am »
Wow !  Thanks a lot Rich !!  It's working now !!

Scar

  • Full Member
  • ***
  • Posts: 1035
    • J-lux
Re: Category Menu Icon / Images
« Reply #7 on: May 26, 2008, 14:35:35 pm »
Really great fix! Works in IE7 and FF. Thanks A LOT!

karamalla

  • Beginner
  • *
  • Posts: 5
Re: Category Menu Icon / Images
« Reply #8 on: June 20, 2008, 19:32:34 pm »
Many thanks, working

adamz

  • Beginner
  • *
  • Posts: 1
Re: Category Menu Icon / Images
« Reply #9 on: June 26, 2008, 00:33:00 am »
Actually it's working but only on the main page - on other pages I'm still getting X on the right side of submenu name in IE, any ideas how can I fix it?

HOME
   --- Submenu 1 X
   --- Submenu 2 X
   --- Submenu 3 X

Scar

  • Full Member
  • ***
  • Posts: 1035
    • J-lux
Re: Category Menu Icon / Images
« Reply #10 on: June 26, 2008, 07:17:07 am »
Are you sure you are not watching cached pages?

x-litero

  • Beginner
  • *
  • Posts: 7
Re: Category Menu Icon / Images
« Reply #11 on: June 27, 2008, 16:24:01 pm »
hi, I got a similar problem with the thumbnails of categories.
i fixed my roblem by only using jpeg files!

grayt7

  • Beginner
  • *
  • Posts: 3
Re: Category Menu Icon / Images
« Reply #12 on: July 29, 2008, 11:47:49 am »
Hi Adamz - did you ever find a fix to your problem? I am having the same problem. The menu system works fine when using the virtuemart shop but when using any other part of the website it seems that submenue items have images missing at the end of the line.

Any help you be very much appriciated. Thank you.

Actually it's working but only on the main page - on other pages I'm still getting X on the right side of submenu name in IE, any ideas how can I fix it?
HOME
   --- Submenu 1 X
   --- Submenu 2 X
   --- Submenu 3 X

Crusty

  • Beginner
  • *
  • Posts: 26
Re: Category Menu Icon / Images
« Reply #13 on: March 25, 2009, 06:41:34 am »
I am having the same problem, i think it is due to the way sh404sef writes the url, i have had a look at the code and have seen that the way that it references the .png is not an absolute address.

could this be the problem? is everyone else here having the same problems using sh404sef?

ads4it

  • Beginner
  • *
  • Posts: 12
Re: Category Menu Icon / Images
« Reply #14 on: May 03, 2009, 06:11:42 am »
hey adamz, grayt7, crusty.

if you still didn't fix this problems, let me know.

i can help you guys with this.