Author Topic: Credit Card Type: Not Showing Up???  (Read 18629 times)

thomking

  • Beginner
  • *
  • Posts: 15
Credit Card Type: Not Showing Up???
« on: April 27, 2008, 02:25:49 am »
I just upgraded to the VM 1.1 (stable) there is still a Java/Ajax issue of looping but, now Credit Card Type is not showing up and it is not allowing transactions to be completed... it give the error message: Error: Credit Card Type not found.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27388
  • Always on vacation
    • Jenkin Hill Internet
Re: Credit Card Type: Not Showing Up???
« Reply #1 on: April 27, 2008, 12:04:31 pm »
Which version of Joomla and which payment method is giving the error?
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.6 PHP 7.0.33
Testing VM 3.4.5.10059 on Joomla 3.9.6

Brian

  • Beginner
  • *
  • Posts: 17
Re: Credit Card Type: Not Showing Up???
« Reply #2 on: April 30, 2008, 16:24:58 pm »
I just upgraded to the VM 1.1 (stable) there is still a Java/Ajax issue of looping but, now Credit Card Type is not showing up and it is not allowing transactions to be completed... it give the error message: Error: Credit Card Type not found.
I've got the same error after upgrading to 1.1.  Using Joomla 1.0.15.  Any ideas?

Jim McFarland

  • Beginner
  • *
  • Posts: 15
Re: Credit Card Type: Not Showing Up???
« Reply #3 on: May 03, 2008, 00:35:55 am »
I'll give the same response that I posted to another forum question.

I cannot make any guarantees, but since this will only take 30 seconds you should give it a try.

Near the very top of your main index.php file, just after the <head> statement try adding the following statement:

   <?php mosShowHead(); ?>

It might be a little bit hard to read on the screen, so to clarify let me state that sandwiched in between the word Head and the semicolon are an open and close parentheses (it's not the number zero and it's not the letter "O").

It would look something like this:

     <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
     <html xmlns="http://www.w3.org/1999/xhtml">
     <head>
        <?php mosShowHead(); ?>
        <meta http-equiv="Content-Type" content="text/html;charset=UTF-8" />
             ...
             ...
             ...

Hope this works for you.
 

ezflyeruk

  • Beginner
  • *
  • Posts: 20
Re: Credit Card Type: Not Showing Up???
« Reply #4 on: May 03, 2008, 17:52:59 pm »

Allen Booth

  • Beginner
  • *
  • Posts: 1
Re: Credit Card Type: Not Showing Up???
« Reply #5 on: May 05, 2008, 14:42:33 pm »
I am having the same problem with the same workaround as someone else mentioned in this thread.

I'm using Joomla 1.5 and Virtuemart 1.1.0 (stable)

My Payment Method Type is Credit Card (Payment class name = ps_payment; accepted credit card type = Visa).

THE PROBLEM:

In Virtuemart Configuration, when I set User Registration Type to "No Account Creation" then when I enter credit card information and move the confirmation page I always get the alert "Credit Card Type Not Found."

This problem goes away if I set User Registration Type to any other value.

However, the ability to set user registration to "No Account Creation" would be extremely welcome.

I'm hoping someone can provide a patch.

beardydanz

  • Beginner
  • *
  • Posts: 1
Re: Credit Card Type: Not Showing Up???
« Reply #6 on: June 21, 2008, 06:57:06 am »
Yes I'm having the same problem- just wondering if anyone else has seen this and found a solution? Any help much appreciated.

Joomla/1.5.3, VM/1.1.0 stable, shared host with PHP/5.2.5, OpenSSL/0.9.8b, Firefox/2.0.0.14 (same error with IE tho'):

If I don't make the customer register (normal or silent mode), and the customer chooses not to register (optional mode), the pull-down box for cc type is not displayed at checkout step 4. Happens in test & live modes- debug mode shows no error codes up to this point, but you cannot progress to the order confirmation page as the cc type is not found. Everything works fine if the user is registered.

Thx, beardydanz

mknz

  • Beginner
  • *
  • Posts: 31
    • National Underground
Re: Credit Card Type: Not Showing Up???
« Reply #7 on: July 11, 2008, 16:30:12 pm »
Yeah!  Any solution to this...seems pretty lame.
I've seen people hard coding dropdowns...but I can't even get that to work on Authorize.net
Any ideas out there?

brett.hooker

  • Beginner
  • *
  • Posts: 14
Re: Credit Card Type: Not Showing Up???
« Reply #8 on: January 13, 2009, 03:08:45 am »
We fixed this on JM 1.0+ and VM 1.1.2 by letting the mainframe class know that there is a script to be added to the page.

This was done by:
1) Edit joomla_home/administrator/components/com_virtuemart/classes/ps_creditcard.php

2) Find function creditcard_lists( &$db_cc ) {   (line 261 in my file)

3) Add this line immediately after the function declaration (this allows the function to access the mainframe variable)
      global $mainframe;

4) Add one more line, after line 274 (   $db_cc->reset();  )
      $mainframe->addCustomHeadTag( '<script src="'.SECUREURL.'/includes/js/joomla.javascript.js" type="text/javascript"></script>' );

This line tells the mainframe handler to load the required javascript file to handle the changeDynaList() method.


Sunglasses-Joe

  • Beginner
  • *
  • Posts: 26
  • Me & My Boy !
    • The Glasses Center
Re: Credit Card Type: Not Showing Up???
« Reply #10 on: December 20, 2010, 19:49:16 pm »
I have been having this problem, ???
The drop down menu to choose credit card type did not appear at all.

After a long search and lots of investigating I worked out that if i Disable the PLUGIN System - JCH_Optimize , the drop down menu starts working !  ;D

Hope this helps someone,

Thanks

Joe
The Glasses Center Group

http://www.sunglassescenter.co.uk/

IPN

  • Beginner
  • *
  • Posts: 6
Re: Credit Card Type: Not Showing Up???
« Reply #11 on: October 19, 2011, 18:16:31 pm »
Sunglasses-Joe

I've been looking for a result to this question for at least 3 hours.  Your solution WORKED! :)

Thanks.