Author Topic: Unable to Show my images  (Read 17475 times)

solvemyproblems

  • Beginner
  • *
  • Posts: 30
Unable to Show my images
« on: April 25, 2008, 12:21:04 pm »
Hello everyone,

My virtuemart version is 1.1.0 an joomla1.5.2.
In my list of products , i am unable to show image of that product.i can see the image when i click "View full size image", but not in list of my products.I am unable to show "Add to my cart" image for each product.Donno why , it worked well in virtuemart1.0.

Can anybody help me to get out of it, plzzzzzzzzzzzzzzzzzzz

Thank u in advance,
Solvemyproblems

Crusty

  • Beginner
  • *
  • Posts: 26
Re: Unable to Show my images
« Reply #1 on: April 25, 2008, 12:40:19 pm »
CHMOD you img_in_img_tag.php to 644

solvemyproblems

  • Beginner
  • *
  • Posts: 30
Re: Unable to Show my images
« Reply #2 on: April 25, 2008, 12:54:44 pm »
CHMOD you img_in_img_tag.php to 644
Sorry , but i didn't understand ur short language lol,
Can u plz Explain  me in brief ..
Thx

babbsela

  • Jr. Member
  • **
  • Posts: 58
Re: Unable to Show my images
« Reply #3 on: April 26, 2008, 23:48:25 pm »
CHMOD you img_in_img_tag.php to 644

I have the same problem, CHMOD the img_in_imgtag.php to 644, still isn't fixed. Even created a second instance and named it img_in_img_tag.php (as you named your file) and still no go.
If I have helped you in any way, please make a donation to the fine folks who work so hard to bring us Virtuemart.

Crusty

  • Beginner
  • *
  • Posts: 26
Re: Unable to Show my images
« Reply #4 on: April 27, 2008, 14:03:49 pm »
sorry, i meant the show_image_in_imgtag.php file located in your components->com_virtuemart folder. using FTP or your site backstage CHMOD the file to change the security settings from 777 to 755. i was thinking off the top of my head as i fixed so many problems since the install of VM 1.1 sorry.

babbsela

  • Jr. Member
  • **
  • Posts: 58
Re: Unable to Show my images
« Reply #5 on: April 29, 2008, 22:08:50 pm »
sorry, i meant the show_image_in_imgtag.php file located in your components->com_virtuemart folder. using FTP or your site backstage CHMOD the file to change the security settings from 777 to 755. i was thinking off the top of my head as i fixed so many problems since the install of VM 1.1 sorry.

Did it. Still no category images.
If I have helped you in any way, please make a donation to the fine folks who work so hard to bring us Virtuemart.

FavoriteU

  • Jr. Member
  • **
  • Posts: 119
Re: Unable to Show my images
« Reply #6 on: April 29, 2008, 22:24:09 pm »
Are your images in a subdirectory of the main product image directory, like /components/com_virtuemart/shop_image/product/SUBDIRECTORY/?  If so, I had the same problem (see thread here: http://forum.virtuemart.net/index.php?topic=39001.0)

I never got an answer to the problem, so I ended up just moving all of the products to the main image directory instead of subdirectories.  Once I changed the image locations for the products, it worked them.  Certainly not ideal, but at least you can see the images.

I think the problem is in show_image_in_imgtag.php, but I'm not sure.

babbsela

  • Jr. Member
  • **
  • Posts: 58
Re: Unable to Show my images
« Reply #7 on: May 04, 2008, 21:28:31 pm »
I gave up and uninstalled virtuemart, and deleted all files; then did a manual install of vm1.1. I now have category pictures, but no product pictures. I'm not sure if that is progress or not.

Joomla 1.0.15
VM 1.1
http://drugalcoholsolutions.com
If I have helped you in any way, please make a donation to the fine folks who work so hard to bring us Virtuemart.

Xenonspesialisten

  • Beginner
  • *
  • Posts: 13
Re: Unable to Show my images
« Reply #8 on: May 04, 2008, 21:55:23 pm »
I have the same problem. No images on my products. When I right click on where the image is supposed to be, and click "view image", I get this error: Parse error: syntax error, unexpected $end in /home/xenonsp/public_html/components/com_virtuemart/show_image_in_imgtag.php on line 94.

Need help FAST!!!

Sublimetime

  • Beginner
  • *
  • Posts: 29
Re: Unable to Show my images
« Reply #9 on: May 04, 2008, 23:50:43 pm »
I had a similar issue , That was caused by my SEF settings..
Check that , maybe even rename your htaccess file to htaccess.txt temporarily and see if it fixes the issue, if it does, then thats your culprit.


Xenonspesialisten

  • Beginner
  • *
  • Posts: 13
Re: Unable to Show my images
« Reply #10 on: May 05, 2008, 10:56:16 am »
I had a similar issue , That was caused by my SEF settings..
Check that , maybe even rename your htaccess file to htaccess.txt temporarily and see if it fixes the issue, if it does, then thats your culprit.
This does not work for me...

solvemyproblems

  • Beginner
  • *
  • Posts: 30
Re: Unable to Show my images
« Reply #11 on: May 05, 2008, 11:29:42 am »
I really dont understand y i am unable to show my product images. My category images are visible but not my product images.........

Can anyone help , plzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz
Its Urgent............ :( :( :( :'( :'(

solvemyproblems

  • Beginner
  • *
  • Posts: 30
Re: Unable to Show my images
« Reply #12 on: May 05, 2008, 13:21:17 pm »
There is no one to help me?????????????????????plz its eating my brain, plz help me....

solvemyproblems

  • Beginner
  • *
  • Posts: 30
Re: Unable to Show my images
« Reply #13 on: May 05, 2008, 15:41:09 pm »
YESSSSSSSSSSSSSSSSSS
I got it, it is bcoz of php library .
Goto easyphp=>rightclick=>Configurations=>ExtensionsPhps=>click en GD2(activate)

For me it works like this ...........


Xenonspesialisten

  • Beginner
  • *
  • Posts: 13
Re: Unable to Show my images
« Reply #14 on: May 05, 2008, 16:00:23 pm »
And where do I find Easy PHP?