Author Topic: Error installing sample data  (Read 8246 times)

gillianm

  • Beginner
  • *
  • Posts: 4
Error installing sample data
« on: April 24, 2008, 18:36:41 pm »
Hi folks,
I am trying to install VirtueMart 1.1.0 RC2 on Joomla! 1.5.2 in legacy mode.

I get as far as the 'Welcome Page'- "The first step of the Installation was SUCCESSFUL"
but when I go to install the sample data I get this error:

Update Log
Warning: require(/hsphere/local/home/xxxx/gravenhurstfarmersmarket.com/administrator/
components/com_virtuemart/classes/ps_database.php): failed to open stream: No such file or directory in /hsphere/local/home/xxxx/gravenhurstfarmersmarket.com/administrator/components/com_virtuemart/
install.php on line 112 Fatal error: require(): Failed opening required '/
hsphere/local/home/xxxx/gravenhurstfarmersmarket.com/administrator/
components/com_virtuemart/classes/ps_database.php'
(include_path='.:/hsphere/shared/apache/libexec/php5ext/php/')
in /hsphere/local/home/xxxx/gravenhurstfarmersmarket.com/administrator
/components/com_virtuemart/install.php on line 112


I am new to Joomla (only 3 months), new to php (the same) and really new to extensions
(it took me a week to figure out how to install Fireboard!)  If you are able to help,
please understand that I am not terribly literate yet terminology-wise.  ::)
It sounds like there is supposed to be a directory which is not there?

Many thanks for responding if you have had a similar problem or can help!

Cheers,
Gillian



jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27954
  • Always on vacation
    • Jenkin Hill Internet
Re: Error installing sample data
« Reply #1 on: April 24, 2008, 18:46:03 pm »
Forget about using RC2 it is very old. You should install VirtueMart 1.1 stable, which will install and run in Joomla 1.5.2 native mode.

http://virtuemart.net/index.php?option=com_content&task=view&id=293&Itemid=57
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.7 10374 on Joomla 3.9.23 PHP 7.4.12

gillianm

  • Beginner
  • *
  • Posts: 4
Re: Error installing sample data
« Reply #2 on: April 24, 2008, 18:52:04 pm »
Thanks, Kelvyn:

Here is one of those newbie questions.  If I uninstall what I have and then install what you suggest, what do I do about the 'mode'.

I have it set to 'legacy' for the FireBoard Forum I installed.  Can I install the Virtue Mart version you suggest while having 'legacy' mode?  Is the mode only selected while installing an extension?  Can it be changed after an extension has been installed?

Yes, complete newbie.  But trying.

Thanks!
Gillian

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27954
  • Always on vacation
    • Jenkin Hill Internet
Re: Error installing sample data
« Reply #3 on: April 24, 2008, 20:34:51 pm »
I have not tested VM1.1 in legacy mode. I only use components that run with J!1.5.2 in native mode. You can change modes after an install.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.7 10374 on Joomla 3.9.23 PHP 7.4.12

gillianm

  • Beginner
  • *
  • Posts: 4
Re: Error installing sample data
« Reply #4 on: April 24, 2008, 20:38:54 pm »
Thanks, Kelvin,

I did download the April 23 version of Virtue Mart.
Printed out the manual.  So, we'll see!

Thanks for explaining about it being okay to change the mode after an install.

We all learn little by little thanks to folks like you!  :)

Cheers,
Gillian