Author Topic: does not install for J! 1.0.15  (Read 8947 times)

Mike C

  • Jr. Member
  • **
  • Posts: 165
does not install for J! 1.0.15
« on: March 05, 2008, 07:21:07 am »
I just tried to install the latest nightly build and it failed.. The messages are:

Unrecoverable error "PCLZIP_ERR_BAD_FORMAT (-10)"
and
Installation file not found

I was supposed to extract the com_virtuemart_1.1.0.zip from the main zip file and install it as a component, correct?

Well anyways, that's what happens.

Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #1 on: March 05, 2008, 22:06:01 pm »
anyone have this problem?

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27389
  • Always on vacation
    • Jenkin Hill Internet
Re: does not install for J! 1.0.15
« Reply #2 on: March 05, 2008, 22:52:57 pm »
VM 1297 installed OK for me on J1.0.15 and J1.5.1

Yes, the component com_virtuemart_1.1.0.zip is installed from the component directory of VirtueMart_1.1.0_COMPLETE_PACKAGE.zip
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.4.3.10057 on Joomla 3.9.6 PHP 7.0.33
Testing VM 3.4.5.10059 on Joomla 3.9.6

Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #3 on: March 05, 2008, 22:54:45 pm »
hmm weird.. well no good for me so I can't install it to help with testing anything.. Hopefully the stable version will install...

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: does not install for J! 1.0.15
« Reply #4 on: March 05, 2008, 23:50:14 pm »
The error has nothing to do with VM, it is a server issue, if you can't install the RC probably you won't be able to install the stable.

Did a Search found the following

"Server using PCLZip as opposed to GZip and it can't handle the zip files"

Comment out the following variable in php.ini
;mbstring.func_overload = 0

Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #5 on: March 05, 2008, 23:52:44 pm »
I have never had a problem installing a Joomla component before (including Virtuemart 1.0.x)  What is different about 1.1 that is causing this to suddenly happen to me? If it's going to happen to me, it will happen to others I'm sure. Perhaps VM needs to go back to the "old way" whatever that was...

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: does not install for J! 1.0.15
« Reply #6 on: March 05, 2008, 23:56:38 pm »
Maybe your host changed something. anyway I'll keep this in mind.

Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #7 on: March 06, 2008, 00:00:54 am »
I've installed other components today without issue, so I don't think anything changed on my host's end. I'm on PHP 5.2.5
I just sent an email to my host..


Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #9 on: March 06, 2008, 00:33:22 am »
I downloaded it from the dev website:
http://dev.virtuemart.net/cb/proj/doc.do?doc_id=1328


Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #11 on: March 06, 2008, 01:01:54 am »
Yeah, it didn't make a difference, same
Code: [Select]
Unrecoverable error "PCLZIP_ERR_BAD_FORMAT (-10)"

Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #12 on: March 07, 2008, 23:09:54 pm »
I just attempted to install the new nightly build and had the same error happened again, no word yet from my host who is taking an usually long time to reply about this issue.....


Mike C

  • Jr. Member
  • **
  • Posts: 165
Re: does not install for J! 1.0.15
« Reply #14 on: March 11, 2008, 23:08:56 pm »
My host finally replied with this:

Quote
Nothing has changed on the server recently. The variable that you mentioned is already commented out, and our server is using the standard GNU gzip that comes with the Linux distribution that we use:

[root@host101 ~]# gzip -V
gzip 1.3.5
(2002-09-30)
Copyright 2002 Free Software Foundation
Copyright 1992-1993 Jean-loup Gailly
This program comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of this program
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.
Compilation options:
DIRENT UTIME STDC_HEADERS HAVE_UNISTD_H HAVE_MEMORY_H HAVE_STRING_H HAVE_LSTAT
Written by Jean-loup Gailly.

The only way I can get VM to install is if I unzip the download, and then rezip it with winrar. So there's definitely something funky with the component zip file. (I didn't have trouble with the mod_virtuemart zip file)