Author Topic: SSL - https/http switchover - both secure nosecure items - encrypted  (Read 70450 times)

JJRO

  • Jr. Member
  • **
  • Posts: 62
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #15 on: May 24, 2008, 20:06:27 pm »
Thought it fixed it! - However, now it doesn't enter into the SSL mode at all... thanks for trying and please keep at it!

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #16 on: May 24, 2008, 23:47:33 pm »
Forgot that your config file has changed. My apology.
Your best bet is to replace these lines of code in your original config file (line 38)
Code: [Select]
if ( @$_SERVER['HTTPS'] == 'on' ) {
define( 'IMAGEURL', SECUREURL .'components/com_virtuemart/shop_image/' );
} else {
define( 'IMAGEURL', URL .'components/com_virtuemart/shop_image/' );
}
define( 'COMPONENTURL', URL .'administrator/components/com_virtuemart/' );
define( 'ADMINPATH', $mosConfig_absolute_path.'/administrator/components/com_virtuemart/' );
define( 'CLASSPATH', ADMINPATH.'classes/' );
define( 'PAGEPATH', ADMINPATH.'html/' );
define( 'IMAGEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/shop_image/' );

define( 'VM_THEMEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/themes/default/' );
define( 'VM_THEMEURL', $mosConfig_live_site.'/components/com_virtuemart/themes/default/' );

with
Code: [Select]
if ( @$_SERVER['HTTPS'] == 'on' ) {
define( 'IMAGEURL', SECUREURL .'components/com_virtuemart/shop_image/' );
// added by JK for fixing https problem
define( 'VM_THEMEURL', SECUREURL.'components/com_virtuemart/themes/default/' );
} else {
define( 'IMAGEURL', URL .'components/com_virtuemart/shop_image/' );
// added by JK for fixing https problem
define( 'VM_THEMEURL', URL.'components/com_virtuemart/themes/default/' );
}
define( 'COMPONENTURL', URL .'administrator/components/com_virtuemart/' );
define( 'ADMINPATH', $mosConfig_absolute_path.'/administrator/components/com_virtuemart/' );
define( 'CLASSPATH', ADMINPATH.'classes/' );
define( 'PAGEPATH', ADMINPATH.'html/' );
define( 'IMAGEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/shop_image/' );

define( 'VM_THEMEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/themes/default/' );
// Following line commented out by JK for fixing https secure warning
//define( 'VM_THEMEURL', $mosConfig_live_site.'/components/com_virtuemart/themes/default/' );

Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

winfreepcs

  • Jr. Member
  • **
  • Posts: 59
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #17 on: May 25, 2008, 00:16:17 am »
Thank you for the fix! I got the https to work in ie and FF.

Finally the online store is working!

JJRO

  • Jr. Member
  • **
  • Posts: 62
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #18 on: May 25, 2008, 00:37:04 am »
Joseph!   BRILLIANT!   CHEERS!!!
Works here perfectly.

Bruce Morgan

  • Full Member
  • ***
  • Posts: 672
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #19 on: June 05, 2008, 03:45:30 am »
Ouch!!!  My site has been down for 4 days since I attempted the earlier fix.  I tried the latest fix but still got an error message.  I tried to replace the file with the original VM release but now I have another error message.  It wants to recover a saved cart and when I try to delete it I get another error message as follows.  Help!

Error: Function Not Registered. deleteSavedCart is not a valid VirtueMart function.

Bruce
www.pepper-passion.com

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #20 on: June 05, 2008, 06:48:30 am »
The save cart error has nothing to do with the fix. For the other problems, please give the detail of the eror message.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

Bruce Morgan

  • Full Member
  • ***
  • Posts: 672
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #21 on: June 05, 2008, 17:29:39 pm »
The saved cart error went away when I closed the window and rebooted mye computer.  However, I still have the error from Authorized.net owing to the fact that during checkout my site never goes into the https mode.  I tried pasting in the code you you show in you recent post bu i may have made a small error.  Could you post a complete new virtuemart.config.php file with the fix?

Bruce

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #22 on: June 05, 2008, 17:45:22 pm »
Go to your site and in the url section (vm configuration), put in the secure url with https.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

Bruce Morgan

  • Full Member
  • ***
  • Posts: 672
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #23 on: June 07, 2008, 21:39:28 pm »
I finally got this working 100%.  Thank God for a program like Winmerge.  That is a very nice fix.

I think the customers will start coming back now.

Bruce

hsitech

  • Beginner
  • *
  • Posts: 31
    • The Next Byte Inc.
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #24 on: June 08, 2008, 05:16:44 am »
Forgot that your config file has changed. My apology.
Your best bet is to replace these lines of code in your original config file (line 38)
Code: [Select]
if ( @$_SERVER['HTTPS'] == 'on' ) {
define( 'IMAGEURL', SECUREURL .'components/com_virtuemart/shop_image/' );
} else {
define( 'IMAGEURL', URL .'components/com_virtuemart/shop_image/' );
}
define( 'COMPONENTURL', URL .'administrator/components/com_virtuemart/' );
define( 'ADMINPATH', $mosConfig_absolute_path.'/administrator/components/com_virtuemart/' );
define( 'CLASSPATH', ADMINPATH.'classes/' );
define( 'PAGEPATH', ADMINPATH.'html/' );
define( 'IMAGEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/shop_image/' );
define( 'VM_THEMEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/themes/default/' );
define( 'VM_THEMEURL', $mosConfig_live_site.'/components/com_virtuemart/themes/default/' );
with
Code: [Select]
if ( @$_SERVER['HTTPS'] == 'on' ) {
define( 'IMAGEURL', SECUREURL .'components/com_virtuemart/shop_image/' );
// added by JK for fixing https problem
define( 'VM_THEMEURL', SECUREURL.'components/com_virtuemart/themes/default/' );
} else {
define( 'IMAGEURL', URL .'components/com_virtuemart/shop_image/' );
// added by JK for fixing https problem
define( 'VM_THEMEURL', URL.'components/com_virtuemart/themes/default/' );
}
define( 'COMPONENTURL', URL .'administrator/components/com_virtuemart/' );
define( 'ADMINPATH', $mosConfig_absolute_path.'/administrator/components/com_virtuemart/' );
define( 'CLASSPATH', ADMINPATH.'classes/' );
define( 'PAGEPATH', ADMINPATH.'html/' );
define( 'IMAGEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/shop_image/' );
define( 'VM_THEMEPATH', $mosConfig_absolute_path.'/components/com_virtuemart/themes/default/' );
// Following line commented out by JK for fixing https secure warning
//define( 'VM_THEMEURL', $mosConfig_live_site.'/components/com_virtuemart/themes/default/' );

I take it thats for pre 1.1.0 because i tried it and got a php error

Code: [Select]
Warning: preg_match_all() expects parameter 2 to be string, array given in /home/oldvolks/public_html/wifirat/libraries/joomla/application/application.php on line 820
Array

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #25 on: June 08, 2008, 08:36:34 am »
Sorry. I don't see any relation between your problem with the fix I suggested.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

hsitech

  • Beginner
  • *
  • Posts: 31
    • The Next Byte Inc.
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #26 on: June 08, 2008, 11:23:36 am »
I came here on a link from a vm 1.1 forum not noticing that this is 1.0 fix, I tried it with 1.1 because 1.1 they still dont have this fixed I get the same errors with 1.1 and I know Im not the only one.

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #27 on: June 09, 2008, 21:22:24 pm »
This fix is for VM 1.1 and will solve the insecure shopcart icon images problem only. Don't rely on this to solve all the insecure warnings.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.

hsitech

  • Beginner
  • *
  • Posts: 31
    • The Next Byte Inc.
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #28 on: June 10, 2008, 06:42:58 am »
This fix is for VM 1.1 and will solve the insecure shopcart icon images problem only. Don't rely on this to solve all the insecure warnings.
Then why is this posted in the 1.0 forum? If its for 1.1.0

Joseph Kwan

  • Advanced
  • Full Member
  • *****
  • Posts: 2344
Re: SSL - https/http switchover - both secure nosecure items - encrypted
« Reply #29 on: June 10, 2008, 07:22:10 am »
I can't answer this question as this is how the thread evolved. Maybe moderator can move this to VM 1.1 instead.
Joomla/VM Upgrade Services. Problems with your migration? We can help.
Custom extensions to VM. Performance Tuning. Template modifications and advices.
Pay service to make VM work according to your needs. Your Joomla/VM solutions are just a PM away.