Author Topic: Persistent Login when browsing  (Read 6044 times)

iamalive

  • Jr. Member
  • **
  • Posts: 133
  • Life is good
    • Websites4U
Persistent Login when browsing
« on: February 02, 2008, 23:39:41 pm »
Hi
I'm using the version from the 30th January with the stable Joomla 1.5

I can't seem to turn off the login module. I have uninstalled the virtuemart login module and turned off the joomla login module in the configuration and yet everytime I want to look at a category, up pops up the login form, telling me I have to login!

I don't understand it. Obviously, a shop which can't be browsed, isnt a lot of use. I would be grateful for some urgent advice on how to get rid of this problem.

You can see what I mean by going to:
http://joomla.neukom-electronic.ch/index.php?option=com_content&view=article&id=18&Itemid=7
and selecting a submenu, eg. "Stromzangen"

Help!

Regards

David
David Jakob
..stressfreie Webseiten von http://websites4u.ch...

iamalive

  • Jr. Member
  • **
  • Posts: 133
  • Life is good
    • Websites4U
Support
« Reply #1 on: February 05, 2008, 09:00:46 am »
One of the things that is a key consideration in the choice of CMS and components, is the level of support available.

In terms of Joomla! as a CMS, the support is very good. Almost all of my issues get solved within a few days.

In terms of the components, the support is very variable. For Virtuemart, the support is frequently very poor. I have waited days for any kind of reply (and I only post when I am really stuck) and often weeks, without getting an answer.

This has consequences:
  • I am always nervous about making use of this component and do so only when I customers insist
  • I advise people to look for alternatives, because the support is so unreliable
  • I am not motivated to participate, as it appears that it's only useful or wanted by a select little group within the community. That is an impression which I find very sad, because the elitism is contrary to the OpenSource system.

It may be that it's just due to the moderators, who don't moderate. I don't know what the cause is, but I wish it would change.

I find the component a very impressive piece of work. For the support to be so unimpressive, lessens the value of the great development work being done.

David
David Jakob
..stressfreie Webseiten von http://websites4u.ch...

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: Support
« Reply #2 on: February 09, 2008, 04:29:30 am »
In terms of the components, the support is very variable. For Virtuemart, the support is frequently very poor. I have waited days for any kind of reply (and I only post when I am really stuck) and often weeks, without getting an answer.
Perhaps that is the problem, you only post when you need help, you have been a member for almost 2 years and not once you have helped someone else, all your questions have been support related, if everyone would help 5 or more users with the basic questions that they know, than the support would be good, unfortunately that is not the case once the problem is solved the user disappears until the next support question, we all are trying our best but all of us like you and others have priorities, obligations, responsibility to our family and job.

That said VirtueMart 1.1 is still in development and no official support is given until RC2 or stable release, in the meanwhile feel free to report any bugs you might find.

iamalive

  • Jr. Member
  • **
  • Posts: 133
  • Life is good
    • Websites4U
Re: Persistent Login when browsing
« Reply #3 on: February 09, 2008, 16:57:11 pm »
I take your point. You're quite right that I've been a member for 2 years. In that time I have not managed to build a single site to any degree of satisfaction and have ended up using other solutions. The main reason is that I didn't get help when trying to build things. How can I offer help, when I haven't managed to solve some of the problems I've asked for help with?

That said. I have started to post bugs. This post here started off as a bug post, which has still not been given an answer. But never mind. My expectations are low.

This time, however, I am determined to complete the project I'm working on, using this component. Perhaps I'll succed. I do admire what has been done, I do think it is a great component. I do want to use it, but I don't feel comfortabel recommending it to my customers until I have at least one working site! I guess that's understandable, isn't it?

Regards

David

PS - do please feel free to tell me I'm wrong, but be aware, I am passing on my personal experience and that is the way it is.
David Jakob
..stressfreie Webseiten von http://websites4u.ch...

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: Persistent Login when browsing
« Reply #4 on: February 09, 2008, 17:40:23 pm »
I can not reproduce your issue, I created a category with 3 sub-categories with one product in each, I can browse fine, perhaps it is your setup, try installing a fresh version of Joomla and VirtueMart (you will have to do it anyway there has been database change) without modifying anything, see if the problem persist, if so give us steps to reproduce.

iamalive

  • Jr. Member
  • **
  • Posts: 133
  • Life is good
    • Websites4U
Re: Persistent Login when browsing
« Reply #5 on: February 09, 2008, 18:59:26 pm »
Thanks for your very fast reply!!

I'd come to the same conclusion: I've made a fresh install and the problem has gone away. Unfortunately, I don't know the correct commands for mysql to be able to add the product hierarchies and products from the previous install. I'd appreciate knowing how to do that, as I had added a rather comprehensive hierarchy and a lot of products and manufacturers. Help here would speed things up.

I will provide feedback. Is this the right forum?

Regards

David
David Jakob
..stressfreie Webseiten von http://websites4u.ch...