Author Topic: Shows error messages  (Read 3678 times)

ludde

  • Beginner
  • *
  • Posts: 7
Shows error messages
« on: January 23, 2008, 16:37:46 pm »
When I run VM on my external site it shows the following error messages:

Notice: Only variables should be assigned by reference in 
..../components/com_virtuemart/virtuemart_parser.php on line 144


Is this a bug or is there a way to turn of warnings? On my local machine I do not get this error messages.   

VM: 1.1 revision 1175
PHP: 4.4.7
Apache 2.0.52
Joomla! 1.5.0 Production/Stable

aravot

  • Peter
  • Moderator
  • Sr. Member
  • *
  • Posts: 2874
    • VirtueMart Extensions
Re: Shows error messages
« Reply #1 on: January 23, 2008, 18:59:47 pm »
I can't not replicate I am on php5, this could be a php4 issue

ludde

  • Beginner
  • *
  • Posts: 7
Re: Shows error messages
« Reply #2 on: January 23, 2008, 20:00:06 pm »

I have earlier tried on an other webb hotel (indell) with PHP 4.4.7 (VM 1055 /J1.5rc3) and did not get this error - the code in this part was the same as now. It is probably related to my new webb hotel (Crystone) - but how?



 

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 27799
  • Always on vacation
    • Jenkin Hill Internet
Re: Shows error messages
« Reply #3 on: January 23, 2008, 20:55:14 pm »
I suspect it a server issue due to the php error reporting level setting.

See this old thread:
http://forum.virtuemart.net/index.php?topic=826.0
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VM 3.8.4.10335 on Joomla 3.9.19 PHP 7.3.18

ludde

  • Beginner
  • *
  • Posts: 7
Re: Shows error messages
« Reply #4 on: January 23, 2008, 21:54:26 pm »
Thanks a lot, it  helped