Author Topic: Joomla configuration file missing variable  (Read 8796 times)

database9

  • Beginner
  • *
  • Posts: 3
Joomla configuration file missing variable
« on: September 26, 2007, 20:49:37 pm »
I've resolved this issue but I'm posting it here because I wasn't able to find any other posts with this problem, and I thought it might be helpful to others. 

Problem:
Unable to install VirtueMart V 1.1 with Joomla V. 1.5.0

Error Message:
Fatal error: main(): Failed opening required '/components/com_virtuemart/virtuemart_parser.php' (include_path='.;c:\php4\pear') in E:\USERS\Sitefolder\www\Joomla\administrator\components\com_virtuemart\admin.virtuemart.php on line 59

Cause:
VirtueMart requires the variable $jconfig->absolute_path in the joomla config file, configuration.php.   Joomla V 1.5.0 does not contain that variable.

Solution:
Edit the JConfig  class in the joomla configuration file.  Add the following line, replacing the path with the path to your site.:

   var $absolute_path = 'E:\\USERS\\Sitefolder\\www\\Joomla';



gregdev

  • Full Member
  • ***
  • Posts: 968
    • PlainlyCode
Re: Joomla configuration file missing variable
« Reply #1 on: September 26, 2007, 21:02:06 pm »
Which version of VirtueMart are you using? This works fine in the latest SVN revision of Virtuemart (and has for a while now).

Greg

database9

  • Beginner
  • *
  • Posts: 3
Re: Joomla configuration file missing variable
« Reply #2 on: September 26, 2007, 21:27:08 pm »
Well, now that I've installed I find that I somehow installed the 1.0.10 version.  So my solution wasn't what I thought it was.  I'd tried every method I could think of to get VirtueMart installed.  I knew that I'd used the remote install, then tried to uninstall, but I thought I'd got the new version running.   Aargh!  Well, I'm going to just accept that I at least got the older version up and running.  It looks really nice.

Thanks, Derek

gorbehnare

  • Beginner
  • *
  • Posts: 23
Re: Joomla configuration file missing variable
« Reply #3 on: September 27, 2007, 21:48:35 pm »
We just figured our thumbnails need this variable in this post:
http://forum.virtuemart.net/index.php?topic=32234.0

Scott Carroll suggested to add this variable to configuration.php of Joomla.

It seems like it's better if there was a way to contain this variable in VM 1.1 instead of modifying joomla since the final versions of joomla 1.5 will be out soon and the more changes we hammer into joomla to make this version of VM work for now the more problems we will cause when upgrading to the latest version of joomla later.

gregdev

  • Full Member
  • ***
  • Posts: 968
    • PlainlyCode
Re: Joomla configuration file missing variable
« Reply #4 on: September 27, 2007, 22:53:32 pm »
Yes. We don't need to add things to Joomla's configuration file. I am working on the image script now.

Greg