Author Topic: [DUPLICATE] Bugs in last VM with last Joomla  (Read 10306 times)

esmark

  • Beginner
  • *
  • Posts: 12
[DUPLICATE] Bugs in last VM with last Joomla
« on: September 03, 2007, 07:45:06 am »
While testing last VM with last Joomla
in VM Summary:
Quote
Notice: Undefined variable: mosConfig_offset_user in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\compat.joomla1.5.php on line 103
in confuguration unset default constants:
Quote
Notice: Use of undefined constant VM_FEED_ENABLED - assumed 'VM_FEED_ENABLED' in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\admin.show_cfg.php on line 1080
value="1" /> Enable Product Feeds
Notice: Use of undefined constant VM_FEED_CACHE - assumed 'VM_FEED_CACHE' in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\admin.show_cfg.php on line 1089
value="1" /> Enable Cache?
& so on for each VM_FEED_*
In Special Product
Quote
Fatal error: Call to a member function on a non-object in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\product.specialprod.php on line 159
In View Inventory
Quote
Fatal error: Call to a member function on a non-object in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\product.product_inventory.php on line 119
In adding a product or category - write a fatal error that this path does't not exist.
Only in Simple Layout - no titles of bookmarks in CSV upload
In Extended Layout - hidden displaying of Summary & Edit Store in menu (browser: IE-6.0)

Using:
Windows XP SP2
Apache 1.3.27 (Win32)
MySQL 4.1.8-max
PHP 4.3.6
Internet Explorer 6.0 + (Opera 7.52 - totaly unsupport Ajax)
Joomla 1.5 RC2 (newest!) + Legacy: 1.0
VirtueMart 1.1.0 SNV rev. 912

gregdev

  • Full Member
  • ***
  • Posts: 968
    • PlainlyCode
Re: Bugs in last VM with last Joomla
« Reply #1 on: September 03, 2007, 16:06:42 pm »
Quote
Notice: Undefined variable: mosConfig_offset_user in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\compat.joomla1.5.php on line 103

Fixed in VM SVN, rev. 913.

Greg

gregdev

  • Full Member
  • ***
  • Posts: 968
    • PlainlyCode
Re: Bugs in last VM with last Joomla
« Reply #2 on: September 03, 2007, 16:10:16 pm »
Quote
Notice: Use of undefined constant VM_FEED_ENABLED - assumed 'VM_FEED_ENABLED' in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\admin.show_cfg.php on line 1080
value="1" /> Enable Product Feeds
Notice: Use of undefined constant VM_FEED_CACHE - assumed 'VM_FEED_CACHE' in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\admin.show_cfg.php on line 1089
value="1" /> Enable Cache?
& so on for each VM_FEED_*

Please check that you are using the latest VM configuration file. Those constants are defined (as of VM SVN rev 773, March 16, 2007).

Greg

gregdev

  • Full Member
  • ***
  • Posts: 968
    • PlainlyCode
Re: Bugs in last VM with last Joomla
« Reply #3 on: September 03, 2007, 16:41:37 pm »
Quote
Fatal error: Call to a member function on a non-object in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\product.specialprod.php on line 159

Quote
Fatal error: Call to a member function on a non-object in w:\home\virtuemart\j15rc2\administrator\components\com_virtuemart\html\product.product_inventory.php on line 119

Fixed in VM SVN, rev. 914.

Greg

esmark

  • Beginner
  • *
  • Posts: 12
Re: Bugs in last VM with last Joomla
« Reply #4 on: September 03, 2007, 22:00:38 pm »
Quote
Please check that you are using the latest VM configuration file. Those constants are defined (as of VM SVN rev 773, March 16, 2007).
Sorry, Yes I use an older configuration file. It is Ok.
Those buds still exist:
Quote
In adding a product or category - write a fatal error that this path does't not exist.
Only in Simple Layout - no titles of bookmarks in CSV upload
In Extended Layout - hidden displaying of Summary & Edit Store in menu (browser: IE-6.0)
At first browser opens add category normally but the next time it writes: "Can't open node: http://j15rc2.virtuemart/administrator/index.php?pshop_mode=admin&page=product.product_category_form&option=com_virtuemart
operation is interrupted."
In addition I noticed that Legace of Joomla doesn't support another languages with old structure components. So my joomla 1.5 admin panel is in Russian, but VM 1.1 (and 1.0.12 too) - in English. :(
I know that Soeren planned multiple vendor support in the beta 2 release. But I didn't find any things concerning it.
Greg, can I help for this project? May we discuss it in MVS-topic?

esmark

  • Beginner
  • *
  • Posts: 12
Re: Bugs in last VM with last Joomla
« Reply #5 on: September 04, 2007, 22:23:34 pm »
Quote
In adding a product or category - write a fatal error that this path does't not exist.
In my opinion this is a some JavaScript\Ajax conflict or error of recognizing by IE browser. I remarks some code in 361 string of editorArea and JavaScript from 1005 to 1072 of the product.product_form and page opens normally. In 2 places exactly! Strange  ???