Author Topic: After updating to Joomla 4.2.2 Error 500  (Read 536 times)

hazael

  • Jr. Member
  • **
  • Posts: 130
    • Biżuteria etniczna i orientalna
  • VirtueMart Version: 3.8.9
After updating to Joomla 4.2.2 Error 500
« on: September 08, 2022, 23:37:34 pm »
After updating to  [J4.2.2]
in the admin panel, I cannot open (to edit) any payment and shipping methods.

The server reports error 500

Quote
500   GET /administrator/index.php?option=com_virtuemart&view=shipmentmethod&task=edit&cid[]=3 HTTP/1.0   
AH01071: Got error 'PHP message: PHP Fatal error: Maximum execution time of 90 seconds exceeded in /libraries/src/Form/Form.php on line 1399',
referer: /administrator/index.php?option=com_virtuemart&view=shipmentmethod            
Apache error #0: *2011096 upstream timed out (110: Connection timed out) while reading response header from upstream


I removed all plugins, components. I removed Virtuemart, cleaned the database of data. I have reinstalled virtuemart and still nothing...

niosme

  • Beginner
  • *
  • Posts: 19
  • Fullstack Developer and Joomla Expert
    • Easylogic
  • VirtueMart Version: Latest (4.0.6)
Re: After updating to Joomla 4.2.2 Error 500
« Reply #1 on: September 09, 2022, 09:36:35 am »
Your welcome!
Also you cant open custom fields!
There a lot more issues you cant even imagine! Restore your site in a previous backup , and praise if in a year or two this will be fixed with a lot of other issues.
You have to run in joomla 3 and not with the latest virtuemart also not with php 8.

The fatal errors are uncountable and turns virtuemart into a completly crap!

Also this is a duplicate ( https://forum.virtuemart.net/index.php?topic=148798.0 ). Problem already have posted with a lot of others if you check the forum!
Fullstack Developer and Joomla Expert

hazael

  • Jr. Member
  • **
  • Posts: 130
    • Biżuteria etniczna i orientalna
  • VirtueMart Version: 3.8.9
Re: After updating to Joomla 4.2.2 Error 500
« Reply #2 on: September 09, 2022, 10:12:15 am »
The problem is that this error shows up on all PHP versions (7.x, 8.0, 8.1).
With the previous version of Joomla 4.1 there was no problem with that...

All bugs are as if related to Joomla Libraries, which has changed after the update.

/libraries/src/Form/Form.php

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10305
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: After updating to Joomla 4.2.2 Error 500
« Reply #3 on: September 12, 2022, 20:33:30 pm »
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

hazael

  • Jr. Member
  • **
  • Posts: 130
    • Biżuteria etniczna i orientalna
  • VirtueMart Version: 3.8.9
Re: After updating to Joomla 4.2.2 Error 500
« Reply #4 on: September 12, 2022, 22:07:11 pm »
Thanks Milbo!
There is significant progress. It's getting better. I'm definitely closer to launching my new VM-shop with Joomla 4   ::)

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10305
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: After updating to Joomla 4.2.2 Error 500
« Reply #5 on: September 12, 2022, 22:42:55 pm »
The search is imho the last problem.

What a foo. Long time ago, I wrote it so, that vm encoded the strings to html entities. I removed that 1-2 years ago, because some people had trouble with imports.

now joomla changed the db handler (and it looks like for j3 also) that any query gets encoded. So they adapted my "stubborn" way for which I got so much negative response. But yes it is just a lot more secure.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

joomlabuff

  • Beginner
  • *
  • Posts: 3
  • A beginner
  • Skype Name: vijayfrocky
Re: After updating to Joomla 4.2.2 Error 500
« Reply #6 on: September 18, 2022, 11:40:12 am »
Thank you Hazael,
fixed with https://dev.virtuemart.net/attachments/1329/com_virtuemart.4.0.7.10701.zip

Am using Joomla 4.2.2 and VM 4.0.7 (which you provide in the link above.) after updating this package the issue is not solved. the same problem again when I try to edit the custom fields it does not allow me to do this. taking a long time end up with the error in joomla

/libraries/src/Form/Form.php:1394


jflash

  • 3rd party VirtueMart Developer
  • Jr. Member
  • *
  • Posts: 60
Re: After updating to Joomla 4.2.2 Error 500
« Reply #7 on: September 20, 2022, 12:24:59 pm »
Hi all! I have new webpage Joomla 4.2.2. with Virtuemart 4.0.7.10701 on PHP 8.1. If i want to create new custom field, i fill fields and after Saving it, webpage thinks wery long and ends with error 500:
Sorry, there was a problem we could not recover from. The server returned a "500 - Whoops, looks like something went wrong."

But it saves a record. If i now open this record, it also ends with error 500. I cant open and edit no one custom fields (related categories, related products, own made custom fields...) Only if i see in log file is:
fghjfghf.eu 2022-09-20T09:50:31.059781Z 193.40.60.232 8623 - - "GET /administrator/index.php?option=com_virtuemart&view=custom&task=edit&virtuemart_custom_id=4 HTTP/2.0" 500 18921
"https://fhfdfg.eu/administrator/index.php?option=com_virtuemart&view=custom" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:104.0) Gecko/20100101 Firefox/104.0" 30131273 (14F9CED0-30.130)


I changed PHP to 7.4 and there is all same...

hazael

  • Jr. Member
  • **
  • Posts: 130
    • Biżuteria etniczna i orientalna
  • VirtueMart Version: 3.8.9
Re: After updating to Joomla 4.2.2 Error 500
« Reply #8 on: September 20, 2022, 15:07:31 pm »
Because VM Virtuemart 4.0.7 is not a stable version It is even written: [RC]

Mike J

  • Jr. Member
  • **
  • Posts: 81
Re: After updating to Joomla 4.2.2 Error 500
« Reply #9 on: September 20, 2022, 22:51:50 pm »
Because VM Virtuemart 4.0.7 is not a stable version It is even written: [RC]

True, but also note, 4.0.6 (stable, compatible J4), 4.0.4 (stable, compatible J4) & 4.0.2 (stable, compatible J4) are not and never were stable, even though they are/were promoted as being so.
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

hazael

  • Jr. Member
  • **
  • Posts: 130
    • Biżuteria etniczna i orientalna
  • VirtueMart Version: 3.8.9
Re: After updating to Joomla 4.2.2 Error 500
« Reply #10 on: September 21, 2022, 14:41:19 pm »
Even a marital relationship with a woman can be STABLE, but never perfect...  ::)

Mike J

  • Jr. Member
  • **
  • Posts: 81
Re: After updating to Joomla 4.2.2 Error 500
« Reply #11 on: September 22, 2022, 01:25:13 am »
Even a marital relationship with a woman can be STABLE, but never perfect...  ::)

Dear Hazael,

Did you ever test 4.0.6 (stable, compatible J4), 4.0.4 (stable, compatible J4) & 4.0.2 (stable, compatible J4)?

Some of these issues are not just related to J4 either.

If you want to understand my perspective, feel free to read through a sample of my work (mostly helping others) from June on (don't just skim over them, read them to the end).

https://forum.virtuemart.net/index.php?topic=148686.msg530616#msg530616
https://forum.virtuemart.net/index.php?topic=148780.msg530876#msg530876
https://forum.virtuemart.net/index.php?topic=148669.msg530563#msg530563
https://forum.virtuemart.net/index.php?topic=148440.msg529486#msg529486
https://forum.virtuemart.net/index.php?topic=148403.0
https://forum.virtuemart.net/index.php?topic=148609.msg530754#msg530754 < Nice read.

If your definition of STABLE is that it doesn't crash but it's unable to take orders, then yes, it's STABLE. In my book STABLE means it can take live orders otherwise what's the point? Sure, it's a shingle in cyberspace but it can't produce revenue... But hey, at least it's STABLE???
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

niosme

  • Beginner
  • *
  • Posts: 19
  • Fullstack Developer and Joomla Expert
    • Easylogic
  • VirtueMart Version: Latest (4.0.6)
Re: After updating to Joomla 4.2.2 Error 500
« Reply #12 on: September 22, 2022, 08:08:26 am »
All the situation is tragic. Hazael stop acting like a clown.
We post here bugs and fixes and they never get fixed like those.

https://forum.virtuemart.net/index.php?topic=148808.0
https://forum.virtuemart.net/index.php?topic=148809.0

We want to help Milbo fix the component but he seems he have not the passion and strength to continue developing this project.
I started figuring out that developing a new open-source eshop with all virtuemart feautures for joomla is the solution. I am so close to start this project instead trying and dont know what problem i will face with this kinda abandoned component in each update.
Fullstack Developer and Joomla Expert

hazael

  • Jr. Member
  • **
  • Posts: 130
    • Biżuteria etniczna i orientalna
  • VirtueMart Version: 3.8.9
Re: After updating to Joomla 4.2.2 Error 500
« Reply #13 on: September 22, 2022, 10:29:59 am »
Did you ever test 4.0.6 (stable, compatible J4), 4.0.4 (stable, compatible J4) & 4.0.2 (stable, compatible J4)?
Yes, I have tested all VM versions starting on January 20, 2005. I create new pages regularly and update old ones. Currently I'm working with Joomla 3 and 4.
I have a private dedicated server where I test various PHP SQL system solutions etc. Until then, I regularly report critical Virtuemart bugs. When they are not repaired, I waiting patiently for a new, improved version or (if necessary) I solve the problem myself and I don't cry as much as some. I am not writing to anyone privately (like some): "request to fix my Virtuemart"[LOL]

Stable version (production version) - It is a utility version in accordance with the assumptions of the AUTHORS - not yours.
In case you do not understand - I gave an eloquent comparison about a stable marriage relationship. Unfortunately, you probably didn't understand that either.
The stable version is not suitable for everyone. For me, what is supposed to work - works. You can fix the rest yourself. If you don't know how, ask in the forum or hire an IT speshitpillt.
Or wait for someone to do something for you for free. I'm just begging you - don't complain..

All the situation is tragic. Hazael stop acting like a clown (...)
If you report your found bugs on other topic (than yours) to a forum set up by other user, no one will notice your problem.
The topic for this discussion is "After updating to Joomla 4.2.2 Error 500".
And you are writing about something completely different here. Later, someone will say that he has not found a solution on the forum and is assuming another topic about the same.

PS.
I think a professional bug reporting application would be a better solution than this forum.

niosme

  • Beginner
  • *
  • Posts: 19
  • Fullstack Developer and Joomla Expert
    • Easylogic
  • VirtueMart Version: Latest (4.0.6)
Re: After updating to Joomla 4.2.2 Error 500
« Reply #14 on: September 22, 2022, 11:45:08 am »
Ok then.
I give up with this.I will stop reporting bugs and fix them only for me. There's no reason to post here. Better develop my own version to get rid of this.
Virtuemart acting like this will lose all the users left.

Have a good luck and i hope you get it work in some years if a joomla update not happen again.
Fullstack Developer and Joomla Expert