Author Topic: vmError: Model Userfields, state with id Shipment not found  (Read 561 times)

iodurodisodio

  • Beginner
  • *
  • Posts: 1
  • A beginner
  • VirtueMart Version: 4.0.2 10661
I do not understand how to solve this error: "vmError: Model Userfields, state with id Shipment not found" I am notified when I open the details of an order received in my shop, but not for all orders for some it happens for others not. Does anyone know the reason or a possible solution?
Thanks Alan

Joomla! 3.10.10
VirtueMart 4.0.2 10661

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28324
  • Always on vacation
    • Jenkin Hill Internet
Re: vmError: Model Userfields, state with id Shipment not found
« Reply #1 on: July 05, 2022, 11:40:28 am »
As a guess, you may have a state which has a default entry of "shipment". Some users may overwrite this to select their correct state, others nay ignore it. Check the State shopper field details for a Default entry.
Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart  4.0.2 10661 on Joomla 3.10.9 PHP 7.4.29

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10283
  • VM3.9 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Re: vmError: Model Userfields, state with id Shipment not found
« Reply #2 on: July 06, 2022, 22:26:21 pm »
It tries to load a state with the "id" "shipment", but an id is always a number. I think it is some 3rd party plugin which creates this.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/