Author Topic: State drop down & "vmadmin - Default" template errors - Brand new install  (Read 1448 times)

Mike J

  • Jr. Member
  • **
  • Posts: 86
Hi guys,

Upon unleashing a fresh install of the latest versions: Joomla & VM 4, state drop down in the admin BE doesn't work and if I switch to the "vmadmin - Default" template, the layout breaks as also shown.

https://ibb.co/9wWpDxj

There's nothing else installed here. No templates or plugins just J! & VM bare.

My only thoughts are that I must have a server config problem.

Any ideas from someone who may have seen & rectified these probs?

Mike
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10638
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
not 100% sure VM4 is fully php8 ready...

re old template .. make sure your browser cache is cleared...
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Mike J

  • Jr. Member
  • **
  • Posts: 86
Hey, thanks for that.

I'll give PHP 7.4 a run tomorrow and see if that sorts it out.

Many thanks,

M

PS J! caching is off and I flush the FE consistently. "Vmadmin - Default"  is bundled with VM 4.0.2 so it can't be too old or maybe it is. ;D
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

Mike J

  • Jr. Member
  • **
  • Posts: 86
No go.

Just installed Joomla! and then Virtuemart (versions shown in signature) in an account running PHP 7.4.29.

The state drop down selector is still frozen in the Virtuemart back end. Jumped in from a different PC to make sure it wasn't local but same deal.

Any other ideas anyone? No one else seems to be experiencing this issue so it's a bit perplexing.

Looks like they've dropped the"Vmadmin - Default" template between VM 4.0.0.10645 and 4.0.2.10661 so that solves that one.

VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

Mike J

  • Jr. Member
  • **
  • Posts: 86
As an experiment I installed VirtueMart4.0.0_Joomla_3.10.8-Stable-Full_Package > PHP 7.4.29 account.

I chose the install VM sample data option.

This all worked great, however, after updating this site to J! 4, the drop down menu in VMs back end locked up again.
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10638
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
Have found the same sadly .. if u look at the source the State select is there .. but the chosen JS isn't rendering it

If you switch off "Use jQuery chosen for dropdowns in FE" the FE is usable - sadly not the admin unless u manually disable the chosen until this is fixed
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10638
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Mike J

  • Jr. Member
  • **
  • Posts: 86
Hey, nice to know GJC Web Design,

Thank you. I am not alone ;)

I even set up a new server thinking it must have been at my end after failing multiple > J! 4 upgrade attempts (rolled back from MariaDB and things like that).

Figured I must have had an incompatible plugin somewhere so decided to strip things back and add one by one... But this kept popping up…

As Jumbo points out in your link above, “The issue is created by the jQuery Chosen library being loaded by your template. If you switch to any other template, the problem will be resolved.”

I haven’t added any templates… The only stuff in my build is what comes in the VirtueMart4.0.0_Joomla_3.10.8-Stable-Full_Package.zip package and the admin state drop down breaks when I upgrade this install to J! 4. Same situation when launching fresh J! 4 builds.

Thankfully I have a backup and might hold at Joomla! 3.10.9 / VirtueMart 4.0.2 10661 for a while.

I only post once a year and you’re generally the guy who answers.

Many thanks and have a great one.
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10638
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.8.8
in my case using the stock templates no chosen is loaded except the native Joomla 4 one .. media/vendor/chosen/js/chosen.jquery.min.js?1.8.7

and as its FE and admin I think we can conclude it's a combination of J4/VM4

there are further problems that once u use that snippet ( which works if the ajax return is there) sometimes no ajax fetch is triggered for the states so u are stuck with the states from the previous country selected..
so the trigger needs looking at as well..
GJC Web Design
VirtueMart and Joomla Developers - php developers https://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
https://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

Mike J

  • Jr. Member
  • **
  • Posts: 86
Hey, thanks GJC Web Design,

I always find it tricky mucking around with that sort of stuff... But I certainly do appreciate your insight and expertise in getting to the bottom of it.

Just knowing that there is an issue has helped me a lot. I would have probably spent another day trying different things but thanks to you, I think I'll just sit it out a while.

I really do appreciate you looking into it. Thank you again.

Mike
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

Mike J

  • Jr. Member
  • **
  • Posts: 86
PS I got it working OK in the FE when checking out as a guest but when I tried logging in and checking out as an existing customer (to reorder), the system would break and throw errors that referenced Post Code and State after clicking "Place Order", even though I could select the state drop down and add the post code correctly in the FE. No such issues with Joomla! 3.10.9 Stable and VirtueMart 4.0.2 so will hold for now.
VirtueMart 4.0.2 10661
Joomla! ‎3.10.11
PHP 7.4.30
mysql 5.7.39

Milbo

  • Virtuemart Projectleader
  • Administrator
  • Super Hero
  • *
  • Posts: 10497
  • VM4.0.7 Eagle Owl
    • VM3 Extensions
  • VirtueMart Version: VirtueMart 3 on joomla 3
Sounds for me like a j4 bug. Or some "new great feature" which destroys our cart.
Should I fix your bug, please support the VirtueMart project and become a member
______________________________________
Extensions approved by the core team: http://extensions.virtuemart.net/

kolokotronis

  • Beginner
  • *
  • Posts: 14