Author Topic: Manufacturer SEF URL doesn't work properly (solved)  (Read 293 times)

mizu

  • Beginner
  • *
  • Posts: 28
Manufacturer SEF URL doesn't work properly (solved)
« on: November 07, 2021, 15:06:43 pm »
VM 3.8.9 10473
J 3.10.2


I created a category manufacturer in VM. Parameters set identically to other categories.
The products have the manufacturer field filled.
No product has been specifically assigned to the manufacturer category.

Open the site no SEF:
Using the manufacturer link in product detail (pop-up)

index.php?option=com_virtuemart&view=category&virtuemart_manufacturer_id=5&Itemid=128&lang=en

All correct, 3 products per row.

With SEF enabled:
http://website/en/component/virtuemart/manufacturer/xxx

Shows first all categories (with cat image) and finally the manufacturers. All in one row. Why?
Not what I expected.


When I change the URL manually to
http://website/en/manufacturer/xxx

all looks nice again, rows are back categories vanished.


I tried with creating a Joomla menu for the category first and then assigning products to the category. This works.
However, I want to use the manufacturer links from detail and category only.
And without SEF it works perfectly.

I did read http://forum.virtuemart.net/index.php?topic=136209.0 as well as related posts.
Nothing really helpful came up.

Thanks for reading.

mizu

  • Beginner
  • *
  • Posts: 28
Re: Manufacturer SEF URL doesn't work properly
« Reply #1 on: November 14, 2021, 04:22:28 am »
Hard to believe, but I actually solved this.
Since everything works without SEF I figured router.php would be a promising candidate to look at.

case 'manufacturer'
I commented out line 235
//else $query['Itemid'] = $jmenu['virtuemart'];

Done.

However, I'm still not entirely happy.
Instead of seeing manufacturer's products listed in a certain category, I'd rather see ALL products of a manufacturer on the page.

How to achieve that?