Author Topic: Error trying to upgrade plugins  (Read 462 times)

nineplanets

  • Beginner
  • *
  • Posts: 3
  • A beginner
Error trying to upgrade plugins
« on: October 16, 2021, 00:06:54 am »
I'm taking over maintenance on a site using Joomla with VirtueMart, which hasn't been kept up to date, and I'm trying to get things updated to start off with.  I was able to get Joomla and the VirtueMart core updated, but if I try to update any of the VirtueMart plugins via Joomla's updater, I get "invalid extension update" and if I try to upload the AIO plugin zip via the installer, I get "Class 'vDispatcher' not found" instead.  I tried some googling of the errors, but didn't have any luck.  Anyone have any idea what the problem might be based on those errors?  I'm on Joomla 3.10.2 if that makes a difference.

jenkinhill

  • UK Web Developer & Consultant
  • Global Moderator
  • Super Hero
  • *
  • Posts: 28224
  • Always on vacation
    • Jenkin Hill Internet
Re: Error trying to upgrade plugins
« Reply #1 on: October 16, 2021, 11:32:12 am »
The VM default plugins are installed/updated when the aio (All In One) package for the VirtueMart component is installed. If you check the list of packages on http://dev.virtuemart.net/projects/virtuemart/files  you can see the aio package listed under the related VM main component. Use Joomla's Install facility to upload each package (I find this more reliable than the updater)

Kelvyn

Jenkin Hill Internet,
Lowestoft, Suffolk, UK

Unsolicited PMs/emails will be ignored.

Please mention your VirtueMart, Joomla and PHP versions when asking a question in this forum

Currently using VirtueMart 3.8.9.10473 on Joomla 3.9.28 PHP 7.4.14

nineplanets

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Error trying to upgrade plugins
« Reply #2 on: October 18, 2021, 19:59:58 pm »
Trying to use the installer to upload the AIO package is what gives me the "Class 'vDispatcher' not found" error.

GJC Web Design

  • 3rd party VirtueMart Developer
  • Super Hero
  • *
  • Posts: 10300
  • Virtuemart, Joomla & php developer
    • GJC Web Design
  • VirtueMart Version: 3.6.8
Re: Error trying to upgrade plugins
« Reply #3 on: October 18, 2021, 22:12:33 pm »
If your VM is very old you may have to upgrade the AIO step by step with each major release
GJC Web Design
VirtueMart and Joomla Developers - php developers http://www.gjcwebdesign.com
VM3 AusPost Shipping Plugin - e-go Shipping Plugin - VM3 Postcode Shipping Plugin - Radius Shipping Plugin - VM3 NZ Post Shipping Plugin - AusPost Estimator
Samport Payment Plugin - EcomMerchant Payment Plugin - ccBill payment Plugin
VM2 Product Lock Extension - VM2 Preconfig Adresses Extension - TaxCloud USA Taxes Plugin - Virtuemart  Product Review Component
http://extensions.joomla.org/profile/profile/details/67210
Contact for any VirtueMart or Joomla development & customisation

nineplanets

  • Beginner
  • *
  • Posts: 3
  • A beginner
Re: Error trying to upgrade plugins
« Reply #4 on: October 19, 2021, 22:26:41 pm »
Thanks!  Installing the AIO from each major release did the trick.